Reply
Thread Tools
RogerS's Avatar
Posts: 772 | Thanked: 183 times | Joined on Jul 2005 @ Montclair, NJ (NYC suburbs)
#1
Nice post at wxBlog about Hildonizing wxGTK. Obviously, apps won't be as small as using GTK natively, but it should make some ports more likely.

Since XML Copy Editor, the open-source XML editor I am fanatic about, is built with wxWidgets, this might be a way to bring that fabulous app to the Nokia Internet Tablet.

I don't want to make the N8x0 my primary device, but being able to edit when I need to without lugging around the laptop is one of the NIT's selling points.

I'll post more about this as events develop with wxGTK.
Read the full article.
 

The Following 2 Users Say Thank You to RogerS For This Useful Post:
Posts: 245 | Thanked: 25 times | Joined on Apr 2007
#2
That'll be nice. I can think of several apps that I'd like that need wxGTK.
 
yerga's Avatar
Posts: 696 | Thanked: 1,008 times | Joined on Mar 2006 @ Asturies, Spain
#3
For 10¢, applications that need wxGTK: aMule

__________________
Daniel Martín Yerga
maemo.org profile
Twitter
 
Posts: 24 | Thanked: 1 time | Joined on Dec 2007
#4
Originally Posted by yerga View Post
For 10¢, applications that need wxGTK: aMule

Auch, running aMule on the Nokia
 
RogerS's Avatar
Posts: 772 | Thanked: 183 times | Joined on Jul 2005 @ Montclair, NJ (NYC suburbs)
#5
See Maemo Geek's test, maemogeek.blogspot.com/2007/12/wxgtk-working-on-maemo.html

__________________
N900 Guide Brief intro to the Nokia N900 (http://n900guide.com/)
Maemoan since July 2005 )
 

The Following User Says Thank You to RogerS For This Useful Post:
fpp's Avatar
Posts: 2,853 | Thanked: 954 times | Joined on Nov 2005
#6
Now we're going to need wxPython too :-)
 
Posts: 33 | Thanked: 13 times | Joined on Jan 2010
#7
Hi, everyone and happy new year!!!

I,ve been triying to compile WxWidgets (wxGTK) for maemo5/N900, following this link:

http://maemogeek.blogspot.com/2007/1...-on-maemo.html

So i open scratchbox and download wxWidgets trunk:

svn checkout http://svn.wxwidgets.org/svn/wx/wxWidgets/trunk

I renamed the folder to wxwidgets-2.9

I configured it this way:
--prefix=/opt/usr so it create its folders at /opt/usr/include/wx-2.9 /opt/usr/lib
--bindir=/usr/bin so it create wx-config wx wx-2.9 at /usr/bin/
--enable-compat26 to have retro compatibility with wxwidgets 2.6
--with-hildon to be able to use Hildon framework for Nokia 770/800/810 (and hopelly maemo5/N900)

So here is my configuration string:
./configure --prefix=/opt/usr --bindir=/usr/bin --with-hildon --enable-compat26

Here is the result:
Configured wxWidgets 2.9.2 for `arm-unknown-linux-gnu'

Which GUI toolkit should wxWidgets use? GTK+ 2 with support for GTK+ printing
Should wxWidgets be compiled into single library? no
Should wxWidgets be linked as a shared library? yes
Should wxWidgets support Unicode? yes (using UTF-8)
What level of wxWidgets compatibility should be enabled?
wxWidgets 2.6 yes
wxWidgets 2.8 yes
Which libraries should wxWidgets use?
STL no
jpeg sys
png sys
regex builtin
tiff sys
zlib sys
expat sys
libmspack no
sdl no



Its compiles without any problem
And it install aguain with no errors:

------------------------------------------------------

The installation of wxWidgets is finished. On certain
platforms (e.g. Linux) you'll now have to run ldconfig
if you installed a shared library and also modify the
LD_LIBRARY_PATH (or equivalent) environment variable.

wxWidgets comes with no guarantees and doesn't claim
to be suitable for any purpose.

Read the wxWindows Licence on licencing conditions.

------------------------------------------------------


It creates folders:
/opt/usr/include/wx-2.9
/opt/usr/lib/wx

And a bunch of libraries at: /opt/usr/lib/libwx_*
And 1 executable and to sympolic linfiles wx-config wx wx-2.9 at /usr/bin/
wxrc-2.9
wxrc -> wxrc-2.9
wx-config -> /opt/usr/lib/wx/config/gtk2-unicode-2.9

I create some simbolic links from /opt... to /usr...
ln -s /opt/usr/lib/* /usr/lib/
ln -s /opt/usr/include/wx-2.9 /usr/include/wx-2.9


So every thing seems to be ok, then i try to compile and run the example in the link.
g++ hworld.cpp `wx-config --libs` `wx-config --cxxflags` -o hworld

Compiles without problems, but when i try to run it i get:

[sbox-FREMANTLE_ARMEL: /usr/src] > run-standalone.sh ./hworld
/usr/bin/run-standalone.sh: line 2: qemu:: command not found
/usr/bin/run-standalone.sh: line 3: Cannot: command not found
04:46:10 pm: Error: Unable to initialize Hildon program


Could someone please tell me what im doing wrong?
Thanxs in advance

Last edited by pinoverclock; 2011-01-03 at 16:27.
 

The Following User Says Thank You to pinoverclock For This Useful Post:
Posts: 353 | Thanked: 427 times | Joined on Aug 2010
#8
Originally Posted by pinoverclock View Post
...
Which GUI toolkit should wxWidgets use? GTK+ 2 with support for GTK+ printing
If this can help establish a printing dialogue count me in.
I have cups working now just need applications that can print

thanks
__________________
Three n900s: One for stable working platform,
One for development testing Chopping Onions
One for saltwater immersion power testing resurrected ! parts scavenging

My Mods for Wonko's Advanced Clock Plugin:
ISO8601 clock mod and Momental_IST clock mod

Printing your Email with the N900
 
Reply

Thread Tools

 
Forum Jump


All times are GMT. The time now is 13:20.