Notices


Reply
Thread Tools
xxxxts's Avatar
Posts: 491 | Thanked: 341 times | Joined on Nov 2009 @ LA
#11
Not cool man...

apt-get install bluemaemo
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
bluemaemo: Depends: efl-core but it is not going to be installed
Depends: python2.5-efl-core but it is not going to be installed
Depends: python2.5-ecore but it is not going to be installed
Depends: python2.5-evas but it is not going to be installed
Depends: python2.5-edje but it is not going to be installed
Depends: python2.5-elementary but it is not going to be installed
E: Broken packages
 
Posts: 3,617 | Thanked: 2,410 times | Joined on Nov 2009 @ Cambridge, UK
#12
You'll need to reinstall libeina0 first - that should uninstall any of the conflicting packages and allow reinstallation of bluemaemo.
 
xxxxts's Avatar
Posts: 491 | Thanked: 341 times | Joined on Nov 2009 @ LA
#13
Originally Posted by Rob1n View Post
You'll need to reinstall libeina0 first - that should uninstall any of the conflicting packages and allow reinstallation of bluemaemo.
No go... I tired that already...

# apt-get install libeina0
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following NEW packages will be installed:
libeina0
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 41.8kB of archives.
After this operation, 156kB of additional disk space will be used.
Get:1 http://repository.maemo.org fremantle/free libeina0 0.0.2.062+svn41533-maemo1 [41.8kB]
Fetched 41.8kB in 0s (162kB/s)
Selecting previously deselected package libeina0.
(Reading database ... 42503 files and directories currently installed.)
Unpacking libeina0 (from .../libeina0_0.0.2.062+svn41533-maemo1_armel.deb) ...
Setting up libeina0 (0.0.2.062+svn41533-maemo1) ...
# apt-get install bluemaemo
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
bluemaemo: Depends: efl-core but it is not going to be installed
Depends: python2.5-efl-core but it is not going to be installed
Depends: python2.5-ecore but it is not going to be installed
Depends: python2.5-evas but it is not going to be installed
Depends: python2.5-edje but it is not going to be installed
Depends: python2.5-elementary but it is not going to be installed
E: Broken packages
#
 
Posts: 3,617 | Thanked: 2,410 times | Joined on Nov 2009 @ Cambridge, UK
#14
Originally Posted by xxxxts View Post
No go... I tired that already...
In that case, the only thing to do is keep adding the dependencies to the install command until it works:
Code:
apt-get install bluemaemo efl-core python2.5-efl-core python2.5-ecore python2.5-evas python2.5-edjepython2.5-elementary
 
xxxxts's Avatar
Posts: 491 | Thanked: 341 times | Joined on Nov 2009 @ LA
#15
Originally Posted by Rob1n View Post
In that case, the only thing to do is keep adding the dependencies to the install command until it works:
Code:
apt-get install bluemaemo efl-core python2.5-efl-core python2.5-ecore python2.5-evas python2.5-edjepython2.5-elementary
No go;

Code:
apt-get install bluemaemo efl-core python2.5-efl-core py                                                                                                                                                             thon2.5-ecore python2.5-evas python2.5-edje python2.5-elementary
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
  bluemaemo: Depends: python2.5-edbus but it is not going to be installed
             Depends: python-configobj but it is not going to be installed
  efl-core: Depends: libeet1 (>= 1.2.2+svn41533-maemo1) but it is not going to b                                                                                                                                                             e installed
            Depends: libevas0 (>= 0.9.9.062+svn41533-maemo1) but it is not going                                                                                                                                                              to be installed
            Depends: libevas0-all (>= 0.9.9.062+svn41533-maemo1) but it is not g                                                                                                                                                             oing to be installed
            Depends: libecore0 (>= 0.9.9.062+svn41533-maemo1) but it is not goin                                                                                                                                                             g to be installed
            Depends: libecore0-all (>= 0.9.9.062+svn41533-maemo1) but it is not                                                                                                                                                              going to be installed
            Depends: libembryo0 (>= 0.9.9.062+svn41533-maemo1) but it is not goi                                                                                                                                                             ng to be installed
            Depends: libedje0 (>= 0.9.92.062+svn41533-maemo1) but it is not goin                                                                                                                                                             g to be installed
            Depends: libepsilon0 (>= 0.3.0.012+svn41533-maemo1) but it is not go                                                                                                                                                             ing to be installed
            Depends: libetk0 (>= 0.1.0.042+svn41533-maemo1) but it is not going                                                                                                                                                              to be installed
            Depends: libetk0-engine-all (>= 0.1.0.042+svn41533-maemo1) but it is                                                                                                                                                              not going to be installed
            Depends: libedbus0 (>= 0.5.0.062+svn41533-maemo1) but it is not goin                                                                                                                                                             g to be installed
  python2.5-ecore: Depends: libecore0 but it is not going to be installed
                   Depends: libecore0-evas but it is not going to be installed
                   Depends: libecore0-imf but it is not going to be installed
                   Depends: libecore0-input but it is not going to be installed
                   Depends: libecore0-txt but it is not going to be installed
                   Depends: libecore0-x but it is not going to be installed
                   Depends: libevas0 but it is not going to be installed
                   Depends: libecore0 (>= 0.9.9.062+svn41533-maemo1) but it is n                                                                                                                                                             ot going to be installed
                   Depends: libecore0-all (>= 0.9.9.062+svn41533-maemo1) but it                                                                                                                                                              is not going to be installed
  python2.5-edje: Depends: libecore0 but it is not going to be installed
                  Depends: libecore0-imf but it is not going to be installed
                  Depends: libecore0-imf-evas but it is not going to be installe                                                                                                                                                             d
                  Depends: libecore0-job but it is not going to be installed
                  Depends: libedje0 but it is not going to be installed
                  Depends: libeet1 but it is not going to be installed
                  Depends: libembryo0 but it is not going to be installed
                  Depends: libevas0 but it is not going to be installed
  python2.5-efl-core: Depends: python2.5-epsilon (>= 0.3.1+svn41533-maemo1) but                                                                                                                                                              it is not going to be installed
                      Depends: python2.5-etk (>= 0.1.2+svn41533-maemo1) but it i                                                                                                                                                             s not going to be installed
                      Depends: python2.5-efl-utils (>= 0.1.4+svn41533-maemo1) bu                                                                                                                                                             t it is not going to be installed
                      Depends: python2.5-dbus-ecore (>= 0.71-1osso10) but it is                                                                                                                                                              not installable or
                               python2.5-edbus (>= 0.3.1+svn41533-maemo1) but it                                                                                                                                                              is not going to be installed
  python2.5-elementary: Depends: libecore0 but it is not going to be installed
                        Depends: libecore0-con but it is not going to be install                                                                                                                                                             ed
                        Depends: libecore0-evas but it is not going to be instal                                                                                                                                                             led
                        Depends: libecore0-file but it is not going to be instal                                                                                                                                                             led
                        Depends: libecore0-imf but it is not going to be install                                                                                                                                                             ed
                        Depends: libecore0-imf-evas but it is not going to be in                                                                                                                                                             stalled
                        Depends: libecore0-input but it is not going to be insta                                                                                                                                                             lled
                        Depends: libecore0-job but it is not going to be install                                                                                                                                                             ed
                        Depends: libecore0-txt but it is not going to be install                                                                                                                                                             ed
                        Depends: libecore0-x but it is not going to be installed
                        Depends: libedje0 but it is not going to be installed
                        Depends: libeet1 but it is not going to be installed
                        Depends: libelementary0 but it is not going to be instal                                                                                                                                                             led
                        Depends: libembryo0 but it is not going to be installed
                        Depends: libevas0 but it is not going to be installed
                        Depends: libelementary0 (>= 0.5.1.0+svn41533-maemo1) but                                                                                                                                                              it is not going to be installed
  python2.5-evas: Depends: libevas0 but it is not going to be installed
                  Depends: libevas0 (>= 0.9.9.062+svn41533-maemo1) but it is not                                                                                                                                                              going to be installed
                  Depends: libevas0-all (>= 0.9.9.062+svn41533-maemo1) but it is                                                                                                                                                              not going to be installed
  uboot-power: Depends: kernel-power-modules (= 2.6.28-maemo46) but 2.6.28-maemo                                                                                                                                                             46-wl1 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a s                                                                                                                                                             olution).
 
Posts: 3,617 | Thanked: 2,410 times | Joined on Nov 2009 @ Cambridge, UK
#16
Originally Posted by xxxxts View Post
No go
That's why I said you're going to have to keep adding them - each time it'll report more dependencies that aren't being installed, so you'll need to add them all onto the install command and run it again (you may even need to force specific versions, but hopefully not). Eventually it'll work.
 
Posts: 161 | Thanked: 70 times | Joined on Feb 2010
#17
Originally Posted by xxxxts View Post
No go;

Code:
apt-get install bluemaemo efl-core python2.5-efl-core py                                                                                                                                                             thon2.5-ecore python2.5-evas python2.5-edje python2.5-elementary
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
  bluemaemo: Depends: python2.5-edbus but it is not going to be installed
             Depends: python-configobj but it is not going to be installed
  efl-core: Depends: libeet1 (>= 1.2.2+svn41533-maemo1) but it is not going to b                                                                                                                                                             e installed
            Depends: libevas0 (>= 0.9.9.062+svn41533-maemo1) but it is not going                                                                                                                                                              to be installed
            Depends: libevas0-all (>= 0.9.9.062+svn41533-maemo1) but it is not g                                                                                                                                                             oing to be installed
            Depends: libecore0 (>= 0.9.9.062+svn41533-maemo1) but it is not goin                                                                                                                                                             g to be installed
            Depends: libecore0-all (>= 0.9.9.062+svn41533-maemo1) but it is not                                                                                                                                                              going to be installed
            Depends: libembryo0 (>= 0.9.9.062+svn41533-maemo1) but it is not goi                                                                                                                                                             ng to be installed
            Depends: libedje0 (>= 0.9.92.062+svn41533-maemo1) but it is not goin                                                                                                                                                             g to be installed
            Depends: libepsilon0 (>= 0.3.0.012+svn41533-maemo1) but it is not go                                                                                                                                                             ing to be installed
            Depends: libetk0 (>= 0.1.0.042+svn41533-maemo1) but it is not going                                                                                                                                                              to be installed
            Depends: libetk0-engine-all (>= 0.1.0.042+svn41533-maemo1) but it is                                                                                                                                                              not going to be installed
            Depends: libedbus0 (>= 0.5.0.062+svn41533-maemo1) but it is not goin                                                                                                                                                             g to be installed
  python2.5-ecore: Depends: libecore0 but it is not going to be installed
                   Depends: libecore0-evas but it is not going to be installed
                   Depends: libecore0-imf but it is not going to be installed
                   Depends: libecore0-input but it is not going to be installed
                   Depends: libecore0-txt but it is not going to be installed
                   Depends: libecore0-x but it is not going to be installed
                   Depends: libevas0 but it is not going to be installed
                   Depends: libecore0 (>= 0.9.9.062+svn41533-maemo1) but it is n                                                                                                                                                             ot going to be installed
                   Depends: libecore0-all (>= 0.9.9.062+svn41533-maemo1) but it                                                                                                                                                              is not going to be installed
  python2.5-edje: Depends: libecore0 but it is not going to be installed
                  Depends: libecore0-imf but it is not going to be installed
                  Depends: libecore0-imf-evas but it is not going to be installe                                                                                                                                                             d
                  Depends: libecore0-job but it is not going to be installed
                  Depends: libedje0 but it is not going to be installed
                  Depends: libeet1 but it is not going to be installed
                  Depends: libembryo0 but it is not going to be installed
                  Depends: libevas0 but it is not going to be installed
  python2.5-efl-core: Depends: python2.5-epsilon (>= 0.3.1+svn41533-maemo1) but                                                                                                                                                              it is not going to be installed
                      Depends: python2.5-etk (>= 0.1.2+svn41533-maemo1) but it i                                                                                                                                                             s not going to be installed
                      Depends: python2.5-efl-utils (>= 0.1.4+svn41533-maemo1) bu                                                                                                                                                             t it is not going to be installed
                      Depends: python2.5-dbus-ecore (>= 0.71-1osso10) but it is                                                                                                                                                              not installable or
                               python2.5-edbus (>= 0.3.1+svn41533-maemo1) but it                                                                                                                                                              is not going to be installed
  python2.5-elementary: Depends: libecore0 but it is not going to be installed
                        Depends: libecore0-con but it is not going to be install                                                                                                                                                             ed
                        Depends: libecore0-evas but it is not going to be instal                                                                                                                                                             led
                        Depends: libecore0-file but it is not going to be instal                                                                                                                                                             led
                        Depends: libecore0-imf but it is not going to be install                                                                                                                                                             ed
                        Depends: libecore0-imf-evas but it is not going to be in                                                                                                                                                             stalled
                        Depends: libecore0-input but it is not going to be insta                                                                                                                                                             lled
                        Depends: libecore0-job but it is not going to be install                                                                                                                                                             ed
                        Depends: libecore0-txt but it is not going to be install                                                                                                                                                             ed
                        Depends: libecore0-x but it is not going to be installed
                        Depends: libedje0 but it is not going to be installed
                        Depends: libeet1 but it is not going to be installed
                        Depends: libelementary0 but it is not going to be instal                                                                                                                                                             led
                        Depends: libembryo0 but it is not going to be installed
                        Depends: libevas0 but it is not going to be installed
                        Depends: libelementary0 (>= 0.5.1.0+svn41533-maemo1) but                                                                                                                                                              it is not going to be installed
  python2.5-evas: Depends: libevas0 but it is not going to be installed
                  Depends: libevas0 (>= 0.9.9.062+svn41533-maemo1) but it is not                                                                                                                                                              going to be installed
                  Depends: libevas0-all (>= 0.9.9.062+svn41533-maemo1) but it is                                                                                                                                                              not going to be installed
  uboot-power: Depends: kernel-power-modules (= 2.6.28-maemo46) but 2.6.28-maemo                                                                                                                                                             46-wl1 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a s                                                                                                                                                             olution).
I can confirm that this is working. Tried manual installation of each packet from a .deb .downloaded it before that. Tried manual installation of older packets, tried apt-get -f install and nothing works, but am not sure which caused the problem, tried libeina0 and libeina1 and still cannot install bluemaemo.
 
xxxxts's Avatar
Posts: 491 | Thanked: 341 times | Joined on Nov 2009 @ LA
#18
Originally Posted by Rob1n View Post
That's why I said you're going to have to keep adding them - each time it'll report more dependencies that aren't being installed, so you'll need to add them all onto the install command and run it again (you may even need to force specific versions, but hopefully not). Eventually it'll work.
I am up to here:

Code:
apt-get install bluemaemo efl-core python2.5-efl-core python2.5-ecore python2.5-evas python2.5-edje python2.5-elementary libeet1 libevas0 libevas0-all libecore0 libecore0-all libembryo0 libedje0 libepsilon0 libetk0 libetk0-engine-all libedbus0 python2.5-edbus python-configobj libecore0-con libecore0-evas libecore0-file libecore0-job libecore0-txt libecore0-x libecore0-ipc libecore0-imf libecore0-imf-evas libecore0-input libevas0-engine-software-x11 libevas0-engine-software-x11-16 libetk0-engine-all libetk0-engine-evas-x11 libetk0-engine-evas libetk0-engine-evas-software-x11 libetk0-engine-evas-software-x11-16 libevas0-all libevas0-loaders-all libevas0-savers-all libevas0-engines-all python2.5-efl-core python2.5-epsilon python2.5-etk python2.5-efl-utils python2.5-elementary libelementary0 libevas0-loader-eet libeina1 libevas0-engine-software-generic libevas0-engine-buffer libevas0-engine-software-generic libevas0-loader-eet libevas0-loader-jpeg libevas0-loader-png libevas0-saver-eet libevas0-saver-jpeg libevas0-saver-png
It simply won't fit.
 
xxxxts's Avatar
Posts: 491 | Thanked: 341 times | Joined on Nov 2009 @ LA
#19
And no love;

Code:
# apt-get install bluemaemo efl-core python2.5-efl-core python2.5-ecore python2.5-evas python2.5-edje python2.5-elementary libeet1 libevas0 libevas0-all libecore0 libecore0-all libembryo0 libedje0 libepsilon0 libetk0 libetk0-engine-all libedbus0 python2.5-edbus python-configobj libecore0-con libecore0-evas libecore0-file libecore0-job libecore0-txt libecore0-x libecore0-ipc libecore0-imf libecore0-imf-evas libecore0-input libevas0-engine-software-x11 libevas0-engine-software-x11-16 libetk0-engine-all libetk0-engine-evas-x11 libetk0-engine-evas libetk0-engine-evas-software-x11 libetk0-engine-evas-software-x11-16 libevas0-all libevas0-loaders-all libevas0-savers-all libevas0-engines-all python2.5-efl-core python2.5-epsilon python2.5-etk python2.5-efl-utils python2.5-elementary libelementary0 libevas0-loader-eet  libevas0-engine-software-generic libevas0-engine-buffer libevas0-engine-software-generic libevas0-loader-eet libevas0-loader-jpeg libevas0-loader-png libevas0-saver-eet libevas0-saver-jpeg
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  libeet1: Depends: libeina1 (>= 1.0.0~beta) but it is not going to be installed
E: Broken packages
 
leetut's Avatar
Posts: 1,169 | Thanked: 1,174 times | Joined on Jan 2010 @ sunderland
#20
i once had major problems with libeina0
was trying to install canola2 but it always failed with the libeina0 problem
i worked out it was because i had previously installed and removed another media player type app, cant remember its name
i tried all the suggestions at the time and none of them fixed the problem
flashing the device was the only way to fix it
__________________
born to rage against them
 
Reply

Thread Tools

 
Forum Jump


All times are GMT. The time now is 17:30.