Reply
Thread Tools
Posts: 6 | Thanked: 0 times | Joined on Jul 2010
#1
Hi Community,
My /home/user/MyDocs is no more! What could have happened?
I had a ton of data in there.
I haven't deleted anything, I haven't changed any mount points,
I recently had a look at my lock code and soon changed it, thats all
the changes I've done , apart from taking a few more pictures.
I first noticed the absurdity when I couldn't scroll up my pics more
than 1 page.
Whatever data / directories I had is also missing in /home/user/MyDocs
It resembles what it looked like when I first bought the phone:-
Let me show you the listing:-
Nokia-N900-51-1:/home/user/MyDocs# cd /home/user/MyDocs/
Nokia-N900-51-1:/home/user/MyDocs# ls -l
drwxrwxrwx 2 user root 16384 May 2 14:24 DCIM
Nokia-N900-51-1:/home/user/MyDocs# ls -la
drwxrwxrwx 7 user root 16384 Jan 1 1970 .
drwxr-xr-x 64 user users 4096 Mar 9 12:22 ..
drwxrwxrwx 2 user root 16384 Apr 29 16:04 .documents
drwxrwxrwx 2 user root 16384 Apr 29 16:04 .images
drwxrwxrwx 2 user root 16384 Apr 29 16:04 .sounds
drwxrwxrwx 2 user root 16384 Apr 29 16:04 .videos
drwxrwxrwx 2 user root 16384 May 2 14:24 DCIM
Nokia-N900-51-1:/home/user/MyDocs# ls -l DCIM/
-rw-r--r-- 1 user root 2111310 May 1 18:17 20110501_001.jpg
-rw-r--r-- 1 user root 2110910 May 1 18:19 20110501_002.jpg
-rw-r--r-- 1 user root 2050658 May 1 18:20 20110501_003.jpg
-rw-r--r-- 1 user root 1512658 May 1 20:27 20110501_004.jpg
-rw-r--r-- 1 user root 1034694 May 1 20:32 20110501_005.jpg
-rw-r--r-- 1 user root 958746 May 1 20:38 20110501_006.jpg
-rw-r--r-- 1 user root 881954 May 1 20:38 20110501_008.jpg
-rw-r--r-- 1 user root 842630 May 1 20:42 20110501_009.jpg
-rw-r--r-- 1 user root 859714 May 1 20:42 20110501_010.jpg
-rw-r--r-- 1 user root 869730 May 1 20:43 20110501_014.jpg
-rw-r--r-- 1 user root 872338 May 1 20:43 20110501_015.jpg
-rw-r--r-- 1 user root 1107958 May 1 21:20 20110501_016.jpg
-rw-r--r-- 1 user root 1795518 May 1 23:16 20110501_017.jpg
-rw-r--r-- 1 user root 996114 May 2 06:29 20110502_001.jpg
-rw-r--r-- 1 user root 823174 May 2 12:26 20110502_002.jpg
-rw-r--r-- 1 user root 2062434 May 2 14:06 20110502_003.jpg
-rw-r--r-- 1 user root 805594 May 2 14:24 20110502_004.jpg
Nokia-N900-51-1:/home/user/MyDocs# df
Filesystem 1k-blocks Used Available Use% Mounted on
rootfs 233344 151644 77420 66% /
ubi0:rootfs 233344 151644 77420 66% /
tmpfs 1024 68 956 7% /tmp
tmpfs 256 76 180 30% /var/run
none 10240 72 10168 1% /dev
tmpfs 65536 4 65532 0% /dev/shm
/dev/mmcblk0p2 2064208 361804 1597548 18% /home
/home/opt 2064208 361804 1597548 18% /opt
/dev/mmcblk0p1 28301808 21424 28280384 0% /home/user/MyDocs

PS I've noticed other wierdities before with the N900 - not worth
mentioning but this above is definitely worth finding out what
could have happened.?

Repeat, I have not rm'ed or deleted any thing using command line
or GUI. This is just too strange. Please anyone, do you have any
pointers please?
thanks very much,
d

PS: /home/user/MyDocs is a vfat FS
I was thinking of using testdisk or something like that to resolve
the partition but I've not tried anything yet as I'd rather know
whats going on first. Thanks...
 
Posts: 6 | Thanked: 0 times | Joined on Jul 2010
#2
Hi sat2050
I'll try out your suggestion.
Also trying out if I can reply to myself...cause you said you didn't
have perms.
d

Originally Posted by dmed View Post
Hi Community,
My /home/user/MyDocs is no more! What could have happened?
I had a ton of data in there.
I haven't deleted anything, I haven't changed any mount points,
I recently had a look at my lock code and soon changed it, thats all
the changes I've done , apart from taking a few more pictures.
I first noticed the absurdity when I couldn't scroll up my pics more
than 1 page.
Whatever data / directories I had is also missing in /home/user/MyDocs
It resembles what it looked like when I first bought the phone:-
Let me show you the listing:-
Nokia-N900-51-1:/home/user/MyDocs# cd /home/user/MyDocs/
Nokia-N900-51-1:/home/user/MyDocs# ls -l
drwxrwxrwx 2 user root 16384 May 2 14:24 DCIM
Nokia-N900-51-1:/home/user/MyDocs# ls -la
drwxrwxrwx 7 user root 16384 Jan 1 1970 .
drwxr-xr-x 64 user users 4096 Mar 9 12:22 ..
drwxrwxrwx 2 user root 16384 Apr 29 16:04 .documents
drwxrwxrwx 2 user root 16384 Apr 29 16:04 .images
drwxrwxrwx 2 user root 16384 Apr 29 16:04 .sounds
drwxrwxrwx 2 user root 16384 Apr 29 16:04 .videos
drwxrwxrwx 2 user root 16384 May 2 14:24 DCIM
Nokia-N900-51-1:/home/user/MyDocs# ls -l DCIM/
-rw-r--r-- 1 user root 2111310 May 1 18:17 20110501_001.jpg
-rw-r--r-- 1 user root 2110910 May 1 18:19 20110501_002.jpg
-rw-r--r-- 1 user root 2050658 May 1 18:20 20110501_003.jpg
-rw-r--r-- 1 user root 1512658 May 1 20:27 20110501_004.jpg
-rw-r--r-- 1 user root 1034694 May 1 20:32 20110501_005.jpg
-rw-r--r-- 1 user root 958746 May 1 20:38 20110501_006.jpg
-rw-r--r-- 1 user root 881954 May 1 20:38 20110501_008.jpg
-rw-r--r-- 1 user root 842630 May 1 20:42 20110501_009.jpg
-rw-r--r-- 1 user root 859714 May 1 20:42 20110501_010.jpg
-rw-r--r-- 1 user root 869730 May 1 20:43 20110501_014.jpg
-rw-r--r-- 1 user root 872338 May 1 20:43 20110501_015.jpg
-rw-r--r-- 1 user root 1107958 May 1 21:20 20110501_016.jpg
-rw-r--r-- 1 user root 1795518 May 1 23:16 20110501_017.jpg
-rw-r--r-- 1 user root 996114 May 2 06:29 20110502_001.jpg
-rw-r--r-- 1 user root 823174 May 2 12:26 20110502_002.jpg
-rw-r--r-- 1 user root 2062434 May 2 14:06 20110502_003.jpg
-rw-r--r-- 1 user root 805594 May 2 14:24 20110502_004.jpg
Nokia-N900-51-1:/home/user/MyDocs# df
Filesystem 1k-blocks Used Available Use% Mounted on
rootfs 233344 151644 77420 66% /
ubi0:rootfs 233344 151644 77420 66% /
tmpfs 1024 68 956 7% /tmp
tmpfs 256 76 180 30% /var/run
none 10240 72 10168 1% /dev
tmpfs 65536 4 65532 0% /dev/shm
/dev/mmcblk0p2 2064208 361804 1597548 18% /home
/home/opt 2064208 361804 1597548 18% /opt
/dev/mmcblk0p1 28301808 21424 28280384 0% /home/user/MyDocs

PS I've noticed other wierdities before with the N900 - not worth
mentioning but this above is definitely worth finding out what
could have happened.?

Repeat, I have not rm'ed or deleted any thing using command line
or GUI. This is just too strange. Please anyone, do you have any
pointers please?
thanks very much,
d

PS: /home/user/MyDocs is a vfat FS
I was thinking of using testdisk or something like that to resolve
the partition but I've not tried anything yet as I'd rather know
whats going on first. Thanks...
 
Posts: 6 | Thanked: 0 times | Joined on Jul 2010
#3
Hi sat2050
I connected it via mass storage drive to a windows XP
virtual host that I run in linux.
It still shows me the few new files only.

mount -a keeps mount /home/opt time and again.
I have this output so you can understand
Nokia-N900-51-1:/# mount -a
mount: mounting rootfs on / failed: Invalid argument
Nokia-N900-51-1:/# df
Filesystem 1k-blocks Used Available Use% Mounted on
rootfs 233344 151556 77508 66% /
ubi0:rootfs 233344 151556 77508 66% /
tmpfs 1024 68 956 7% /tmp
tmpfs 256 76 180 30% /var/run
none 10240 72 10168 1% /dev
tmpfs 65536 4 65532 0% /dev/shm
/dev/mmcblk0p2 2064208 361820 1597532 18% /home
/home/opt 2064208 361820 1597532 18% /opt
/home/opt 2064208 361820 1597532 18% /opt
/dev/mmcblk0p1 28301808 21424 28280384 0% /home/user/MyDocs
/home/opt 2064208 361820 1597532 18% /opt
/home/opt 2064208 361820 1597532 18% /opt
/home/opt 2064208 361820 1597532 18% /opt
Nokia-N900-51-1:/# mount -a
mount: mounting rootfs on / failed: Invalid argument
Nokia-N900-51-1:/# df -h
Filesystem Size Used Available Use% Mounted on
rootfs 227.9M 148.0M 75.7M 66% /
ubi0:rootfs 227.9M 148.0M 75.7M 66% /
tmpfs 1.0M 68.0k 956.0k 7% /tmp
tmpfs 256.0k 76.0k 180.0k 30% /var/run
none 10.0M 72.0k 9.9M 1% /dev
tmpfs 64.0M 4.0k 64.0M 0% /dev/shm
/dev/mmcblk0p2 2.0G 353.3M 1.5G 18% /home
/home/opt 2.0G 353.3M 1.5G 18% /opt
/home/opt 2.0G 353.3M 1.5G 18% /opt
/dev/mmcblk0p1 27.0G 20.9M 27.0G 0% /home/user/MyDocs
/home/opt 2.0G 353.3M 1.5G 18% /opt
/home/opt 2.0G 353.3M 1.5G 18% /opt
/home/opt 2.0G 353.3M 1.5G 18% /opt
/home/opt 2.0G 353.3M 1.5G 18% /opt
Nokia-N900-51-1:/#

I tried umounting /home/user/MyDocs and remounting it
even tried a reboot, and on remounting it using
mount /dev/mmcblk0p1 it still shows the few new files
pics i created since may 1st only. It looks like somehow
the data has all been reset since May 1.
I tried also a fsck.vfat /dev/mmcblk0p1 which didn't
change anything....

Originally Posted by dmed View Post
Hi sat2050
I'll try out your suggestion.
Also trying out if I can reply to myself...cause you said you didn't
have perms.
d
 
Posts: 6 | Thanked: 0 times | Joined on Jul 2010
#4
also,
all this while i.e before may 1, whenever i used to connect using
the usb to my linux box i'd get an entry in my df that said my
nokia was mounted as
/media/Nokia N900
now its showing /media/disk
how'd that happen?

again, i've not deleted or changed anything at all apart from
changing my default lock code.
-d

Originally Posted by dmed View Post
Hi sat2050
I connected it via mass storage drive to a windows XP
virtual host that I run in linux.
It still shows me the few new files only.

mount -a keeps mount /home/opt time and again.
I have this output so you can understand
Nokia-N900-51-1:/# mount -a
mount: mounting rootfs on / failed: Invalid argument
Nokia-N900-51-1:/# df
Filesystem 1k-blocks Used Available Use% Mounted on
rootfs 233344 151556 77508 66% /
ubi0:rootfs 233344 151556 77508 66% /
tmpfs 1024 68 956 7% /tmp
tmpfs 256 76 180 30% /var/run
none 10240 72 10168 1% /dev
tmpfs 65536 4 65532 0% /dev/shm
/dev/mmcblk0p2 2064208 361820 1597532 18% /home
/home/opt 2064208 361820 1597532 18% /opt
/home/opt 2064208 361820 1597532 18% /opt
/dev/mmcblk0p1 28301808 21424 28280384 0% /home/user/MyDocs
/home/opt 2064208 361820 1597532 18% /opt
/home/opt 2064208 361820 1597532 18% /opt
/home/opt 2064208 361820 1597532 18% /opt
Nokia-N900-51-1:/# mount -a
mount: mounting rootfs on / failed: Invalid argument
Nokia-N900-51-1:/# df -h
Filesystem Size Used Available Use% Mounted on
rootfs 227.9M 148.0M 75.7M 66% /
ubi0:rootfs 227.9M 148.0M 75.7M 66% /
tmpfs 1.0M 68.0k 956.0k 7% /tmp
tmpfs 256.0k 76.0k 180.0k 30% /var/run
none 10.0M 72.0k 9.9M 1% /dev
tmpfs 64.0M 4.0k 64.0M 0% /dev/shm
/dev/mmcblk0p2 2.0G 353.3M 1.5G 18% /home
/home/opt 2.0G 353.3M 1.5G 18% /opt
/home/opt 2.0G 353.3M 1.5G 18% /opt
/dev/mmcblk0p1 27.0G 20.9M 27.0G 0% /home/user/MyDocs
/home/opt 2.0G 353.3M 1.5G 18% /opt
/home/opt 2.0G 353.3M 1.5G 18% /opt
/home/opt 2.0G 353.3M 1.5G 18% /opt
/home/opt 2.0G 353.3M 1.5G 18% /opt
Nokia-N900-51-1:/#

I tried umounting /home/user/MyDocs and remounting it
even tried a reboot, and on remounting it using
mount /dev/mmcblk0p1 it still shows the few new files
pics i created since may 1st only. It looks like somehow
the data has all been reset since May 1.
I tried also a fsck.vfat /dev/mmcblk0p1 which didn't
change anything....
 
Reply

Thread Tools

 
Forum Jump


All times are GMT. The time now is 22:40.