Notices


Reply
Thread Tools
Posts: 698 | Thanked: 2,014 times | Joined on Jan 2011 @ Germany
#3261
I see you have mixed glibc packages (notice the deb8u4/deb8u6 in your output!).
Where are the deb8u6 packages from? If they are from the official Debian repo then I'd be puzzled that your ED works at all.

Originally Posted by Malakai View Post
Should I install the archive you provided with dpkg -i?
The archive contains Debian packages. Please try to install these packages with dpkg -i !
The easiest way would be to unpack the archive to an empty directory and then run dpkg -i *.deb in that directory. It will install some packages you don't need but that's only some MB. Maybe afterwards you'll have to run apt-get -f install again.
 

The Following 3 Users Say Thank You to sulu For This Useful Post:
Posts: 167 | Thanked: 186 times | Joined on Mar 2013
#3262
Originally Posted by sulu View Post
I see you have mixed glibc packages (notice the deb8u4/deb8u6 in your output!).
Where are the deb8u6 packages from? If they are from the official Debian repo then I'd be puzzled that your ED works at all.
Yes, they are from the official Debian repo (didn't touch that part yet, wanted to install vim first and then look to change them but only to find a closer repo to my location, knowing that now it is in Netherlands).
I try to always use the official repos and add another repo only if really needed.
After getting in the chroot I did an apt-get update && apt-get upgrade which got me in this state (I always try to get the system up to date before installing additional packages).

Originally Posted by sulu View Post
The archive contains Debian packages. Please try to install these packages with dpkg -i !
The easiest way would be to unpack the archive to an empty directory and then run dpkg -i *.deb in that directory. It will install some packages you don't need but that's only some MB. Maybe afterwards you'll have to run apt-get -f install again.
Ok, will try that as soon as possible.

Thanks.
 
Posts: 698 | Thanked: 2,014 times | Joined on Jan 2011 @ Germany
#3263
Originally Posted by Malakai View Post
I try to always use the official repos and add another repo only if really needed.
That is a very wise approch - except for when you want to run a recent Debian on a kernel from the stone age.

In Easy Debian Jessie (and only here) please avoid any packages from the Debian repo that are build from the glibc source package! [1]
In principle the same is true for pulseaudio, but installing that from Debian will only result in broken sound in the chroot, not in a completely broken chroot.


[1] https://packages.debian.org/source/jessie/glibc
 

The Following 2 Users Say Thank You to sulu For This Useful Post:
Posts: 167 | Thanked: 186 times | Joined on Mar 2013
#3264
So, I did a dpkg -i *.deb and some packages installed without any issue but the result was :

Code:
dpkg: dependency problems prevent configuration of libc6-dev:armhf:
 libc6-dev:armhf depends on linux-libc-dev; however:
  Package linux-libc-dev:armhf is not configured yet.

...

dpkg: error processing libc6-dev:armhf (--install):
 dependency problems - leaving unconfigured

...

Errors were encountered while processing:
libc6-dev:armhf
And when I try to do an apt-get install vim I get :

Code:
FATAL: kernel too old
Segmentation fault
FATAL: kernel too old
Segmentation fault
dpkg: error processing libc-bin (--configure):
subprocess new pre-installation script returned error exit status 139
Errors were encountered while processing:
dbus
dbus-x11
libc-bin
E: Sub-process /usr/bin/dpkg returned an error code (1)
So I decided to use nano, but when trying to install other packages it works (still giving some errors, but the package installs and is usable), which is related to what you said in your previous post about packages build from the glibc source package.

My first usage of Easy Debian is for web browsing, as some websites don't work at all with Maemo's browser, so I decided to install midori and surf. Those installed without any issue and they are technically working, but frankly it is not the user experience I expect on a mobile device.

All in all, thank you for keeping this alive as much as you can.
 

The Following User Says Thank You to Malakai For This Useful Post:
Posts: 305 | Thanked: 772 times | Joined on Aug 2013
#3265
Originally Posted by sulu View Post
In Easy Debian Jessie (and only here) please avoid any packages from the Debian repo that are build from the glibc source package! [1]

[1] https://packages.debian.org/source/jessie/glibc
Quite a long list...

I already did an
echo "libc6 hold" | dpkg --set-selections
and
echo "libc6-dev hold" | dpkg --set-selections

in my current Easy Debian image but that doesn't seem to be enough then.
What is the best approach to put everything from this list that shouldn't be updated on-hold?
 

The Following 2 Users Say Thank You to t-b For This Useful Post:
Posts: 14 | Thanked: 11 times | Joined on Jan 2012
#3266
I'm trying to add printer via cups web interface, but no local printers are listed...

lsusb output from maemo:
Bus 001 Device 042: ID 03f0:0604 Hewlett-Packard DeskJet 840c
Bus 001 Device 001: ID 1d6b:0002

lsusb from debian chroot:
libudev: udev_has_devtmpfs: name_to_handle_at on /dev: Function not implemented

I could not find any useful info on google and I really don't want to cram up my rootfs with cups (>60MB!)

Ideas?
 
Posts: 14 | Thanked: 11 times | Joined on Jan 2012
#3267
Originally Posted by t-b View Post
Quite a long list...

I already did an
echo "libc6 hold" | dpkg --set-selections
and
echo "libc6-dev hold" | dpkg --set-selections

in my current Easy Debian image but that doesn't seem to be enough then.
What is the best approach to put everything from this list that shouldn't be updated on-hold?
Not sure if 100% correct, but holding these packages worked for me:

glibc-doc
glibc-source
libc-bin
libc-dev-bin
libc6
libc6-dbg
libc6-dev
libc6-pic
libpulse0
linux-libc-dev
locales-all
pulseaudio
xkb-data
 
Posts: 564 | Thanked: 953 times | Joined on Dec 2012
#3268
Anybody have patched glibc for latest Ubuntu? I would like to try kwin with xwayland on sailfish but ancient kernel stops me.
__________________
My Thumb repo
 

The Following User Says Thank You to elros34 For This Useful Post:
Posts: 1 | Thanked: 4 times | Joined on Oct 2017
#3269
Originally Posted by sulu View Post

1)
As mentioned in [2] we need to patch glibc to accept Fremantle's 2.6.28 kernel. You'll need an armhf/armel system running at least kernel 2.6.32 to do all this, so doing it on the N900 itself is no longer an option.
I did all of this on my Cubieboard2, which took about 6 hours. Once you have an image running you can create new patched glibc packages on the N900 (if the watchdog doesn't kill it).
I would strongly advise against using qemu, at least if you're over 40 and want it done before you retire.
If you need newer glibc packages and can't create them on your own drop me a note and I'll build them. But it may take a week or so.

a)
On a Debian Jessie armhf (or armel) system get the glibc sources
Code:
apt-get source glibc
b)
change into the created folder and apply the following changes:

This is what dpkg-source recorded of my changes:
Code:
Description: decrease min kernel version to 2.6.28 for Fremantle compatibility

--- glibc-2.19.orig/ports/sysdeps/unix/sysv/linux/tile/configure
+++ glibc-2.19/ports/sysdeps/unix/sysv/linux/tile/configure
@@ -1,4 +1,4 @@
 # This file is generated from configure.ac by Autoconf.  DO NOT EDIT!
  # Local configure fragment for sysdeps/unix/sysv/linux/tile.

-arch_minimum_kernel=2.6.32
+arch_minimum_kernel=2.6.28
--- glibc-2.19.orig/ports/sysdeps/unix/sysv/linux/tile/configure.ac
+++ glibc-2.19/ports/sysdeps/unix/sysv/linux/tile/configure.ac
@@ -1,4 +1,4 @@
 GLIBC_PROVIDES dnl See aclocal.m4 in the top level source directory.
 # Local configure fragment for sysdeps/unix/sysv/linux/tile.

-arch_minimum_kernel=2.6.32
+arch_minimum_kernel=2.6.28
Additionally the testsuite checks have to be ignored during the package generation because some of them will fail:
Code:
# diff -u libc6/glibc-2.19/debian/testsuite-checking/compare.sh.orig libc6/glibc-2.19/debian/testsuite-checking/compare.sh
--- libc6/glibc-2.19/debian/testsuite-checking/compare.sh.orig	2014-11-09 14:43:46.809977508 +0000
+++ libc6/glibc-2.19/debian/testsuite-checking/compare.sh
@@ -41,5 +41,5 @@
 
 rm -f $expected $results
 # This would be a lovely place to exit 0 if you wanted to disable hard failures
-#exit 0
+exit 0
 exit $rv
c)
We need to tell dpkg that we changed the sources:
Code:
dpkg-source --commit
This will ask you to specify a name for the patch (chose whatever you like) and bring up the standard editor to provide a description for it.

d)
Now you can build the packages
Code:
debuild -us -uc
I found out that these instructions almost work still, in addition to the above changes, I also had to change these files:
Code:
--- debian/debhelper.in/libc.preinst.orig       2017-10-08 11:32:18.123876676 +0200
+++ debian/debhelper.in/libc.preinst    2017-10-08 11:33:07.583800072 +0200
@@ -357,11 +357,11 @@
         # sanity checking for the appropriate kernel on each architecture.
         kernel_ver=`uname -r`
 
-        # The GNU libc requires a >= 2.6.32 kernel, found in squeeze/lucid/RHEL6
-        if linux_compare_versions "$kernel_ver" lt 2.6.32
+        # The GNU libc requires a >= 2.6.28 kernel, found in squeeze/lucid/RHEL6
+        if linux_compare_versions "$kernel_ver" lt 2.6.28
         then
             echo WARNING: this version of the GNU libc requires kernel version
-            echo 2.6.32 or later.  Please upgrade your kernel before installing
+            echo 2.6.28 or later.  Please upgrade your kernel before installing
             echo glibc.
             kernel26_help

--- debian/sysdeps/linux.mk.orig        2017-10-08 11:32:00.903903345 +0200
+++ debian/sysdeps/linux.mk     2017-10-08 11:32:39.073844230 +0200
@@ -1,5 +1,5 @@
 # When changing this, make sure to update debian/debhelper.in/libc.preinst!
-MIN_KERNEL_SUPPORTED := 2.6.32
+MIN_KERNEL_SUPPORTED := 2.6.28
in both files you need to change "2.6.32" into "2.6.28". Then you can build, and have firefox/iceweasel version 45.9.0esr-1~deb8u1

Oh, I'm doing the build on a Raspberry3, and it took close to 6 hours, so it's nice getting it right the first time.
 

The Following 4 Users Say Thank You to klausade For This Useful Post:
Posts: 698 | Thanked: 2,014 times | Joined on Jan 2011 @ Germany
#3270
Originally Posted by elros34 View Post
Anybody have patched glibc for latest Ubuntu? I would like to try kwin with xwayland on sailfish but ancient kernel stops me.
My approach won't work on whatever you consider "latest Ubuntu".
It only works up to glibc 2.22 and Xenial already comes with 2.23.
If someone has a working solution I'd be interested too, because then also Debian Stretch would become an option again.

@klausade:
Indeed you're right. Sorry for the inconvenience! I neglected to document these steps because dpkg-source didn't record them.
Nice to see, someone is actually checking what I've been doing!
I'll update the instructions.
 

The Following 3 Users Say Thank You to sulu For This Useful Post:
Reply

Tags
beta, debian, easy debian, extras-devel, fremantle, i <3 qole, squeeze

Thread Tools

 
Forum Jump


All times are GMT. The time now is 04:29.