Notices


Reply
Thread Tools
Community Council | Posts: 4,113 | Thanked: 9,877 times | Joined on May 2012 @ Southerrn Finland
#41
Originally Posted by frogjump View Post
Anybody got the mmcblk0p28 ? and can send to me?
Did a stupid thing and now my Jolla only shows logo,recovery mode dont help.
I doubt anyone's going to send you the image, it is where all private stuff is kept...
 

The Following 2 Users Say Thank You to juiceme For This Useful Post:
Posts: 7 | Thanked: 3 times | Joined on Dec 2014
#42
Originally Posted by juiceme View Post
I doubt anyone's going to send you the image, it is where all private stuff is kept...
There where a file before but cannot find it anymoore,jolla-sailfish-1.0.8.21.tar.xz
just send a private message If someone know where to get It
Edit..I see It was removed,Jolla care then

Last edited by frogjump; 2014-12-22 at 10:53.
 
Posts: 142 | Thanked: 635 times | Joined on Dec 2014 @ Earth
#43
It's 2017 now and I'm still using a Jolla 1 phone.

My BTRFS partition got corruption.
(One log entry causes the kernel to segfault while trying to replay).

I made the mistake of trying the recovery mode without much checking.
I ended up with a partition with cleared checksum, that still doesn't mount in-kernel (Still the same replay-log segfault).

Luckily, I can recover nearly every file I need from my busted partition (thank you BTRFS's Copy-on-Write !!!) using btrfs tools which will use whichever copy happens to not be busted.

Now instead of trying to rebuild a functioning BTRFS partition myself....
(which would be possible at this point but tedious - recovery mode lost the checksums, btrfs tools doesn't save the posix access rights, and I still need to fix the segfault causing log entry. So quite some work until phone is up again)
...I wanted to know if anyone happens to have a useable "factory-@" Image file ?

(Jolla Care are slow to answer my Zendesk ticket, and as mentioned above, it's not possible to publish it on web due to copyrighted bit from Qualcomm)
 

The Following User Says Thank You to DrYak For This Useful Post:
Posts: 142 | Thanked: 635 times | Joined on Dec 2014 @ Earth
#44
Originally Posted by DrYak View Post
...I wanted to know if anyone happens to have a useable "factory-@" Image file ?
Update:

My laptop's btrfs restore works even better and I got everything I wanted out of the busted partition.

I managed to rebuild a new BTRFS partition with both the recovery bits ( 'factory-@', etc. ) and the regular subvolumes ( '@', '@home' ).

I replaced mmcblk0p28 and now I've got everything back working, not even needing to do a factory reset.

("Copy-on-Write", bitches ! It works)
 

The Following 3 Users Say Thank You to DrYak For This Useful Post:
Amboss's Avatar
Posts: 135 | Thanked: 185 times | Joined on May 2010 @ Mittelfranken, Germany
#45
Argh, I had send in my Jolla for service to Finland.See here.
They actually had to change mainboard because it was completely dead. So I had it back now for three weeks or so,everything set up again, as far as possible since I didn't have a full backup and only an older one from backup function.
Last week I found it on my table stuck on boot screen. This time I could get into recovery mode, but...

I thought, the option in that menu are actually to be used! Naah, almost everytime I tried something, it disconnected telnet. An everytime I tried again, I made it worse. factory-@ was broke pretty early maybe even form the beginning.

Yesterday I finally got around to make my own image file from the remaining pieces, while adding missing pieces from /@ which I thought were part of the original image (mostly translations). It seems, it was not enough to be recovered Tar complained about errors while packing and unplacking as well.

I am proud to at least make it to the next stage: It went from bootloop to "trying to revover file system" but ends at "please seek service".

Could someone help me out with advice or even factory-@? factory-@home seems to be OK. I understand, these parts don't contain personal information as with the other 2 subvolumes.
 

The Following 2 Users Say Thank You to Amboss For This Useful Post:
Amboss's Avatar
Posts: 135 | Thanked: 185 times | Joined on May 2010 @ Mittelfranken, Germany
#46
*BUMP*

Sorry to doublepost. I could still use some help here. I already contacted jolla support, but they seem to be busy shipping sailfish X.

Where could I get help from? For a start I would at least try to confirm contents of factory-@ just to be sure of it's completeness.
 
Reply

Tags
backup, jolla image

Thread Tools

 
Forum Jump


All times are GMT. The time now is 04:50.