Notices


Reply
Thread Tools
Posts: 8 | Thanked: 40 times | Joined on Oct 2017
#1
Hi everyone,

Good day to you all. I have been struggling with an MMS problem on Sailfish OS using the T-Mobile USA network for a long time and really need some help. I was wondering if anyone could please offer me some advice on troubleshooting this problem? I would be very grateful if someone knowledgeable could help me. Here are the core details:
  • Sending or receiving MMS messages only succeeds intermittently
  • I have zero issues with phone, SMS, or 4G data. The issue is only MMS.
  • Sometimes it works on the first attempt, other times it can take
    many, many tries before it succeeds
  • This happens with my Intex Aqua Fish (2G) as well as Sony Xperia X running the community port (4G)
  • I took my Aqua Fish to Spain recently. T-Mobile has a roaming agreement there and it roamed on vodafone.es. Phone, SMS, and data was great BUT I had the exact same problem with MMS over there.
  • The exact same settings on an Android phone (indeed with the same Xperia X before flashing it) are successful on the first attempt
  • I tried the older legacy T-Mobile USA settings but have the same problem
  • Wifi disabled or enabled does not change anything.

I installed the MMS Logger app from the Jolla store. Here is a link with the output of a sample MMS send. This is a very good example because it failed for about 4 minutes and then suddenly succeeded. The whole time the phone was not moved and it had a strong signal:

https://pastebin.com/e4VgCCuG

The only outright error I could see is HTTP Status 2 -- which doesn't appear to be a valid status code! Since it also says "Cannot resolve hostname", I'm wondering if perhaps I could get around this by hard-coding an IP into the hosts file, though I don't know enough about this topic to know exactly what.

Code:
2017-10-05 15:27:58 [mms-transfer-list] Transfer /msg/1543/Send started
2017-10-05 15:27:58 [mms-task] Send[1543] NEED_CONNECTION -> TRANSMITTING
2017-10-05 15:27:58 [mms-ofono] Settings.Address: 100.225.88.199
2017-10-05 15:27:58 [mms-ofono] Settings.Netmask: 255.255.255.255
2017-10-05 15:27:58 [mms-ofono] Settings.Gateway: 100.225.88.200
2017-10-05 15:27:58 [mms-ofono] Settings.DomainNameServers: 10.177.0.34 10.177.0.210
2017-10-05 15:28:18 [mms-task-http] HTTP status 2 (Cannot resolve hostname)
2017-10-05 15:28:18 [mms-task] Send[1543] TRANSMITTING -> SLEEP
Usually I will see this section in the log just repeated endlessly until it times out, but sometimes it succeeds as in the example log posted.

I honestly have no idea how to go about troubleshooting this any further. I used to think my issue was that I had 2G only with the Aqua Fish, which is a very weak signal for me....but after seeing the same exact problem with a strong 4G signal on the Xperia X, I realized it is a deeper problem. I searched the forums and found several people complaining about this on the Nexus 5 but no solutions were posted.

I would be truly grateful if anyone could point me in the right direction. This MMS issue is a long-term headache and is the only thing interfering with an otherwise great Sailfish experience.

Thanks very much, in advance!
 

The Following 4 Users Say Thank You to paulwk For This Useful Post:
Posts: 218 | Thanked: 564 times | Joined on Jun 2010 @ USA
#2
It's an ofono bug, I experience the same thing. I'm on SFOS 2.1.2.3 on an Xperia X using T-Mobile in the US (Chicago, city proper).

I'm not sure what triggers the bug, because I can do 3-5 tests before it happens (MMS logger output isn't conclusive), but if I do "pkill mms-engine" from fingerterm or over ssh, it works instantly.

I'm working on a solution, I'm not certain which way I want to go yet, but I'm thinking about changing the way it "hangs up" the connection after sending or receiving... maybe script it so that it pkills mms-engine each time as a workaround, until we can figure out why ofono does this.

I wish I had better news for you, but I've been banging my head against the wall on this one for a while. I'll keep you posted for certain, though.

Edit: at the moment, even a quick toggle to pkill mms-engine will work when MMS isn't functioning, rather than restarting the networking stack or rebooting. I'll update with progress as it comes.

Edit: some progress (16:57 Central time): I've been able to reproduce the bug. I sent 10 test messages to myself, sent and received successfully, then put the screen to sleep. When I woke the device, I was unable to send or receive again. I pkill'ed mms-engine, and sent 5 test messages to myself, sent and received successfully, then put the phone to sleep. When I woke the device, I was unable to send or receive again. I did this again several times, with varied message amounts, to verify that the putting the device to sleep with the power button is indeed what triggers the bug.

So, the bug *is* reproducible, and I've at least narrowed it down. I'm going to see if there's some way I can script it to pkill mms-engine when the device wakes or sleeps, just as a temporary workaround.
__________________
Sony Xperia X SFOS 2.1.2.3, Nokia N810

Last edited by deprecated; 2017-10-09 at 22:01.
 

The Following 7 Users Say Thank You to deprecated For This Useful Post:
karlos devel's Avatar
Posts: 63 | Thanked: 165 times | Joined on Mar 2013 @ Guatemala
#3
Try: network-mobile -> access-point-mms -> protocol -> IPv6
__________________
Caballlero

Last edited by karlos devel; 2017-10-09 at 22:41.
 

The Following 7 Users Say Thank You to karlos devel For This Useful Post:
Posts: 611 | Thanked: 2,002 times | Joined on Nov 2010 @ USA
#4
I have problems with sfos on oneplus x(at&t) receiving mms with text attached. Pictures without accompanying text, e.g., come in fine. You might ask those sending mms messages to you to try sending just the media and see if it makes a difference. Either way, your results might be interesting...
 

The Following 2 Users Say Thank You to robthebold For This Useful Post:
Posts: 8 | Thanked: 40 times | Joined on Oct 2017
#5
Guys, thank you very much for the advice and suggestions, I really appreciate your help.

SUCCESS!!

karlos devel -- Your suggestion seems to have resolved my problem! It's amazing, but it is working consistently now after only toggling Settings->Cellular network->MMS access point->Protocol to IPv6

When it is on "Dual" or "IP" I get the problem, but IPv6 is fine. I wish I'd tried that a long time ago. Thank you so much, this is a huge help!!

deprecated - It continues to work for me after manually pressing the sleep button and waking it back up. If you are on IP or DUAL, you might want to try IPv6 in case it also resolves it for you.

robthebold - At least in my case with T-Mobile USA, it doesn't seem to matter if the mms has text with the attachment. That might be a provider specific issue. Nevertheless, I appreciate the tip.

Thanks again for everyone's input. It was very kind of you all to take time to respond and help me with this. This was the last hurdle I had to fully enjoy SailfishOS. Awesome!


Best Wishes,
 

The Following 6 Users Say Thank You to paulwk For This Useful Post:
Posts: 218 | Thanked: 564 times | Joined on Jun 2010 @ USA
#6
Originally Posted by paulwk View Post
Guys, thank you very much for the advice and suggestions, I really appreciate your help.

SUCCESS!!

karlos devel -- Your suggestion seems to have resolved my problem! It's amazing, but it is working consistently now after only toggling Settings->Cellular network->MMS access point->Protocol to IPv6

When it is on "Dual" or "IP" I get the problem, but IPv6 is fine. I wish I'd tried that a long time ago. Thank you so much, this is a huge help!!

deprecated - It continues to work for me after manually pressing the sleep button and waking it back up. If you are on IP or DUAL, you might want to try IPv6 in case it also resolves it for you.

robthebold - At least in my case with T-Mobile USA, it doesn't seem to matter if the mms has text with the attachment. That might be a provider specific issue. Nevertheless, I appreciate the tip.

Thanks again for everyone's input. It was very kind of you all to take time to respond and help me with this. This was the last hurdle I had to fully enjoy SailfishOS. Awesome!


Best Wishes,

@paulwk - awesome! Glad to hear it's working for you. Do you mind sharing your Data and MMS APN settings with me? I've tried everything from the old voicestream MMS APN to the newer epc, but I always have intermittent functionality - and I can reproduce that bug above - like clockwork.
__________________
Sony Xperia X SFOS 2.1.2.3, Nokia N810
 

The Following 2 Users Say Thank You to deprecated For This Useful Post:
Posts: 8 | Thanked: 40 times | Joined on Oct 2017
#7
Originally Posted by deprecated View Post
@paulwk - awesome! Glad to hear it's working for you. Do you mind sharing your Data and MMS APN settings with me? I've tried everything from the old voicestream MMS APN to the newer epc, but I always have intermittent functionality - and I can reproduce that bug above - like clockwork.
No problem at all, I'd be happy to share them. I originally set these settings manually because the defaults did not work nor did epc or voicestream. I copied these from an Android device with my SIM card in it and they work great for me.

Connection Name: T-Mobile MMS
Access point name: fast.t-mobile.com
Protocol: IPv6
Authentication: None
Proxy Address: Leave blank
Proxy Port: Leave blank
MMS message center address:
http://mms.msg.eng.t-mobile.com/mms/wapenc

BTW, if it's relevant for you, here are my Data access point settings:
Connection name: Internet/WebConnect
Access point name: fast.t-mobile.com
Protocol: Dual
Authentication: None

I hope this helps!
 

The Following 7 Users Say Thank You to paulwk For This Useful Post:
Posts: 218 | Thanked: 564 times | Joined on Jun 2010 @ USA
#8
Originally Posted by paulwk View Post
No problem at all, I'd be happy to share them. I originally set these settings manually because the defaults did not work nor did epc or voicestream. I copied these from an Android device with my SIM card in it and they work great for me.

Connection Name: T-Mobile MMS
Access point name: fast.t-mobile.com
Protocol: IPv6
Authentication: None
Proxy Address: Leave blank
Proxy Port: Leave blank
MMS message center address:
http://mms.msg.eng.t-mobile.com/mms/wapenc

BTW, if it's relevant for you, here are my Data access point settings:
Connection name: Internet/WebConnect
Access point name: fast.t-mobile.com
Protocol: Dual
Authentication: None

I hope this helps!

Thanks a lot! That's literally the only combination I *hadn't* tried. Now it's working well, without the need to toggle off 4G! This is great, maybe I was overthinking it. LOL

Still going to monitor ofono and see what happens.

Edit: most of my problems seem to be stemming from the fact that, up until very recently, I had to use the 3G APN's for my area, as some parts of Chicago are heavily saturated on the 4G bands, so I didn't mind resigning to the 3G bands which were actually faster. Hey, this works, and maybe I was wrong about the ofono bug. More of a glitch than a bug, and limited to a very small set of conditions.

Thanks again, @paulwk, and @karlos devel for suggesting it.
__________________
Sony Xperia X SFOS 2.1.2.3, Nokia N810
 

The Following 3 Users Say Thank You to deprecated For This Useful Post:
Posts: 8 | Thanked: 40 times | Joined on Oct 2017
#9
Originally Posted by deprecated View Post
Thanks a lot! That's literally the only combination I *hadn't* tried. Now it's working well, without the need to toggle off 4G! This is great, maybe I was overthinking it. LOL

Still going to monitor ofono and see what happens.

Edit: most of my problems seem to be stemming from the fact that, up until very recently, I had to use the 3G APN's for my area, as some parts of Chicago are heavily saturated on the 4G bands, so I didn't mind resigning to the 3G bands which were actually faster. Hey, this works, and maybe I was wrong about the ofono bug. More of a glitch than a bug, and limited to a very small set of conditions.

Thanks again, @paulwk, and @karlos devel for suggesting it.
Cool!! I'm happy to hear that it's working for you, too. So that seems to be the winning combination for Sailfish on T-Mobile USA: the APN settings above with IPv6 for the MMS protocol. This is just great!

It's interesting that that bug you found only manifests when connected to their other APNs. It must be some weird compatibility issue, though I suppose it doesn't matter now. BTW, I've found that these same APN settings will still work if you are connected to 2G (prefer 2G setting in Settings or with 2G only in US Aqua Fish). Where I live, I only have a weak 2G signal and good 4G -- strangely, there is no 3G available, so not sure about that band.

Hurray for Sailfish on T-Mobile USA. Enjoy your device!
 

The Following 3 Users Say Thank You to paulwk For This Useful Post:
Posts: 218 | Thanked: 564 times | Joined on Jun 2010 @ USA
#10
Originally Posted by paulwk View Post
Cool!! I'm happy to hear that it's working for you, too. So that seems to be the winning combination for Sailfish on T-Mobile USA: the APN settings above with IPv6 for the MMS protocol. This is just great!

It's interesting that that bug you found only manifests when connected to their other APNs. It must be some weird compatibility issue, though I suppose it doesn't matter now. BTW, I've found that these same APN settings will still work if you are connected to 2G (prefer 2G setting in Settings or with 2G only in US Aqua Fish). Where I live, I only have a weak 2G signal and good 4G -- strangely, there is no 3G available, so not sure about that band.

Hurray for Sailfish on T-Mobile USA. Enjoy your device!
Very exciting! I think I figured out the culprit. The older MMS APNs absolutely require the old MMS proxy, and it seems ofono freaks out sporadically when it attempts to connect to the proxy.

Nice to see this working 100% though. I always thought I'd be limited to 3G on Sailfish in the US. This is why I love this community. Working together!
__________________
Sony Xperia X SFOS 2.1.2.3, Nokia N810
 

The Following 5 Users Say Thank You to deprecated For This Useful Post:
Reply

Thread Tools

 
Forum Jump


All times are GMT. The time now is 13:53.