Notices


Reply
Thread Tools
Posts: 324 | Thanked: 739 times | Joined on Jun 2009 @ São Paulo, Brazil
#11
hi,
I tryied to install but I got the error (translated from Portuguese) "Impossible to install openttd-data. Incompatible package)
what's wrong?
 

The Following User Says Thank You to traysh For This Useful Post:
Posts: 76 | Thanked: 41 times | Joined on Nov 2008 @ Germany
#12
Same for me, so i repacked with

Code:
Section: user/games
Architecture: armel
Don't know which one did the trick, works then. But after that the installer complains about a permissions issue when installing the data files to mmc (which is obviously related to mmc being vfat). Finally when i forced everything and tried openttd, it can't find the data files although they are in /usr/share/games/openttd where they are supposed to be..
 

The Following User Says Thank You to MrWeasel For This Useful Post:
javispedro's Avatar
Posts: 2,330 | Thanked: 5,200 times | Joined on Jan 2009 @ Barcelona
#13
Originally Posted by traysh View Post
hi,
I tryied to install but I got the error (translated from Portuguese) "Impossible to install openttd-data. Incompatible package)
what's wrong?
Seems the application manager won't install a non-user package from a local directory.

You'll have to install from the command line; as root:
dpkg -i openttd*.deb

Or wait until I decide to upload to extras...
 
javispedro's Avatar
Posts: 2,330 | Thanked: 5,200 times | Joined on Jan 2009 @ Barcelona
#14
Originally Posted by MrWeasel View Post
Don't know which one did the trick, works then. But after that the installer complains about a permissions issue when installing the data files to mmc (which is obviously related to mmc being vfat). Finally when i forced everything and tried openttd, it can't find the data files although they are in /usr/share/games/openttd where they are supposed to be..
I suggest you first purge both packages, then delete /usr/share/games/openttd and /media/mmc2/share/openttd, then reinstall the openttd-data package.

Just tested again after doing all that and it works for me.
Code:
# dpkg -i /media/mmc1/pkgs/openttd-data_0.7.1-1_all.deb 
Selecting previously deselected package openttd-data.
(Reading database ... 19464 files and directories currently installed.)
Unpacking openttd-data (from .../openttd-data_0.7.1-1_all.deb) ...
Internal MMC card found.
Ok. Installing to memory card.
Installing to /media/mmc2/share/openttd...
Setting up openttd-data (0.7.1-1) ...
BTW, thanks for testing.

Last edited by javispedro; 2009-06-24 at 14:46.
 
Posts: 76 | Thanked: 41 times | Joined on Nov 2008 @ Germany
#15
Thanks again for your quick reply. After purging and removing the directories now it mysteriously started working.

Either I made a mistake in recreating the .deb (which indeed was my first attempt to create a debian package) or the installer got confused by the already existing directory containing the commercial files...

P.S. even the music works now! Never got it working with any other port of openttd before! Thanks a lot!!
 
Posts: 324 | Thanked: 739 times | Joined on Jun 2009 @ São Paulo, Brazil
#16
Very nice, thank you and congratulations, it's wonderful
 
javispedro's Avatar
Posts: 2,330 | Thanked: 5,200 times | Joined on Jan 2009 @ Barcelona
#17
The package is now on extras-devel!
I've incremented version number to 0.7.1-2 but there should be no visible changes. It also should seamlessly update from the application manager if you enable the extras-devel repository.

I'm testing it and seems to be fine. I hope I can promote it to regular extras soon.

If anything goes wrong with this build, please tell me.
 
Cadabena's Avatar
Posts: 240 | Thanked: 71 times | Joined on Jun 2008 @ United Kingdom
#18
Absolutely AMAZING... free slots in my timetable will never be the same again! Installed fine with dpkg, but would only install to the internal card, not the device memory, not sure if this is a problem that might need ironing out.

Anyway, I was always a Rollercoaster Tycoon fan, I'll have to find out how to play this properly now

And, I know I strictly shouldn't, but to save some of you some grief looking for the original files... look no further

Last edited by Cadabena; 2009-06-29 at 21:51.
 

The Following User Says Thank You to Cadabena For This Useful Post:
javispedro's Avatar
Posts: 2,330 | Thanked: 5,200 times | Joined on Jan 2009 @ Barcelona
#19
Originally Posted by Cadabena View Post
Installed fine with dpkg, but would only install to the internal card, not the device memory, not sure if this is a problem that might need ironing out.
Oops. I think I just lost some karma points

(using both set -e and maemo-confirm-text is really prone to error )

Thanks for the "bugreport", Cadabena.
 
Pushwall's Avatar
Posts: 373 | Thanked: 110 times | Joined on Jul 2007
#20
Thanks for this excellent port, javispedro!

I'm off now to read some docs on how to play and also to find my glasses so I can see all the cool tiny graphics.
 
Reply

Tags
games, openttd, port, sdl

Thread Tools

 
Forum Jump


All times are GMT. The time now is 05:19.