Notices


Reply
Thread Tools
Posts: 450 | Thanked: 16 times | Joined on Mar 2006
#11
Originally Posted by linuxrebel View Post
I did mean /etc/bluetooth/hcdi.conf sorry for the foobar.
Thanks you guys for the clarification. I did edit the file, but my trusty Bluetooth headphones so far don't work in either Kagu or Kilikali.

Hope I understood the second edit instruction correctly -- "lp rswitch,hold,sniff,park; and remove rswitch" to change the line to
"lp hold,sniff, park;"

And what should I have done with the "Setup the .asoundrc file" instruction, if anything?
 
Posts: 18 | Thanked: 0 times | Joined on Jul 2007
#12
Yup i can confirm that that does what it's says on the tin, i still have a slight problem every now and then where mplayer and alsa get overrun but i think that might be just down to load spikes and the sco codec not being able to empty the buffer out
 
Johnx's Avatar
Posts: 643 | Thanked: 628 times | Joined on Mar 2007 @ Seattle (or thereabouts)
#13
@ascherjim: Just setup your .asoundrc the way I have it in my instructions at the top of the thread. The "profile a2dp" line is technically optional. I included it because I had issues with a2dp not being available and my N800 automatically reverting to SCO (the mono sound, headset protocol). Tell us how it goes. The more data points out here the better.

-John
 
linuxrebel's Avatar
Posts: 182 | Thanked: 46 times | Joined on Jan 2007 @ Silly-Con Valley
#14
Originally Posted by ascherjim View Post
Thanks you guys for the clarification. I did edit the file, but my trusty Bluetooth headphones so far don't work in either Kagu or Kilikali.

Hope I understood the second edit instruction correctly -- "lp rswitch,hold,sniff,park; and remove rswitch" to change the line to
"lp hold,sniff, park;"

And what should I have done with the "Setup the .asoundrc file" instruction, if anything?
You did get it right. jusr remove rswitch from the line, not the line just rswitch, the word. As for the "Setup the .asoundrc file" the opening post on the thread covered that one. Didn't feel the need to duplicate.

As for not working. Do you have fmradio installed? If you do make sure you can use regular plugin headphones as there is a switch on it that forces sound to the speakers (just using the headphones as an antenna) that if it's set wrong you can't use regular phones either.

Last edited by linuxrebel; 2007-12-21 at 10:19.
 
iancumihai's Avatar
Posts: 274 | Thanked: 143 times | Joined on Jun 2007 @ Romania
#15
Originally Posted by Johnx View Post
Sometimes I'll play a song and it will cut out every 10-20 seconds and sometimes ...
This happend to me also but in a different setup.

Laptop -> motorola handset (not a2dp) ... 5s pause
Laptop -> nokia handset ... perfect
 
Johnx's Avatar
Posts: 643 | Thanked: 628 times | Joined on Mar 2007 @ Seattle (or thereabouts)
#16
Interesting update: I got A2DP working on my old Zaurus C1000 (XScale @ 416MHz) with a USB bluetooth dongle. Plays back smoothly with ~15-20% CPU usage. Somehow there is definitely a software issue with A2DP on the N8x0 w/ 2008OS. I'll be doing further research. I wonder if it's mplayer, bluez or alsa though...

Edit: On the Zaurus it's also quite a bit more resilient while I'm loading down the machine with lots of other CPU intensive tasks and doesn't even skip when heavily swapping to the SD card.

Edit: I did a couple quick tests of mplayer playing to my bluetooth headphones on 3 machines (Zaurus, N800 and my desktop). The Zaurus and the Desktop were both using the same usb bluetooth 1.2 dongle since I only have one.
Code:
--Zaurus SL-C1000 (bluez 3.23, Linux 2.6.22)
alsa-init: requested format: 44100 Hz, 2 channels, 9
alsa-init: using ALSA 1.0.15
alsa-init: setup for 1/2 channel(s)
alsa-init: using device bluetooth
alsa-init: pcm opened in blocking mode
alsa-init: chunksize set to 1024
alsa-init: fragcount=6
alsa-init: got buffersize=24576
alsa-init: got period size 1024

--Nokia N800 (bluez 3.22, Linux 2.6.21)
alsa-init: requested format: 44100 Hz, 2 channels, 9
alsa-init: using ALSA 1.0.14a
alsa-init: setup for 1/2 channel(s)
alsa-init: using device bluetooth
alsa-init: pcm opend in blocking mode
alsa-init: chunksize set to 128
alsa-init: fragcount=16
alsa-init: got buffersize=8192
alsa-init: got period size 128

--Desktop PC Athlon 64 3000+ (bluez 3.23, Linux 2.6.22)
alsa-init: requested format: 44100 Hz, 2 channels, 9
alsa-init: using ALSA 1.0.14a
alsa-init: setup for 1/2 channel(s)
alsa-init: using device bluetooth
alsa-init: pcm opened in blocking mode
alsa-init: chunksize set to 1024
alsa-init: fragcount=6
alsa-init: got buffersize=24576
alsa-init: got period size 1024
The buffersize on the N800 looks quite low, comparatively. And to top it off the frequent complaints about "broken pipe" and "trying to reset soundcard" seem to happen on the other platforms mostly under high load when the buffer would be most likely to be empty. I wonder if this might be connected to the other issues the mplayer guys are having with alsa...

-John

Last edited by Johnx; 2007-12-21 at 12:42. Reason: Adding additional info... (again)
 
Posts: 450 | Thanked: 16 times | Joined on Mar 2006
#17
Originally Posted by Johnx View Post
@ascherjim: Just setup your .asoundrc the way I have it in my instructions at the top of the thread. The "profile a2dp" line is technically optional. I included it because I had issues with a2dp not being available and my N800 automatically reverting to SCO (the mono sound, headset protocol). Tell us how it goes. The more data points out here the better.

-John
Johnx: Well, I believe I made all the file edits required, and even installed mplayer, but my Bluetooth headphones don't pick up anything, again trying with Kagu and Kilikali. I'm used to editing and creating files, so I trust I didn't make any mistakes in following your various instructions. I'll be watching this thread for further developments -- as well as awaiting the arrival in the mail of my ad20 mp3 dongle! Keep up with your dedicated endeavor on this matter. Regards, Jim
 
Johnx's Avatar
Posts: 643 | Thanked: 628 times | Joined on Mar 2007 @ Seattle (or thereabouts)
#18
@ascherjim: So are you saying it does work in mplayer but not in the other players? I really have no idea on what other players may or may not work. All I can tell you is how to make it work with mplayer. The authors of the other players will have to answer questions about whether their software works with A2DP in 2008OS. If it doesn't work in mplayer, what error does it give? Also, be sure that you rebooted after making changes to anything under /etc/bluetooth/ . Tell me how it goes for you, and thanks for helping me test this.
 
sachin007's Avatar
Posts: 2,041 | Thanked: 1,066 times | Joined on Mar 2006 @ Houston
#19
Can some one tell me how you edit that file? I want to try a2dp. thanks
 
Posts: 450 | Thanked: 16 times | Joined on Mar 2006
#20
Originally Posted by Johnx View Post
@ascherjim: So are you saying it does work in mplayer but not in the other players? I really have no idea on what other players may or may not work. All I can tell you is how to make it work with mplayer. The authors of the other players will have to answer questions about whether their software works with A2DP in 2008OS. If it doesn't work in mplayer, what error does it give? Also, be sure that you rebooted after making changes to anything under /etc/bluetooth/ . Tell me how it goes for you, and thanks for helping me test this.
Johnx: I did not try it with mplayer. (Isn't that a video player?) I know that previously Kagu had enabled a2dp through incorporation of mplayer. Their application still permits the option of using mplayer, but their Bluetooth activation icon is no longer present in their OS800 version. Can I use mplayer for an audio item? Probably a very naive question.
 
Reply

Thread Tools

 
Forum Jump


All times are GMT. The time now is 10:30.