Notices


Closed Thread
Thread Tools
d-iivil's Avatar
Posts: 2,153 | Thanked: 2,186 times | Joined on Dec 2009 @ Hellsinki, Finland
#11
Hmm.. won't accept my settings (Saunalahti, Finnish carrier). Keeps saying "could not save APN settings. Did you enter a correct APN?"

I'm trying to offer it these settings:
APN: mms.saunalahti.fi
MMSC: http://mms.saunalahti.fi:8002
width: 300
and my number

What am I doing wrong?
__________________
If you're rich and you think I deserve a cold beer, you may donate one or two :-P

80's style stadium rock is back - FIRENOTE
Hi-Octane heavy metal - FORCE MAJEURE
 
Posts: 377 | Thanked: 97 times | Joined on Dec 2009 @ US
#12
Installed fine, boots fine, but it won't accept epc.tmobile.com as an APN.

~shrug~

Edit: Used settings that are in Internet Settings... Still nothing, but at least now it "accepted" the APN name or "T-Mobile Internet".

I'm sure it's something I'm missing...
Attached Images
 
__________________
HNIC target-testing.com

Last edited by That One Guy; 2010-01-08 at 18:37.
 
Posts: 547 | Thanked: 1,381 times | Joined on Sep 2009 @ Stockholm, Sweden
#13
Updated first post to answer some FAQ.

Make sure you type in the name like it's listed in "Internet Connections" - this application does not (currently) add a new APN for you - you have to set it up yourself in "Internet Connections" and then enter that name in fMMS.
__________________

Problem with fMMS? Run in x-terminal: cp /tmp/fmms.log /home/user/MyDocs/
After that you'll see fmms.log in filemanager or when you connect the device to your desktop as a mass storage device.
E-mail the log to me, if you don't have the email address, drop me a PM. Thanks!

fMMS - MMS for your N900
fAPN - GUI for adding a new GPRS APN
If you like this post, don't be shy to thank me -->
 

The Following User Says Thank You to frals For This Useful Post:
d-iivil's Avatar
Posts: 2,153 | Thanked: 2,186 times | Joined on Dec 2009 @ Hellsinki, Finland
#14
Originally Posted by frals View Post
Updated first post to answer some FAQ.

Make sure you type in the name like it's listed in "Internet Connections" - this application does not (currently) add a new APN for you - you have to set it up yourself in "Internet Connections" and then enter that name in fMMS.
Okay.. after this I get Error 111 Connection refused.

Can someone who is using Saunalahti and has succeeded in making fMMS working please provide settings I should use?

But hail to you frals anyway for putting in so much effort for making MMS-messages appearing on N900
__________________
If you're rich and you think I deserve a cold beer, you may donate one or two :-P

80's style stadium rock is back - FIRENOTE
Hi-Octane heavy metal - FORCE MAJEURE
 
amorek13's Avatar
Posts: 245 | Thanked: 32 times | Joined on Oct 2009 @ CT USA
#15
is it me or internet connection if you go new it only lets you set up wifi?
 
d-iivil's Avatar
Posts: 2,153 | Thanked: 2,186 times | Joined on Dec 2009 @ Hellsinki, Finland
#16
Originally Posted by amorek13 View Post
is it me or internet connection if you go new it only lets you set up wifi?
It's not just you. N900 won't let us define more than one APN at the time :-/
__________________
If you're rich and you think I deserve a cold beer, you may donate one or two :-P

80's style stadium rock is back - FIRENOTE
Hi-Octane heavy metal - FORCE MAJEURE
 
Posts: 547 | Thanked: 1,381 times | Joined on Sep 2009 @ Stockholm, Sweden
#17
First post updated.

Right I notice there's currently a bug with how the application tries to connect to MMSC which contains a path (ie http://mmsc.something/servlet/mms) - this should be the reason most of you see the "Name or service not known" error message (I hope)

I'll try to get this fixed in the next version - thanks for testing and reporting!

When reporting an error please include the settings from your "Internet Connections" as well as the settings your carrier requires you to have!

Thanks again for testing!
__________________

Problem with fMMS? Run in x-terminal: cp /tmp/fmms.log /home/user/MyDocs/
After that you'll see fmms.log in filemanager or when you connect the device to your desktop as a mass storage device.
E-mail the log to me, if you don't have the email address, drop me a PM. Thanks!

fMMS - MMS for your N900
fAPN - GUI for adding a new GPRS APN
If you like this post, don't be shy to thank me -->
 

The Following 4 Users Say Thank You to frals For This Useful Post:
Posts: 36 | Thanked: 16 times | Joined on Dec 2009
#18
Originally Posted by frals View Post
When reporting an error please include the settings from your "Internet Connections" as well as the settings your carrier requires you to have!

Thanks again for testing!
It fails saying:
Error: -2 Name or service not known

Settings:
APN: WAP
MMSC: http://mms.msg.eng.t-mobile.com/mms/wapenc
Resize image width: 92
phone number: [my #]

Another try
Settings:
APN: WAP
MMSC: http://216.155.174.84/servlets/mms
Resize image width: 92
phone number: [my #]


I think http://mms.msg.eng.t-mobile.com/mms/wapenc is the official T-Mobile MMSC according to: http://support.t-mobile.com/doc/tm21...revPageIndex=1

Also I created the WAP settings using gconftool-2
/system/osso/connectivity/IAP/WAP:
gprs_accesspointname = wap.voicestream.com
name = WAP
sim_imsi = [**********************]
type = GPRS
ipv4_type = AUTO


Thanks for looking at this
 

The Following 2 Users Say Thank You to gesperon For This Useful Post:
Posts: 547 | Thanked: 1,381 times | Joined on Sep 2009 @ Stockholm, Sweden
#19
Originally Posted by gesperon View Post
It fails saying:
Error: -2 Name or service not known
[snip]


Thanks for looking at this
Thanks for posting, this is the problem I've listed in the first post "Known problems" - I'll try to include the fix in the next version
__________________

Problem with fMMS? Run in x-terminal: cp /tmp/fmms.log /home/user/MyDocs/
After that you'll see fmms.log in filemanager or when you connect the device to your desktop as a mass storage device.
E-mail the log to me, if you don't have the email address, drop me a PM. Thanks!

fMMS - MMS for your N900
fAPN - GUI for adding a new GPRS APN
If you like this post, don't be shy to thank me -->
 

The Following User Says Thank You to frals For This Useful Post:
Posts: 278 | Thanked: 209 times | Joined on Dec 2009
#20
Ok. Here is what happened with me

First i got the check your APN thing in fMMS so it wouldn't save the settings. so discovered thru frals that I had to add a new APN thru terminal. manually

Code:
gconftool-2 --set /system/osso/connectivity/IAP/NEWAPNNAME/type --type string "GPRS"

gconftool-2 --set /system/osso/connectivity/IAP/NEWAPNNAME/name --type string "NEWAPNNAME"
Get sim_imsi: (Really long number)

Code:
gconftool -R /system/osso/connectivity/IAP |grep sim_imsi
Set sim_imsi:

Code:
gconftool-2 --set /system/osso/connectivity/IAP/NEWAPNNAME/sim_imsi --type string YOURSIMIMSI
Then a new packet data connection appeared in my Internet Connection. I went there to edit it.

New Internet connection settings:
Access Point Name: du
user: (none for me)
pass: (none for me)

Advanced:
HTTP Proxy: 10.14.18.4
Port: 8080

Then I saved and connected to this connection
Now in fmms

fmms Settings:
APN: du
MMSC: http://mms.du.ae
Resize image width: 400
Phone number: [my #]

I got the error "Unknown name" when I was trying to send an MMS without connecting to the new data connection first. (silly me)

I got the error "Connection Refused" when I had the port set wrong in the proxy.

At the moment, after ironing out the APN settings. It's working. I get 200k success message. And the other mobile receives the MMS. but it says invalid text or attachment.

I've only tried with one Picture (smallest i can find). I'll try others later.

Last edited by Corso85; 2010-01-08 at 20:00.
 

The Following 2 Users Say Thank You to Corso85 For This Useful Post:
Closed Thread

Tags
application, community win, fmms, frals rocks, fralsvsnokia1-0, fremantle, maemo, maemo 5, mms, n900, python

Thread Tools

 
Forum Jump


All times are GMT. The time now is 05:05.