Notices


Reply
Thread Tools
Posts: 47 | Thanked: 3 times | Joined on Jan 2010
#721
This is the one right?

Is it worth me returning the phone (bought it through Nokia UK website)? Does anyone know if they replace phones or fix them up themselves and send the same one back?
 
Posts: 3,617 | Thanked: 2,410 times | Joined on Nov 2009 @ Cambridge, UK
#722
Yes, that one should work fine.

You could return the phone, but it'll take a few weeks for them to send you a replacement, so I wouldn't bother.
 
Posts: 47 | Thanked: 3 times | Joined on Jan 2010
#723
Ok, charged my battery up in a friend's 5800. Put it back in the N900 and it still won't start up. Nokia logo screen appears but after a while it goes away and it's just a blank screen (i.e. how the screen appears when the phone is off).

If I plug the mains charger in I experience the same problem, logo screen comes (washed/dimmed out), LED is off. Then the LED turns yellow for a while before the phone turns off and on again, repeating that process.

I don't think the battery is the issue. Anything else to try or is the phone dead?

Edit - I also tried my friend's 5800 (fully charged) battery in my N900 and it didn't start up with that.

Last edited by norstadt; 2010-01-16 at 22:47.
 
Posts: 3,617 | Thanked: 2,410 times | Joined on Nov 2009 @ Cambridge, UK
#724
If you hold down the U key when you start it up, does it stay with the Nokia logo & a small USB logo in the top-right corner? If so, you can still reflash it using the flasher program. Otherwise you'll have to get it returned & replaced.
 
Posts: 47 | Thanked: 3 times | Joined on Jan 2010
#725
Yes, if I press U and connect it via the USB the Nokia logo (on a dimmed out screen) and the USB icon appear.

I'll try flashing it then. On the link to the bin files, which isn't working right now, but from what I can remember last night, there was no 44.1 download, just an older one and the new 51.1. Someone said 44.1 was needed before going to 51.1, which one shall I try?

Know anywhere else I can get the bin files from?

Last edited by norstadt; 2010-01-16 at 23:26.
 
Posts: 5,335 | Thanked: 8,180 times | Joined on Mar 2007 @ Pennsylvania, USA
#726
Originally Posted by norstadt View Post
Someone said 44.1 was needed before going to 51.1, which one shall I try?
Only if you're doing incremental, over-the-air (OTA) updates. As you'll be doing a full flash of the firmware, jump straight to 51.1.
__________________
maemo.org profile
 

The Following User Says Thank You to sjgadsby For This Useful Post:
Posts: 7 | Thanked: 6 times | Joined on Jan 2010 @ S:t Karins, Finland
#727
Originally Posted by norstadt View Post
Someone said 44.1 was needed before going to 51.1, which one shall I try?
Well, servers seems to be down... anyway.

If you flash 1.2009.51-1 release instead of upgrading via SSU (App manager), you don't need to install 1.2009.44-1 before. Only the case if you upgrade with the flasher-3.5 or with NSU. Version 44-1 did upgrade to SSU so that's for it is required before doing upgrade to 51-1 via the SSU.
__________________
" The computer is no better than its program." - Morison E.
 
Posts: 47 | Thanked: 3 times | Joined on Jan 2010
#728
I flashed 51.1 onto the device and now it successfully starts up. Are there settings/config I can check to make sure the firmware is flashed correctly?
 
Posts: 268 | Thanked: 304 times | Joined on Oct 2009 @ Orlando, USA
#729
Originally Posted by norstadt View Post
I flashed 51.1 onto the device and now it successfully starts up. Are there settings/config I can check to make sure the firmware is flashed correctly?
Settings -> About
 
Reply

Tags
firmware, firmware update, minor update, n900, ota, pr1.0.1, ssu, update

Thread Tools

 
Forum Jump


All times are GMT. The time now is 16:32.