Notices


Reply
Thread Tools
pelago's Avatar
Posts: 2,119 | Thanked: 1,519 times | Joined on Mar 2008 @ Oxford, UK
#21
Sorry for the user-level question, but what are "USB modules for USB pseudo-host"?
 
Posts: 102 | Thanked: 23 times | Joined on Nov 2009 @ Finland
#22
Hi! Im new to this kernel stuff but is it possible to somehow improve the Bt HID support, so you could use bt mouse?
 
Posts: 946 | Thanked: 1,650 times | Joined on Oct 2009 @ Germany
#23
the default kernel cannot be USB host and therefore does not contain common USB device drivers.
Originally Posted by pelago View Post
Sorry for the user-level question, but what are "USB modules for USB pseudo-host"?
 
pelago's Avatar
Posts: 2,119 | Thanked: 1,519 times | Joined on Mar 2008 @ Oxford, UK
#24
Originally Posted by titan View Post
the default kernel cannot be USB host and therefore does not contain common USB device drivers.
Ah, I see now that this is to do with USB/IP, as talked about on http://talk.maemo.org/showthread.php?p=489609, not 'normal' USB host.
 
Posts: 94 | Thanked: 10 times | Joined on Jan 2010
#25
Hi,

I've got a usbip server so am willing to test

I've run your steps and get the following when running modprobe vhci-hcd:

FATAL: Module vhci_hcd not found

ls /lib/modules/2.6.28maemo3omap1 shows that it is definately there!

The depmod -a step returns no output on completion.

What could I have done wrong?

Cheers
 
Posts: 94 | Thanked: 10 times | Joined on Jan 2010
#26
Righto, a reboot and running depmod -a again resolved

I'll update when I am able to test this! May be over the next hour or if work is busy (anyone looking over my shoulder!) this evening.

Cheers
 

The Following 2 Users Say Thank You to meep For This Useful Post:
Posts: 67 | Thanked: 28 times | Joined on Oct 2009 @ Switzerland
#27
Originally Posted by titan View Post
the default kernel cannot be USB host and therefore does not contain common USB device drivers.
I thought that was a hardware limitation on the N900, see http://lists.maemo.org/pipermail/mae...er/020830.html . So what's the point in adding the driver?
 
Posts: 946 | Thanked: 1,650 times | Joined on Oct 2009 @ Germany
#28
this is for the USB/IP workaround, see http://talk.maemo.org/showthread.php?p=489609

Originally Posted by gidoca View Post
I thought that was a hardware limitation on the N900, see http://lists.maemo.org/pipermail/mae...er/020830.html . So what's the point in adding the driver?
 

The Following User Says Thank You to titan For This Useful Post:
Posts: 946 | Thanked: 1,650 times | Joined on Oct 2009 @ Germany
#29
Originally Posted by meep View Post
Righto, a reboot and running depmod -a again resolved
I'll update when I am able to test this! May be over the next hour or if work is busy (anyone looking over my shoulder!) this evening.
cool! I've just uploaded the usbip package in my repository.
 

The Following User Says Thank You to titan For This Useful Post:
Posts: 94 | Thanked: 10 times | Joined on Jan 2010
#30
Thanks for that...

I've just discovered my ubuntu build on my laptop is buggered! I'm in the process of creating a VM to test...
 
Reply

Thread Tools

 
Forum Jump


All times are GMT. The time now is 10:36.