Notices


Reply
Thread Tools
Posts: 1,101 | Thanked: 1,183 times | Joined on Aug 2008 @ Spain
#21
It doesn't seem to work any longer. Does it work for anybody?
 
Posts: 99 | Thanked: 65 times | Joined on Jan 2008 @ Finland
#22
Originally Posted by maacruz View Post
It doesn't seem to work any longer. Does it work for anybody?
64.14.59.165 works for me.

"Cache refreshed: Sep 11 11:59pm 2011" (UTC+3)
 
peterleinchen's Avatar
Posts: 3,210 | Thanked: 5,822 times | Joined on Aug 2010 @ Ruhrgebiet, Germany
#23
All the IPs 64. or 66. do not return any answer.

Looking up for nokia.supl.com (nokia.supl.svc.ovi.com) resolves
de.nokia.supl.geodns.fi or pos.svc.ovi.com with IP 83.150.75.211 and port 7275 (supl) open. So assuming it works...
 
Posts: 1,101 | Thanked: 1,183 times | Joined on Aug 2008 @ Spain
#24
No matter what I do (even reinstalled agps), I can't get it to work.
I observe the traffic with wireshark, it connects to pos.svc.ovi.com (83.150.75.211), it sends some data, receives what appears to be a certificate, exchanges a little bit more data, and the supl data is not updated. Last successful update is 20 dec 2010
 
Posts: 424 | Thanked: 195 times | Joined on Mar 2010 @ Sweden
#25
This was discussed in the CSSU thread.
I think supl.google.com does work.
 

The Following 2 Users Say Thank You to toxaris For This Useful Post:
Posts: 673 | Thanked: 854 times | Joined on Mar 2006
#26
Originally Posted by maacruz View Post
No matter what I do (even reinstalled agps), I can't get it to work.
I observe the traffic with wireshark, it connects to pos.svc.ovi.com (83.150.75.211), it sends some data, receives what appears to be a certificate, exchanges a little bit more data, and the supl data is not updated. Last successful update is 20 dec 2010
Is that SSL (TLS) connection?
Server is supposed to pass full certificate chain during session establishment. The root CA should be trusted within your certificate trust store. If they've issued a new certificate for their server from the hierarchy that is not trusted by the client, the client will drop connection.

In practice this can involve additional tcp connections for downloading CRLs or making OCSP queries to check the status of each certificate.

Can you capture the traffic with wireshark or tcpdump?
I can troubleshoot the session establishment.

Last edited by momcilo; 2011-09-13 at 21:20.
 

The Following 2 Users Say Thank You to momcilo For This Useful Post:
Posts: 1,101 | Thanked: 1,183 times | Joined on Aug 2008 @ Spain
#27
Originally Posted by toxaris View Post
This was discussed in the CSSU thread.
I think supl.google.com does work.
This is the N8x0, not the N900.
supl.google.com doesn't work for me, either.
 
Joseph.skb's Avatar
Posts: 752 | Thanked: 283 times | Joined on Sep 2010 @ Malaysia
#28
Never worked for me
 
Posts: 5,795 | Thanked: 3,148 times | Joined on Feb 2007 @ Agoura Hills Calif
#29
Neither worked for me for awhile. Finally, with good old Nokia supl, I waited FOREVER and it began to work.
__________________
All I want is 40 acres, a mule, and Xterm.
 
Posts: 2,802 | Thanked: 4,487 times | Joined on Nov 2007
#30
Still works here with /system/osso/supl/agps_srv_address set to 64.14.59.165.
 

The Following User Says Thank You to lma For This Useful Post:
Reply

Thread Tools

 
Forum Jump


All times are GMT. The time now is 00:47.