Thread Tools
Posts: 87 | Thanked: 287 times | Joined on Jan 2012
Originally Posted by Breeze5 View Post
No, that's not the problem. We do/have like this: when you get your new SIM and plug it in, it connects to the network and the old one is dissabled at the same time, takes about 15-60 min. My new SIM works fine in my N9 and N900. I have a carrier locked phone =/

But this i wonder:
You can unlock the carrier by going into service menu and enter a code you can buy online.
But how do i access the service menu with SFOSX? Android is the *#*#7378432#*#*
I guess you cannot do that in sailfish, you have to flash back to Android.

The Following 2 Users Say Thank You to Heik For This Useful Post:
Posts: 62 | Thanked: 311 times | Joined on Aug 2017
Originally Posted by DrYak View Post
Thus this last option should still work even if you completely **** up the whole GPT partition and need to re-partition manually.
(But this isn't a guarantee. Maybe the bootloader needs to do something silly, like checking a checksum or a signature in order to decide if it needs to display a warning, and crashes in case of corrupt partitions)
The main issue here is not messing up partition 51 or 52, I agree with you that those can be (more or less) restored easily. Another option here could be to reflash the whole image (or even restore Android with EMMA and then flashing SFOS again).
However, the biggest issue here are probably all those other partitions which contain crucial data for some hardware components. As I understood it when this topic was discussed in the second-to-last community meeting, some of those partitions can't be restored and you hard-brick the device when they are removed / damaged. So f***ing up the whole partition table (or at least making the slightest mistake during its restoration) could FUBAR (f*** up beyond all repair) your phone.

We also need to keep in mind that "moderately safe" or even "unlikely events" are not safe enough for Jolla to deploy an automated process with the possibility to completely brick the device.

Last edited by jenix; 2017-11-14 at 13:15.

The Following 4 Users Say Thank You to jenix For This Useful Post:
Posts: 29 | Thanked: 63 times | Joined on Dec 2011 @ Virginia
Does any one know if the browser and email client will be improved in regards to general UI speed within the next year?

The Following 2 Users Say Thank You to Robissimo For This Useful Post:
Breeze5's Avatar
Posts: 70 | Thanked: 59 times | Joined on Nov 2012 @ Sweden
Is there a way to get rid of the warning screen on the start up?
Xperia Sailfish X
soon Neo900

The Following 2 Users Say Thank You to Breeze5 For This Useful Post:
Posts: 1,205 | Thanked: 4,065 times | Joined on Oct 2014
Originally Posted by Breeze5 View Post
Is there a way to get rid of the warning screen on the start up?
yes, flash stock Sony Android.

Joke aside
no, there is no known way of removing that warning.
You can still support my work by donation - click here

ETH: 0xFcD031609DB739C62730589361940C68ceEbC913

The Following 7 Users Say Thank You to nieldk For This Useful Post:
Posts: 235 | Thanked: 1,084 times | Joined on Dec 2014 @ Earth
The non-joke way to remove the warning screen would require Jolla to get their boot image (the hybris-boot.img file with the kernel+initrd that gets flashed on the boot partition) signed by Sony's key.

Or alternatively, to get their own certificate admitted into the Xperia X's bootloader.

And then, re-locking the bootloader.

The Following 8 Users Say Thank You to DrYak For This Useful Post:
Posts: 930 | Thanked: 2,273 times | Joined on Jan 2012 @ UK
Seems like with the new string being translated for 2.1.4 we might have another update before Christmas which would be a nice

The Following 8 Users Say Thank You to mariusmssj For This Useful Post:
Posts: 620 | Thanked: 2,036 times | Joined on Nov 2010 @ USA
Been unusually busy lately, but I haven't fallen off the face of the Earth (or blasted off to test the spherical vs. flat argument).

<long story alert>

In fact, I've gotten an Xperia X to try the official Sailfish X on. I'd been using a Oneplus X with a community SFOS build, and really liked it. Unfortunately, its support for US frequency bands is incomplete, so it's voice and data QOS is a problem in some places -- one of which is my house. So on the Experia bandwagon I hop!

Backing up the Digital Restrictions Management stuff turned out to be a bigger PITA than I'd expected, and began to look like it was gonna take more time than the device sells for at the hourly rate I bill my free time to myself. So it's SFOS all the way for me! (If I ever need to part with the phone, I'm sure someone here would like it at a very reasonable price with Sailfish installed.)

I miss the double-tap to wake. Hopefully that gap will be filled soon. Also miss the display-off gestures, particularly to start the camera and the flashlight. But the biggest regression from the OnePlus community build is the SD card support. On the OnePlus X, I was able to use any SD card I tried, including a 64GB card with the exfat support from OpenRepos, but with Sailfish X I found that all my cards 32GB and bigger -- fat32 or exfat -- fail with dmesg errors about "tuning". I see that's apparently a kernel issue with the build and certain SD cards related to timing and transfer speed, etc.

</long story>

But now, something I hope someone has some insight on. I was able to use a 16GB fat32 card -- for a while. I installed a few apps, including SSHFS support to copy my backup off the other device -- so far so good. Then I tried the exfat tools, including bleeding edge SD card tools. Once I installed the bleeding edge sd-utils, the 16GB card wouldn't mount, automagically or manually. I removed bleeding edge sd-utils and replaced it with stock, and 16GB SD card was back.

Again -- so far, so good.

So I restored the backup from SD card and went on to install a bunch of my favorite apps. Somewhere along the way, the 16GB SD card disappeared again. It's okay in other devices and on the Ubuntu PC, so I don't think it's a hardware failure. Instead, I suspect that something I installed in the meantime has caused the issue. I've tried uninstalling a few things and retrying the SD card, but I haven't found a culprit. I've searched here and on TJC, but haven't found another report of this behavior. As of now, I can't seem to use any SD I have of any size or format.

If anyone's got any ideas on this, I love to hear them . . .

The Following User Says Thank You to robthebold For This Useful Post:
Posts: 280 | Thanked: 242 times | Joined on Jan 2006 @ Cambridge, England

I don't have the answer, but suspect microsd support is behind this issue on X

I have noticed ext4 errors in dmesg. Repairing ext4 on a desktop and using the card in J1 and the card works fine. Back in the X it works initially, then the ext4 errors appear again. Presumably need a newer kernel or to try a different card.


The Following 2 Users Say Thank You to richie For This Useful Post:
Posts: 810 | Thanked: 2,883 times | Joined on Apr 2012
Originally Posted by robthebold View Post
I miss the double-tap to wake. Hopefully that gap will be filled soon.
I enabled double-tap to wake shortly after installing Sailfish X, using this method. It works about as well as it did on the OnePlus X, except that occasionally the proximity sensor seems to get confused and the screen won't unlock unless you cover the proximity sensor and uncover it again. Battery life is decent, over two days with double tap enabled, wifi on, and bluetooth on and connected.

The Following 5 Users Say Thank You to taixzo For This Useful Post:

sailfish os, sony xperia x

Thread Tools

Forum Jump

All times are GMT. The time now is 09:05.