Active Topics

 



Notices


Reply
Thread Tools
Posts: 252 | Thanked: 221 times | Joined on Jul 2010
#371
Originally Posted by impeham View Post
I have 2 N900 devices and i paired and connected successfully both freedom pro bluetooth keyboard and a BT microsoft mouse on my first device.
Which microsoft BT mouse do you have? I have the original mouse from the Microsoft Wireless Optical Desktop combo, and I haven't been able to pair it with the N900.
 
Posts: 669 | Thanked: 430 times | Joined on May 2010
#372
i'm using microsoft bluetooth notebook mouse 5000 which is pairing fine for me.
Gameboy - thanks - the problem was indeed with the files in the folder "/etc/bluetooth/" - i copied the files of the device from before the backup opening and everything is fine now.
 

The Following 2 Users Say Thank You to impeham For This Useful Post:
Posts: 2 | Thanked: 2 times | Joined on Jul 2012
#373
I have microsoft bluetooth keyboard 5000

I have been struggling with extkbd app for a week, none of the seettings were changing the keyboard map and all the keys were working the same way as the internal keyboard of n900.
Any of the number keys (2345 and !@#$%%) were not working

So my first guss was :- may be the extkbd is not changing the keyboard map for externel keyboard.

Here are the steps which worked for me with trial and error. and is working in the exact same order

Procedure 1

1) Go to Setting External Keyboard: change it to any layout (Generic 101 to 105 Doesnt Matter)
2) open the terminal and type :setxkbmap
3) voilla : after about 3 or 5 seconds all the keys were working..

there is 1 issue though : return key is not working now .. which was working earlier


procedure 2

so there is another workaround
1) Go to Settings : turn on the virtual keyboard
2) Go to Setting External Keyboard: change it to any layout (Generic 101 to 105 Doesnt Matter)
3) open the terminal and type :setxkbmap
4) voilla : after about 3 or 5 seconds all the keys were working..

now the issue is all the keys work but return key simpy triggers the virtual keyboard where u have to press (enterbutton)


however these problem doesnot exists if i open the terminal inside LXDE desktop of easy debian
all the keys were working in procedure 1 only. I did not had to enable the virtual keyboard drama

am i missing anything here

is there any workaroud?
 

The Following 2 Users Say Thank You to jeanbrat For This Useful Post:
TomJ's Avatar
Posts: 505 | Thanked: 664 times | Joined on Oct 2009
#374
Originally Posted by jeanbrat View Post
I have microsoft bluetooth keyboard 5000

I have been struggling with extkbd app for a week, none of the seettings were changing the keyboard map and all the keys were working the same way as the internal keyboard of n900.
Any of the number keys (2345 and !@#$%%) were not working

So my first guss was :- may be the extkbd is not changing the keyboard map for externel keyboard.

Here are the steps which worked for me with trial and error. and is working in the exact same order

Procedure 1

1) Go to Setting External Keyboard: change it to any layout (Generic 101 to 105 Doesnt Matter)
2) open the terminal and type :setxkbmap
3) voilla : after about 3 or 5 seconds all the keys were working..

there is 1 issue though : return key is not working now .. which was working earlier


procedure 2

so there is another workaround
1) Go to Settings : turn on the virtual keyboard
2) Go to Setting External Keyboard: change it to any layout (Generic 101 to 105 Doesnt Matter)
3) open the terminal and type :setxkbmap
4) voilla : after about 3 or 5 seconds all the keys were working..

now the issue is all the keys work but return key simpy triggers the virtual keyboard where u have to press (enterbutton)


however these problem doesnot exists if i open the terminal inside LXDE desktop of easy debian
all the keys were working in procedure 1 only. I did not had to enable the virtual keyboard drama

am i missing anything here

is there any workaroud?
Did you (or anyone) get any further with this?
__________________
Want to know how to add public holidays to your device calendar? See the instructions wiki page.

Want to improve the location bar's search capabilities? there's a wiki page for that too...
 
TomJ's Avatar
Posts: 505 | Thanked: 664 times | Joined on Oct 2009
#375
Originally Posted by kirillkk View Post
I changed evdev_drv.so to be able to handle keyboard and mouse events separately. Driver source was taken from
xserver-xorg-input-evdev-mouse-2.1.99-1osso20090206.12.tar.gz (xserver-xorg-input-evdev-mouse 1:2.1.99-1osso20090206.12-1mouse+0m5).

There are two new options KeyboardOnly and MouseOnly.
If you set KeyboardOnly to "yes", then the evdev can be registered with Xorg for the second time with MouseOnly = "yes". So the single linux evdev can be registered as two X server devices.

There are hal scripts, readme and evdev patch in the attachment.
Thanks, both to you for this and fmg for extkbd and extmou; thanks to your efforts I'm now typing this on a Microsoft Wireless Entertainment 8000 keyboard with built in trackpad into the old n900 with knackered SIM slot which is now going to be more or less permanently plugged into my TV running easydebian. Only niggles so far are not being able to persuade esydebian it"s a uk layout< even though maemo realises, and wondering whether I can get the media keys (pause/play, ffwd, rwd and vol+/-) to work in maemo.

Once again, many thanks to you both.
__________________
Want to know how to add public holidays to your device calendar? See the instructions wiki page.

Want to improve the location bar's search capabilities? there's a wiki page for that too...
 
Posts: 9 | Thanked: 6 times | Joined on Sep 2012
#376
Anyone has any help relating to my problems using extkbd and DrNokSnes? Are they compatible?

Details in the thread below:
http://talk.maemo.org/showthread.php?t=93071

Any help extremely appreciated!!!
 
Reply

Tags
bluetooth, keyboard

Thread Tools

 
Forum Jump


All times are GMT. The time now is 19:23.