Notices


Reply
Thread Tools
Posts: 6 | Thanked: 5 times | Joined on Dec 2015 @ south of germany
#1
I had bought a N9, but with the loss of all Nokia support
I was interested to give sailfish a try, at least to see what it looks like.
But if you want to install or flash into sailfish, you must become root on your phone.
This is achieved by installing the N9repomirror on openrepos.net which works easily.
In the next step you should install developer-mode.
but when you do so, it does not work and now I found out why.
What you ABSOLUTELY need is to flash the openmode kernel after flashing the latest harmattan version.

you can follow the tutorial on youtube: https://www.youtube.com/watch?v=bRncXK6dmMc
after having downloaded all the necessary files given in the Tutorial, sutdown your phone
and unplug it from your computer.

then open a terminal (on computer) in the directory where your files a are and type

sudo flasher -F main.bin -F emmc.bin -f

it will say no device found. waiting....or similar

then plug your phone and it shound begin.

if this fails try:

sudo flasher -F main.bsudo flasher -F main.bin -fin -F emmc.bin -f --no-preserve


when it is done, you need to flash the openmode kernel with:

sudo flasher -a main.bin -k zImage_2.6.32.54-openmode_l2fix --flash-only=kernel -f -R


after that reboot your phone. install N9repomirror from openrepos.net and then deveoper-mode.
I sometimes had difficulties to find deveoper-mode in the search function, but if you search for MyExplorer,
developer-mode is listed in the results below.

now the downloaded file has 2,5 MB and for me it worked this way. (all the times I had tried before
it downloaded developer-mode with just 1,9 MB which was not succesful.


what about sailfish:

with the tutorial on youtube I managed finally to install and boot into sailfish 1.2.0.5 or something
But the graphics and the choice of apps was really poor. Camera did not work. all the behaviour is nothing compared to the
original Meego OS on the N9.
I had first found the more up to date 2.0.0.10-oss Version of sailfish which I got installed but did not boot. So I decided to try the older Version
with maybe an option to update.

Finally I decided to re-install Meego clean and with the apps of the community of openrepos and maemo
I have a brilliant phone which may be missing some apps like ebay or so but I decided to live with that.
If anyone can successfully boot into sailfish 2... let me know. The old Version does not provide the possibility to install android apps
and as I said the choice is quite disappointing. But the principle seemed good to me.


I hope this helps somebody. If I can avoid anyone the mess I have been going through...
best regards
M
 

The Following User Says Thank You to Motoroland For This Useful Post:
Posts: 27 | Thanked: 37 times | Joined on Jan 2012
#2
I'm glad to hear you're having fun with your N9. I'm a recent acquirer of an N9, and haven't played about with Sailfish yet. Technically, you can install the openmode kernel and boot another OS through Ubiboot without needing developer mode and root use access.

I wrote up my findings on this wiki page, and a few others have added to it. You might find it useful, or feel you can expand it.
 

The Following User Says Thank You to kazzie For This Useful Post:
Reply

Tags
nokia n9, root access

Thread Tools

 
Forum Jump


All times are GMT. The time now is 21:41.