Active Topics

 



Notices


Reply
Thread Tools
pichlo's Avatar
Posts: 5,347 | Thanked: 16,354 times | Joined on Sep 2012 @ UK
#1251
Originally Posted by Estel View Post
could you try to:
Code:
killall mafw-dbus-wrapper
...and check if "unplayable" video starts OK afterwards?
It did not, BUT then I followed the CSSU-Thumb official upgrade which brought back a few previously removed packages and that fixed it. I don't know which one was the crucial one.

Funnily enough, the problem still reccurs from time to time. Downloaded video plays in Media Player once, twice, five times, then out of the blue stops playing although it keeps playing fine in CuteTube. Killing mafw-dbus-wrapper as you suggest helps in those cases. Which makes the issue OT in this thread, sorry.

Originally Posted by chill View Post
I downloaded the same video. It finished ok, but the thumbnail is not shown in Archive. Instead, it appears as a .jpg file in the cutetube download folder. Repeating the same download again, the same happens, and another (identical) jpg is created in the cutetube download folder.
This is from observation only so marxian may want to correct me. All paths are relative to MyDocs/cuteTube:
1. Downloading a video foo creates files foo.mp4 and .thumbnails/foo.jpg.
2. Dowloading foo again creates a copy named foo(1).mp4 and (1).jpg (note not .thumbnails/foo(1).jpg as one might expect).
3. foo(1).mp4 does not have a matching foo(1).jpg in the .thumbnails subfolder and thus it is shown in Archive with only the default thumbnail. So downloading it again is not going to help.
4. Deleting a video from Archiive deletes foo.mp4 but not .thumbnails/foo.jpg.

I have managed to reproduce your issue like this:
1. Download foo, creating foo.mp4 and .thumbnails/foo.jpg.
2. Delete foo, deleting foo.mp4 but leaving .thumbnails/foo.jpg behind.
3. Corrupt .thumbnails/foo.jpg (e.g. truncate it to zero bytes).
4. Download foo again: voila, no thumbnail in Archives!

Your use case may have been different but I would start by looking into your MyDocs/cuteTube/.thumbnails folder for leftover files.
__________________
In particle accelerators atoms are indeed not only touching each others. But banging together in a massive explosive orgasm.
-- nieldk in a TMO post
 

The Following 4 Users Say Thank You to pichlo For This Useful Post:
Posts: 252 | Thanked: 221 times | Joined on Jul 2010
#1252
My case may have been slightly different in that the first download only partially succeeded, and then I repeated it. I wasn't suspecting a bug so I wasn't paying attention. I can confirm that it does create (1). jpg (note the blank space, if it matters) and subsequent downloads create (2),(3) etc.

However, even with the correct jpg in place, cutetube will not show the thumbnail. Here is the listing as proof:

Code:
/media/mmc1/cuteTube/.thumbnails $ ls Camera\ falls\ from\ airplane\ and\ lands\ in\ pig\ pen--MUST\ WATCH\ END__.jpg 
Camera falls from airplane and lands in pig pen--MUST WATCH END__.jpg
/media/mmc1/cuteTube/.thumbnails $ ls ../Camera\ falls\ from\ airplane\ and\ lands\ in\ pig\ pen--MUST\ WATCH\ END__.mp4
Removing (1) .jpg didn't help, either.
__________________
21.2011.38-1Smaemo7 (CSSU Stable)
2.6.28.10power53 (not overclocked)
Yes, I search before posting.
 

The Following 2 Users Say Thank You to chill For This Useful Post:
pichlo's Avatar
Posts: 5,347 | Thanked: 16,354 times | Joined on Sep 2012 @ UK
#1253
Are you sure the .jpg in .thumbnails is valid? Have you opened it in a picture viewer?

Obviously removing (1).jpg won't help. However removing Pigs_Can_Fly_Etc*.mp4 and .thumbnails/Pigs_Can_Fly_Etc*.jpg followed by a new download might. As might renaming (1).jpg to Pigs_Can_Fly_Etc.jpg and moving it to .thumbnails, overwriting the one already there.
__________________
In particle accelerators atoms are indeed not only touching each others. But banging together in a massive explosive orgasm.
-- nieldk in a TMO post
 

The Following 3 Users Say Thank You to pichlo For This Useful Post:
Posts: 252 | Thanked: 221 times | Joined on Jul 2010
#1254
Correct and correct! The original .jpg was corrupt (how did that happen?) and replacing it with the renamed (1). jpg solved the problem.
__________________
21.2011.38-1Smaemo7 (CSSU Stable)
2.6.28.10power53 (not overclocked)
Yes, I search before posting.
 

The Following 4 Users Say Thank You to chill For This Useful Post:
Ta76eem's Avatar
Posts: 157 | Thanked: 36 times | Joined on Mar 2013
#1255
does it support Live Stream ?
__________________
it is ok to go Sailing
but it is Forbidden to leave MeeGo on shore
 
marxian's Avatar
Posts: 2,448 | Thanked: 9,513 times | Joined on Aug 2010 @ Wigan, UK
#1256
Originally Posted by pichlo View Post
This is from observation only so marxian may want to correct me. All paths are relative to MyDocs/cuteTube:
1. Downloading a video foo creates files foo.mp4 and .thumbnails/foo.jpg.
2. Dowloading foo again creates a copy named foo(1).mp4 and (1).jpg (note not .thumbnails/foo(1).jpg as one might expect).
3. foo(1).mp4 does not have a matching foo(1).jpg in the .thumbnails subfolder and thus it is shown in Archive with only the default thumbnail. So downloading it again is not going to help.
4. Deleting a video from Archiive deletes foo.mp4 but not .thumbnails/foo.jpg.

I have managed to reproduce your issue like this:
1. Download foo, creating foo.mp4 and .thumbnails/foo.jpg.
2. Delete foo, deleting foo.mp4 but leaving .thumbnails/foo.jpg behind.
3. Corrupt .thumbnails/foo.jpg (e.g. truncate it to zero bytes).
4. Download foo again: voila, no thumbnail in Archives!
I wasn't aware of those bugs, so thanks for raising them. The transfer code has been replaced for the forthcoming update, so those problems should be fixed. Thumbnails are now also deleted when the video is deleted from the archive.
__________________
'Men of high position are allowed, by a special act of grace, to accomodate their reasoning to the answer they need. Logic is only required in those of lesser rank.' - J K Galbraith

My website

GitHub
 

The Following 6 Users Say Thank You to marxian For This Useful Post:
marxian's Avatar
Posts: 2,448 | Thanked: 9,513 times | Joined on Aug 2010 @ Wigan, UK
#1257
Originally Posted by chill View Post
The original .jpg was corrupt (how did that happen?)
Either the server returned invalid JPEG data or there was an error writing to the file. Because such errors are non-fatal (the thumbnail is downloaded after the video download is completed), the download is not marked as failed.
__________________
'Men of high position are allowed, by a special act of grace, to accomodate their reasoning to the answer they need. Logic is only required in those of lesser rank.' - J K Galbraith

My website

GitHub
 

The Following 3 Users Say Thank You to marxian For This Useful Post:
marxian's Avatar
Posts: 2,448 | Thanked: 9,513 times | Joined on Aug 2010 @ Wigan, UK
#1258
Originally Posted by Ta76eem View Post
does it support Live Stream ?
Not at the moment. I received a request for it recently, so I'll be looking at the possibility of implementing it soon. The stumbiling block is that not all media players support live streams.
__________________
'Men of high position are allowed, by a special act of grace, to accomodate their reasoning to the answer they need. Logic is only required in those of lesser rank.' - J K Galbraith

My website

GitHub
 

The Following 3 Users Say Thank You to marxian For This Useful Post:
Estel's Avatar
Posts: 5,029 | Thanked: 8,596 times | Joined on Mar 2011
#1259
Just a little request that buggered me for a while - is it absolutely necessary, that every new version of cuteTube (no matter if it's a "small" bugfix-release) overwrites configuration to default? It's surely not a showstopper and I can live with it, but I'm just wondering if it's done on purpose, or effect of some overlook.

Thank you for your awesome work on cuteTube,
/Estel
__________________
N900's aluminum backcover / body replacement
-
N900's HDMI-Out
-
Camera cover MOD
-
Measure battery's real capacity on-device
-
TrueCrypt 7.1 | ereswap | bnf
-
Hardware's mods research is costly. To support my work, please consider donating. Thank You!
 

The Following 4 Users Say Thank You to Estel For This Useful Post:
marxian's Avatar
Posts: 2,448 | Thanked: 9,513 times | Joined on Aug 2010 @ Wigan, UK
#1260
Originally Posted by Estel View Post
Just a little request that buggered me for a while - is it absolutely necessary, that every new version of cuteTube (no matter if it's a "small" bugfix-release) overwrites configuration to default? It's surely not a showstopper and I can live with it, but I'm just wondering if it's done on purpose, or effect of some overlook.

Thank you for your awesome work on cuteTube,
/Estel
The original reason for removing the old config file was to prevent the loading of incompatible values due to changes in the code (mostly related to the video formats). There is no reason to continue doing this now, so the config file will be left intact in the forthcoming update.
__________________
'Men of high position are allowed, by a special act of grace, to accomodate their reasoning to the answer they need. Logic is only required in those of lesser rank.' - J K Galbraith

My website

GitHub
 

The Following 7 Users Say Thank You to marxian For This Useful Post:
Reply

Tags
youtube

Thread Tools

 
Forum Jump


All times are GMT. The time now is 23:24.