Notices


Reply
Thread Tools
Posts: 26 | Thanked: 56 times | Joined on Jul 2016 @ Where do I live?
#1
I have been trying to install MSF3 from some posts in the forum without success. Finally I flashed Pwnimage into my N900 (thinking MSF was going to work), but no improvements were experimented.

It just keeps me displaying the same error it did when building from source. after
Code:
ruby1.8 msfconsole -L
, it will return:

Code:
msfconsole:117:in `require': no such file to load -- rex (LoadError) from msfconsole:117
Does anybody know what is the main cuase of the error? When I try
Code:
gem1.8 install rex
it will tell me rex is only for > Ruby 2.0.
 
Posts: 1,043 | Thanked: 3,442 times | Joined on Oct 2014
#2
Msf requires Ruby 2.x now,
If you want an older version, you must specify specific Rex version also when using gem
__________________
You can still support my work by donation - click here

ETH: 0xf7544913017653719259c92d38d50d9d55f7c6cd
 

The Following 2 Users Say Thank You to nieldk For This Useful Post:
Posts: 26 | Thanked: 56 times | Joined on Jul 2016 @ Where do I live?
#3
And how do I do it?
 
Posts: 1,043 | Thanked: 3,442 times | Joined on Oct 2014
#4
Originally Posted by cHeXs7eR View Post
And how do I do it?
Find which version supports ruby 1.8 , and use the -v flag

gem install <name> -v <version>
__________________
You can still support my work by donation - click here

ETH: 0xf7544913017653719259c92d38d50d9d55f7c6cd
 

The Following User Says Thank You to nieldk For This Useful Post:
Reply

Tags
fremantle, hacking, maemo, metasploit, pwnphone

Thread Tools

 
Forum Jump


All times are GMT. The time now is 15:48.