Notices


Reply
Thread Tools
zoner's Avatar
Posts: 74 | Thanked: 38 times | Joined on Feb 2010
#21
Originally Posted by t-b View Post
I have a problem with assigning the esc. button as meta key. Can someone who already managed to do that share the method?
Tried remapping the keys but the ESC key doesn't seem to respond. here

This adjustment in rx-51 file doesn't seem to work.

key <RTRN> { [ KP_Enter, KP_Enter, Escape, Menu ] };
so are you getting escape with Fn-Ret ?
It's been a very long time, but I think I had trouble remapping RET, h and x.

-- edit, I misread your issue --
I would try something else for esc & "menu," I use S-Fn-period for menu.
There is several examples of Fn-left for escape and I've gotten used to that.

Get something working, if you really want to mod the RET key, you would at least have a fully functional emacs to do it with

Last edited by zoner; 2013-08-30 at 19:56.
 

The Following User Says Thank You to zoner For This Useful Post:
Posts: 307 | Thanked: 777 times | Joined on Aug 2013
#22
Originally Posted by zoner View Post
There is several examples of Fn-left for escape and I've gotten used to that.

Get something working, if you really want to mod the RET key, you would at least have a fully functional emacs to do it with
Yes I have seen reports of successful use of Escape. I remapped other buttons as well with 'Escape' and also tried 'Alt_L'.
Result is always that the key combo doesn't respond to any keypress. I have also tried updating the down key before.
So I am looking for someone who has succeeded in installing this emacs version and uses the escape button (or another one) as meta key.
Should the escape button be assigned too in the .emacs file? Seems not logical to me on my desktop the escape button is accepted without any hassle.

I still think I am not doing or should do something incredibly obvious, because I don't see any similar post with this problem in any of the emacs threads (and I have read them all..).
 

The Following User Says Thank You to t-b For This Useful Post:
zoner's Avatar
Posts: 74 | Thanked: 38 times | Joined on Feb 2010
#23
Originally Posted by t-b View Post
I still think I am not doing or should do something incredibly obvious, because I don't see any similar post with this problem in any of the emacs threads (and I have read them all..).
The modifier keys are not sticky in emacs but I'm sure you realized this.

Do your modified keys work outside of emacs?
 

The Following User Says Thank You to zoner For This Useful Post:
Posts: 307 | Thanked: 777 times | Joined on Aug 2013
#24
Originally Posted by zoner View Post
The modifier keys are not sticky in emacs but I'm sure you realized this.

Do your modified keys work outside of emacs?
I have seen reports that modified keys were not registered in certain programs, but haven't seen anyone saying escape was not registered after editing the rx-51 file.
Most adjusted keys are working fine in emacs, it is just the escape key that fails. I need a meta key to be able to use emacs with org mode.

Is there another program that uses the escape key that I can test the functionality with?

The only thing I did with this phone is installing emacs and trying to get it working. Please keep in mind I don't know much about the N900 and other software. I don't even know a lot about emacs too. Just recently discovered org mode
 

The Following User Says Thank You to t-b For This Useful Post:
zoner's Avatar
Posts: 74 | Thanked: 38 times | Joined on Feb 2010
#25
Originally Posted by t-b View Post
I have seen reports that modified keys were not registered in certain programs, but haven't seen anyone saying escape was not registered after editing the rx-51 file.
Most adjusted keys are working fine in emacs, it is just the escape key that fails. I need a meta key to be able to use emacs with org mode.

Is there another program that uses the escape key that I can test the functionality with?

The only thing I did with this phone is installing emacs and trying to get it working. Please keep in mind I don't know much about the N900 and other software. I don't even know a lot about emacs too. Just recently discovered org mode
I guess I/we need to see your rx-51 to figure this out. We're a bit OT for this thread. Can you pm or upload your rx-51 somewhere?

You're in Europe, right? You have four directional keys?
 

The Following User Says Thank You to zoner For This Useful Post:
Posts: 307 | Thanked: 777 times | Joined on Aug 2013
#26
One of the rx-51 files I tried is this one from Mr_Pingu
http://talk.maemo.org/showpost.php?p...43&postcount=2

[edit] and yes 4 directional keys and I am from Europe/Netherlands.

Last edited by t-b; 2013-08-31 at 23:07.
 

The Following User Says Thank You to t-b For This Useful Post:
Posts: 307 | Thanked: 777 times | Joined on Aug 2013
#27
I have attached another rx-51 file I tried.
Based on this post http://talk.maemo.org/showpost.php?p=970519&postcount=5

the part that should work:

Code:
xkb_symbols "english_base" {
// 1. row
key <AD01>	{ [	Alt_L,		Alt_L,		1,		F1		] };
I also tried Escape instead of Alt_L

I use the following method to update and use the new rx file.

1. open terminal
2. root
3. emacs /usr/share/X11/xkb/symbols/nokia_vndr/rx-51
4. edit the file
5. ctrl-x ctrl-s to save the file
6. close emacs - goto terminal
7. setxkbmap also tried setxkbmap us
8. start emacs again
9. try key (in this case q) + another key / result: no response
10. press ctrl-x and then q + another key / then I can see the result of the key - Escape/Alt is never registered

Other keys that are mapped (like < and > are registered in emacs)
Attached Files
File Type: txt rx-51_2.txt (18.3 KB, 246 views)
 

The Following User Says Thank You to t-b For This Useful Post:
Posts: 307 | Thanked: 777 times | Joined on Aug 2013
#28
I just did one minor adjustment in the rx-51 file and changed F1 in 1 and after that change the q button was recognized as ESC!

After that I remapped Q as q and changed 1 back to F1 and it still worked...

I have no idea why the previous files failed, but it works now.
I can finally spend some time with org mode
 

The Following 3 Users Say Thank You to t-b For This Useful Post:
Posts: 13 | Thanked: 86 times | Joined on Nov 2012
#29
It was about time to bring Emacs in the Maemo repository up to date with the latest stable release (24.4), which is now done. Upgrade and enjoy!
 

The Following 9 Users Say Thank You to mtvoid For This Useful Post:
Posts: 307 | Thanked: 777 times | Joined on Aug 2013
#30
I have noticed Ubuntu 14.04 still has 24.3 in its repo - nice to have 24.4 for the N900
Using this version for a few weeks now and it works without any issue.
One of the cool things of 24.4 is the built in browser eww. Not perfect, but will work for basic sites like talk.meamo.org. Now I rarely have to leave emacs / org-mode
Google didn't seem to work though - executing a search query gave an error - but duckduckgo.com is an alternative that works fine.

Emacs (org-mode) is fantastic for the N900 with its excellent screen and keyboard. Thanks for the update mtvoid.
 

The Following 4 Users Say Thank You to t-b For This Useful Post:
Reply

Tags
emacs, fremantle

Thread Tools

 
Forum Jump


All times are GMT. The time now is 19:09.