Reply
Thread Tools
Posts: 59 | Thanked: 71 times | Joined on Sep 2009 @ Brazil
#1
Dear all,

I've programmed a bit on the N900 without the SDK, using Perl and Python, from my PC via SSH... but I wanted to try the newest SDK and Qt.

After installing Ubuntu, SDK, Java, ESbox, C++ and Qt packages, I followed the Get Started with Maemo 5 presentation at Forum.Nokia.Com.

Unfortunately I could not build the "Hello World" application (at "Example: Basic application" -> "Building and running application" -> "Build and run in Scratchbox with ESbox"). I used the provided source but ESbox showed these errors:
Code:
Unresolved inclusion: <gtkmm.h>
Unresolved inclusion: <hildonmm.h>
In fact, I have them installed:
Code:
/scratchbox/users/ric/targets/FREMANTLE_ARMEL/usr/include/hildonmm/hildonmm.h
/scratchbox/users/ric/targets/FREMANTLE_X86/usr/include/hildonmm/hildonmm.h

/scratchbox/users/ric/targets/FREMANTLE_ARMEL/opt/maemo/usr/include/gtkmm-2.4/gtkmm.h
/scratchbox/users/ric/targets/FREMANTLE_ARMEL/usr/include/gtkmm-2.4/gtkmm.h
/scratchbox/users/ric/targets/FREMANTLE_X86/usr/include/gtkmm-2.4/gtkmm.h
I could get past the last one by changing the include
Code:
from: #include <hildonmm.h>
to..: #include <hildonmm/hildonmm.h>
I tried to do something similar to the gtkmm.h, but it didn't work:
Code:
from: #include <gtkmm.h>
to..: #include <gtkmm-2.4/gtkmm.h>
Does anyone have any idea of what am I doing wrong?

Thanks!
 
Posts: 190 | Thanked: 127 times | Joined on Mar 2010 @ Bavaria, Germany
#2
You should use pkg-config.

Add the following to your .pro file (for gtkmm)
Code:
CONFIG += link_pkgconfig
PKGCONFIG += gtkmm-2.4

Last edited by gri; 2010-04-03 at 13:36.
 
Posts: 59 | Thanked: 71 times | Joined on Sep 2009 @ Brazil
#3
Thanks, gri... but I was mistaken. ESbox IDE shows that the inclusions are unresolved, but in fact the build works - so this is not a serious problem, just a nuisance. Sorry about the noise...
 
Reply

Thread Tools

 
Forum Jump


All times are GMT. The time now is 07:39.