Notices


Reply
Thread Tools
Posts: 168 | Thanked: 729 times | Joined on Dec 2014 @ Earth
#81
Originally Posted by mosen View Post
All was working great but the Flashtool part.
Is it correct that flashtool needs sudo rights to operate?
To be more precise : FlashTool need to have full read/write access to all the various USB devices that the Xperia X will present to the system.

sudo is a quick shortcut to get the things done.
(But a bit dangerous in theory, because Flashtool will have full read/write access on anything...)

The long way is to add a bunch of rules in some "/etc/udev/rules.d/somthing.rules" file.

You need to add rules for every different DEVID that the device will exhibit (the Xperia X tend to have a multiple personality disorder and exhibit different IDs in each mode) :

Code:
SUBSYSTEM=="usb", ATTR{idVendor}=="0fce", ATTRS{idProduct}=="e1e0", MODE="0660", GROUP="users"
here "users" is a group where I have read/write access.
0fce:e1e0 is the USB ID that the Xepria X present when in normal android mode.

You can see the Vendor/Product ID by doing "lsusb".

You'll need to add entries for the flashmodes (Volume Down + turn on, Volume Up + turn on, etc.). Each time, reboot the phone in a mode, do "lsusb" to see the USB ID, add a new rule in the udev rules.

After that FlashTool will have all the rights it needs, but only those.

Somebody who is not in a hurry should collect all the IDs (I mean, beside 0fce:e1e0) and add them to the tutorial.
(Together with a nice "90-xperia.rules" ready to be dropped in etc).
 

The Following 4 Users Say Thank You to DrYak For This Useful Post:
Posts: 168 | Thanked: 729 times | Joined on Dec 2014 @ Earth
#82
Originally Posted by DrYak View Post
Somebody who is not in a hurry should collect all the IDs (I mean, beside 0fce:e1e0) and add them to the tutorial.
(Together with a nice "90-xperia.rules" ready to be dropped in etc).
Big thanks to foozle from TJC who did collect all the relevant USB IDs.

Seems that all Xperia X modes use common a vendorId, so it would be possible to catch them all with a single rule (hoping that the user doesn't have another Sony device at the same time to which they son't want to give full access).

We can now built a nice 90-xperia.rules ready to by dropped inside /etc/udev/rules.d/ :

Code:
# Xepria X [0fce:e1e0]
# Android [0fce:adde]
# Sony S1Boot Fastboot  [0fce:0dde]
SUBSYSTEM=="usb", ATTR{idVendor}=="0fce", MODE="0660", GROUP="users"

# Jolla Recovery 
SUBSYSTEM=="usb", ATTR{idVendor}=="2931", ATTRS{idProduct}=="0a06", MODE="0660", GROUP="users"
And an alternative with separate productIds :
Code:
# Xepria X [0fce:e1e0]
SUBSYSTEM=="usb", ATTR{idVendor}=="0fce", ATTRS{idProduct}=="e1e0", MODE="0660", GROUP="users"
# Android [0fce:adde]
SUBSYSTEM=="usb", ATTR{idVendor}=="0fce", ATTRS{idProduct}=="adde", MODE="0660", GROUP="users"
# Sony S1Boot Fastboot  [0fce:0dde]
SUBSYSTEM=="usb", ATTR{idVendor}=="0fce", ATTRS{idProduct}=="0dde", MODE="0660", GROUP="users"

# Jolla Recovery 
SUBSYSTEM=="usb", ATTR{idVendor}=="2931", ATTRS{idProduct}=="0a06", MODE="0660", GROUP="users"
Can somebody still running Android and planning to do a Sailfish X flash test it ?

-----

Edit :
This TA backup tutorial uses more or less a similar .rule (uses world-access perms "0777" instead of my approach of groups).

Thus, these files should work.

Last edited by DrYak; 2017-10-24 at 21:26.
 

The Following 2 Users Say Thank You to DrYak For This Useful Post:
Posts: 22 | Thanked: 15 times | Joined on Jan 2014
#83
Official Linux Instructions now on:
https://jolla.com/sailfishxinstall/
 

The Following 3 Users Say Thank You to jayki For This Useful Post:
Posts: 84 | Thanked: 606 times | Joined on Jul 2015 @ Berlin, Germany
#84
Originally Posted by jayki View Post
Official Linux Instructions now on:
https://jolla.com/sailfishxinstall/
Thanks for the link!
I added an disclaimer on the top of the guide, but this one is still useful for those that already unlocked their bootloaders before 34.3.A.0.228 came out since jolla still wants you to use windows in that case.
 

The Following 3 Users Say Thank You to jakibaki For This Useful Post:
Posts: 168 | Thanked: 729 times | Joined on Dec 2014 @ Earth
#85
Originally Posted by jakibaki View Post
Thanks for the link!
I added an disclaimer on the top of the guide
Speaking of links : I think that this one is the best reference for backing up the TA partition and bringing the phone up to date.
 

The Following 4 Users Say Thank You to DrYak For This Useful Post:
Posts: 84 | Thanked: 606 times | Joined on Jul 2015 @ Berlin, Germany
#86
Originally Posted by DrYak View Post
Speaking of links : I think that this one is the best reference for backing up the TA partition and bringing the phone up to date.
Thanks for that link too I added it to the guide.
 

The Following 3 Users Say Thank You to jakibaki For This Useful Post:
Posts: 72 | Thanked: 39 times | Joined on Oct 2009 @ Finland
#87
Did anyone check the MD5 value of the downloaded file from
http://www.flashtool.net/downloads_linux.php

Cause it mismatches the one given on website (tested both .7z and .tar) and is bit worrying tbh. I used the torrent download and trying to download the one from uploaded.to, but it says not available for the moment, pay me crap. Can anyone check if they have mismatching file too?

I guess not many ppl check these things at all and uses it regardless...

Did some more research and its even more concerning tbh, nobody has replied on github when asked about it:
https://github.com/Androxyde/Flashtool/issues/62

Also on XDA people have asked about it, but no "official" answer has been found, if the file has been tampered or not:
https://forum.xda-developers.com/gen...fails-t3636812

Im quite surprised, there has been few others wondering same thing here, but hasn't raised any flags either!

Edit1: Finally finished download from uploaded.to and same mismatch.

Edit2: Well, I just cloned the git and compiled it myself from sources, just in case!

Edit3: Well bloody hell, even the build files dont work anymore, following build instructions, you wont get final .JAR file. Its missing something, even that has been asked about in issues, without any answers. Its like the project is abandoned by dev...

Last edited by ihmemies; 2017-11-14 at 22:14.
 

The Following 2 Users Say Thank You to ihmemies For This Useful Post:
Reply

Thread Tools

 
Forum Jump


All times are GMT. The time now is 05:46.