Active Topics

 



Notices


Reply
Thread Tools
rcull's Avatar
Posts: 299 | Thanked: 168 times | Joined on Jun 2006 @ Wales UK
#21
tso

Yep. The sudoers file is what is amennded in the postinstall script and there was a bug in that the problem with the 'file not open' should also be fixed in 0.8.0-2

Rick
 
tso's Avatar
Posts: 4,783 | Thanked: 1,252 times | Joined on Aug 2007 @ norway
#22
that was after i installed 0.8.0-2, as 0.8.0-1 failed to install at all...
__________________
Be warned, posts are often line of thoughts at highway speeds...
 

The Following User Says Thank You to tso For This Useful Post:
rcull's Avatar
Posts: 299 | Thanked: 168 times | Joined on Jun 2006 @ Wales UK
#23
tso

Because its just a read a sudoers line isn't needed to copy /etc/hosts. Advoid checks for the presence of orighosts before doing a copy.
Check your ~/.advoid for orighosts if its there it should contain just the original contents of /etc/hosts.

0.8.0-3 now in the extras-devel queue.

Rick
 

The Following User Says Thank You to rcull For This Useful Post:
rcull's Avatar
Posts: 299 | Thanked: 168 times | Joined on Jun 2006 @ Wales UK
#24
advoid is now available from extras-devel. Please test. All bugs / suggestions gratefully recieved.
 
Posts: 607 | Thanked: 450 times | Joined on Sep 2009 @ Washington, DC
#25
I installed version 0.8.0-3 on my N810 running OS version 5.2008.43-7.

Installation seemed to go without a hitch. Program starts up with information screen (a minor suggestion - put the version in there). I dismiss the screen and see a downloaded file (from 1/10/2009 according to the header), no personal additions, and a Nokia-N810-43-7 line in the current system settings. So far so good.

Then I click update system and the message "Updating hostfile.." comes up and stays up (for hours if I let it run) with no obvious effect. The Home Tools applet shows minimal CPU load so I would guess it's hung somewhere.

However it's not locked. I can get back to my home screen and if I click Advoid's End Program button it terminates promptly and, seemingly, gracefully. Upon restart it shows only the Nokia line in the current system settings.

This behavior occurs before and after switching off, when plugged in or unplugged, when connected to the Internet or not, or when I try to include a personal URL or not.

I thought it might be a problem with Python but I have HomeTools installed and operating. HomeTools shows in its details that it uses the hildon-desktop-python-loader and python2.5-hildondesktop but these don't show up in the list of installed applications.

Any suggestions would be appreciated.
 
Addison's Avatar
Posts: 3,807 | Thanked: 1,133 times | Joined on Oct 2007 @ East Lansing, MI
#26
I have the exact same issues as reported by Dave.

I recently installed Adblocker on my home computer and love it to death.

Would be nice to hear from someone in getting this to work.
 
Addison's Avatar
Posts: 3,807 | Thanked: 1,133 times | Joined on Oct 2007 @ East Lansing, MI
#27
If I run Advoid from Xterm it's requesting a password.
 
rcull's Avatar
Posts: 299 | Thanked: 168 times | Joined on Jun 2006 @ Wales UK
#28
Guys

Sorry I've been out of circulation for a while.

The reason your having problems is that there needs to be an extra line in the sudoers file.

Tso told me about this a few posts ago but I couldn't see it at the time.

I've got a new version about to be submitted. Give it a day or so and update from the new version - It should sort these problems out.

Rick
 

The Following 2 Users Say Thank You to rcull For This Useful Post:
Posts: 607 | Thanked: 450 times | Joined on Sep 2009 @ Washington, DC
#29
Originally Posted by rcull View Post
Sorry I've been out of circulation for a while.
No need to apologize, it's not like we're sending you a paycheck.

Between my Windoze computers, my old Palm, and my N810, I have plenty of open source apps that were last updated two years ago. A response in less than a week is express service.

Thanks for your efforts,

Dave
 

The Following User Says Thank You to DaveP1 For This Useful Post:
Addison's Avatar
Posts: 3,807 | Thanked: 1,133 times | Joined on Oct 2007 @ East Lansing, MI
#30
Super awesome that you're building another release for us.

Many thanks ahead.
 
Reply

Tags
adblocking, browser, hostfile

Thread Tools

 
Forum Jump


All times are GMT. The time now is 14:50.