Active Topics

 



Notices


Reply
Thread Tools
Posts: 5 | Thanked: 0 times | Joined on Oct 2018
#1
I removed the package 'mp-harmattan-003-pr' by mistake while installing gcc and I can't find the correct package('mp-harmattan-003-pr') on available repos.I just found the package'mp-harmattan-001-pr' and it's not suitable on my China device.The apt-get can't work correctly now.It said ALL THE PACKAGES on my device is automatically installed and they are useless now and asked me to use 'apt-get autoremove' to remove them ALL.

Last edited by Sunset_Shimmer; 2018-10-16 at 14:56.
 
Posts: 5 | Thanked: 0 times | Joined on Oct 2018
#2
Originally Posted by Sunset_Shimmer View Post
I removed the package 'mp-harmattan-003-pr' by mistake while installing gcc and I can't find the correct package('mp-harmattan-003-pr') on available repos.I just found the package'mp-harmattan-001-pr' and it's not suitable on my China device.The apt-get can't work correctly now.It said ALL THE PACKAGES on my device is automatically installed and they are useless now and asked me to use 'apt-get autoremove' to remove them ALL.
And here is another question.

When I was installing some packages(eg. Ageisctl HeadphoneFix N9QT and devtools-* for Developer Mode),all the apps closed automatically (eg.Browser Terminal Reader Warehouse) Is it normal? Do I need to fix it? And if I need,how can I fix it?
 
Posts: 486 | Thanked: 937 times | Joined on Aug 2014
#3
No idea whether this resource still active, but worth a look:
http://www.uuuwg.com/other/4IiAjJ
 

The Following User Says Thank You to aspergerguy For This Useful Post:
Posts: 5 | Thanked: 0 times | Joined on Oct 2018
#4
Originally Posted by aspergerguy View Post
No idea whether this resource still active, but worth a look:
http://www.uuuwg.com/other/4IiAjJ
Yes.I know that reflash the device CAN fix the problem,but I AM TIRED OF IT.I have flashed it for THREE TIMES(I always break it ;-) ) ,and I don't want to do that again.

I just need a .deb package that's called "mp-harmattan-003-pr",then I can fix it.
 
Posts: 486 | Thanked: 937 times | Joined on Aug 2014
#5
These resources are well out of date now unfortunately:
http://www.voidcn.com/article/p-kuoiuohr-gq.html
 

The Following User Says Thank You to aspergerguy For This Useful Post:
coderus's Avatar
Posts: 6,158 | Thanked: 11,661 times | Joined on Nov 2011 @ Open Mobile Platform, Innopolis, Russia
#6
 

The Following 2 Users Say Thank You to coderus For This Useful Post:
Posts: 5 | Thanked: 0 times | Joined on Oct 2018
#7
Originally Posted by coderus View Post
what wrong with https://openrepos.net/content/ancelad/n9-repomirror ?
It don't have packages that are for China device(PR_003)
e.g.'mp-harmattan-003-pr' this package makes apt know that which packages are system packages and avoid removing them.
e.g. 'camera-ui-settings-003' This package is not in the repo. It is the camera ui in China device(PR_003)
 
Ancelad's Avatar
Posts: 1,471 | Thanked: 2,770 times | Joined on Jun 2012 @ Russia, 96
#8
Reflashing to another PR?
__________________
Twitter: @iAncelad
Try my SailfishOS theme for Nokia N9
 
Posts: 5 | Thanked: 0 times | Joined on Oct 2018
#9
Originally Posted by aspergerguy View Post
These resources are well out of date now unfortunately:
http://www.voidcn.com/article/p-kuoiuohr-gq.html
Worked ,Thanks
Package file link:
https://gitorious.org/mp-harmattan-0...798f4580797581
use the command:
AEGIS_FIXED_ORIG
IN=com.nokia.maemo dpkg -i --force-all mp-harma
ttan-003-pr_40.2012.21-3-004_all.deb

Last edited by Sunset_Shimmer; 2018-10-14 at 15:18.
 
Posts: 1,658 | Thanked: 3,654 times | Joined on Mar 2010 @ North Potomac MD
#10
Originally Posted by coderus View Post
what wrong with https://openrepos.net/content/ancelad/n9-repomirror ?
Hi. Does this repository also have apps that were available from Nokia as well. If not where would I find those? Thanks!
 
Reply

Thread Tools

 
Forum Jump


All times are GMT. The time now is 03:50.