Notices


Reply
Thread Tools
Posts: 3 | Thanked: 0 times | Joined on Jan 2018
#1
Hello everyone. I need and appreciate all of your help on this problem I have with my N900. The phone does not read my SIM card (which is still usable), and everytime I boot up the message would appear as follows: "All telephony functions, including emergency calls, are disabled due to a communication error. To recover, you might have to reboot the device." The phone's IMEI is also gone. I have done extensive research on fixing this problem, tried flashing back and forth with flasher 3.5, and even wedged paper rolls in the GSM modules on the motherboard. Nothing worked. All flashing ends with the message "CMT flashing failed" with no clue as to why it did not succeed, and the paper rolls changed nothing. Everything else is functional I am at my wit's end right now. Please help me. Thank you for reading.
 
Posts: 68 | Thanked: 608 times | Joined on Sep 2010 @ UK
#2
hello

My understanding is sadly that as you have already tried all the other "fixes" is not a fixabled problem, it needs a motherboard replacement.

If i am wrong and you find a solution please let me know as I have a N900 in my draw with the same problem
 

The Following User Says Thank You to zenecho For This Useful Post:
Posts: 229 | Thanked: 612 times | Joined on Jun 2015 @ Lisbon - Portugal
#3
Originally Posted by KoreanTigers View Post
Hello everyone. I need and appreciate all of your help on this problem I have with my N900. The phone does not read my SIM card (which is still usable), and everytime I boot up the message would appear as follows: "All telephony functions, including emergency calls, are disabled due to a communication error. To recover, you might have to reboot the device." The phone's IMEI is also gone. I have done extensive research on fixing this problem, tried flashing back and forth with flasher 3.5, and even wedged paper rolls in the GSM modules on the motherboard. Nothing worked. All flashing ends with the message "CMT flashing failed" with no clue as to why it did not succeed, and the paper rolls changed nothing. Everything else is functional I am at my wit's end right now. Please help me. Thank you for reading.
Did this on mine and worked
http://talk.maemo.org/showthread.php?t=77248&page=4
 

The Following User Says Thank You to deutch1976 For This Useful Post:
Posts: 3 | Thanked: 0 times | Joined on Jan 2018
#4
Originally Posted by zenecho View Post
hello

My understanding is sadly that as you have already tried all the other "fixes" is not a fixabled problem, it needs a motherboard replacement.

If i am wrong and you find a solution please let me know as I have a N900 in my draw with the same problem
I have been looking up the forum and this is most certain a hardware problem. May be reballing the gsm modules and replacing the sim card slot might do sth. I will update as soon as I can find someone who can do it.
 
Posts: 3 | Thanked: 0 times | Joined on Jan 2018
#5
Originally Posted by deutch1976 View Post
Did this on mine and worked
http://talk.maemo.org/showthread.php?t=77248&page=4
Thanks for sharing. For discussion's sake, do you think that according to this fix reballing the gsm modules may fix the problem?
 
Posts: 229 | Thanked: 612 times | Joined on Jun 2015 @ Lisbon - Portugal
#6
Originally Posted by KoreanTigers View Post
Thanks for sharing. For discussion's sake, do you think that according to this fix reballing the gsm modules may fix the problem?
I was sceptical about this solution but it worked fine. Mine was also not showing imei and was giving the same error. It's not very hard to do but it takes some time and patience
 

The Following User Says Thank You to deutch1976 For This Useful Post:
Reply

Thread Tools

 
Forum Jump


All times are GMT. The time now is 10:23.