Notices


Reply
Thread Tools
Posts: 123 | Thanked: 65 times | Joined on Aug 2009
#1
Hello,

when using OpenVPN on my Nokia N9 everything works fine as long as I'm on WiFi. However, when I switch to GSM/UMTS, and try to reestablish the VPN the tunnel is comming up, but it's not possible to change the default route to tunnel all traffic.
Is this an issue which I could overcome with inception?
Any other hints?
Thanks,

Chris
 

The Following 2 Users Say Thank You to inte For This Useful Post:
Posts: 158 | Thanked: 56 times | Joined on Jan 2012 @ Timisoara, Romania
#2
I think it is operator related
__________________
"No one will need more than 637 kb of memory for a personal computer."
 
Posts: 123 | Thanked: 65 times | Joined on Aug 2009
#3
How could this be operator-related?
The tunnel comes up just fine, only the default route is not changed and cannot be changed!
I would rather suspect some aegis "features" interfering!
 
Posts: 38 | Thanked: 24 times | Joined on Aug 2012 @ Zürich, Switzerland
#4
Hi,

I'm afraid i don't have an answer to your question, but rather i'll ask you. How did you get VPN to work, even just in Wifi, because that's what i'm looking for. I've look up the very few threads related to the VPN connection but i wasn't able to install OpenVPN. Do you have a set of instructions i could follow?

Thanks,
 
Posts: 123 | Thanked: 65 times | Joined on Aug 2009
#5
I just followed the guide from https://12vpn.com/setup/harmattan/ but used my own config!
 
Posts: 198 | Thanked: 130 times | Joined on Sep 2012 @ Pakistan
#6
Does anyone know how to create a config file for OpenVPN

e.g vpn.config?

I've got some files: something.ovpn; a cert; and key

I don't how to use these files. Can anyone help?
__________________
N9 - 16 GB Black Reborn

Tutorial - OpenVPN for N9
 
Posts: 307 | Thanked: 488 times | Joined on Sep 2010 @ USA around Chicago
#7
I am sorry, I have not successfully configured this so I am not sure if this is something you missed or it does not make any difference.

The first paragraph (at the link you provided) says "Due to security limitations on the N9, you need to use the VPN in hybrid routing mode when using GPRS or 3G. On WiFi both the hybrid routing mode and the full routing mode work well. When enabling hybrid routing mode be sure to add Google to your routing list."

Have you tried that? I am very interested because I would like to get this working also.
__________________
Apps for iPhone & iPad
Malayalam Keyboard for iPhoneTelugu Keyboard for iPhoneGujarati Keyboard for iPhone
 

The Following User Says Thank You to abyzthomas For This Useful Post:
Posts: 198 | Thanked: 130 times | Joined on Sep 2012 @ Pakistan
#8
Well, I have been digging up the web for the past 5 hours and have made some progress. but somehow, I can't get this VPN to work. It doesn't open youtube.

I followed this guide Here. It has got full info on how to install & Configure OpenVPN. Followed the FLUSH DNS also to avoid DNSpoisoning

Not sure what Hybrid Routing means, but I'm trying this on WiFi, so according to your statement on Routing, I am inside safezon

OpenVPN starts successfully but when I try to open YouTube, it still says "cannot open".

Edit: The guide link which I gave above hasn't given any CONFIGURATION file i.e vpn.conf along with 'Certificate' and 'key' which are necessary to run openVPN. So then I got Cert from www.vpnbook.com which is a free service provider. Placed it alongside vpn.conf (or something.ovpn) in /etc/openvpn/ . Still doesn't work

Maybe someone more experienced will know how to make it work.
__________________
N9 - 16 GB Black Reborn

Tutorial - OpenVPN for N9

Last edited by khan.orak; 2013-04-04 at 21:42.
 
Posts: 198 | Thanked: 130 times | Joined on Sep 2012 @ Pakistan
#9
Looks like I have successfully made OpenVPN to work.

Feels good now!

Will post tutorial ASAP.

Edit: Follow this thread Here
__________________
N9 - 16 GB Black Reborn

Tutorial - OpenVPN for N9

Last edited by khan.orak; 2013-04-05 at 10:55.
 

The Following 2 Users Say Thank You to khan.orak For This Useful Post:
Posts: 39 | Thanked: 30 times | Joined on May 2011
#10
Originally Posted by inte View Post
Hello,

when using OpenVPN on my Nokia N9 everything works fine as long as I'm on WiFi. However, when I switch to GSM/UMTS, and try to reestablish the VPN the tunnel is comming up, but it's not possible to change the default route to tunnel all traffic.
Is this an issue which I could overcome with inception?
Any other hints?
Thanks,

Chris
Same here. VPN works under wifi but not with GSM/UMTS.
Did anybody get the "hybrid routing mode" issue solved? I could not find anything on the web.
 
Reply

Thread Tools

 
Forum Jump


All times are GMT. The time now is 03:39.