Notices


Reply
Thread Tools
Mara's Avatar
Posts: 1,298 | Thanked: 772 times | Joined on Mar 2006 @ Irving, TX
#21
I have got the i486 compiled version to run on Sailfish OS emulator! It throws a bunch of debug messages/errors but does work.
 

The Following 10 Users Say Thank You to Mara For This Useful Post:
olf's Avatar
Posts: 65 | Thanked: 228 times | Joined on Aug 2015
#22
Just to clearly state this (as there is some misinformation in this thread):

Stellarium-SF v0.9.1-1(from https://github.com/marko429/stel-sf/releases) is working really well on a Jolla 1 phone under SailfishOS 2.1.3.7 (and earlier SFOS releases), except for the garbled start-up screen.

Stellarium Mobile Sky Map v1.29.4 (for Android; I used v1.25 before) is also working fine, under AlienDalvik on a Jolla 1 phone.

Last edited by olf; 2017-11-20 at 20:30. Reason: Added comment WRT Stellarium for Android
 

The Following User Says Thank You to olf For This Useful Post:
Mara's Avatar
Posts: 1,298 | Thanked: 772 times | Joined on Mar 2006 @ Irving, TX
#23
I have been working on the Stellarium Mobile version and have got it to work on my Moto G4 Plus for ~10 seconds... (it shows the main screen that is rendered properly and fully operational, including menus.) After the ~10 seconds it has finished loading satellites data in the background and crashes. (Segmentation fault.)

Log of the last run:
Code:
[D] unknown:0 - QML debugging is enabled. Only use this in a safe environment.
 -------------------------------------------------------
[ This is Stellarium 0.12.3 - http://www.stellarium.org ]
[ Copyright (C) 2000-2013 Fabien Chereau et al          ]
 -------------------------------------------------------
Writing log file to: "/home/nemo/.stellarium/log.txt"
File search paths:
  0 .  "/home/nemo/.stellarium"
  1 .  "/usr/share/stellarium"
Attempting to use an existing older config file.
Config file is:  "/home/nemo/.stellarium/config.ini"
Couldn't load translations for language  "system"
Empty translation file for language  "system"
Using Wayland-EGL
Cache directory is:  "/home/nemo/.cache/stellarium/Stellarium Mobile"
Couldn't load translations for language  "en_US"
Empty translation file for language  "en_US"
Sky language is  "en_US"
Couldn't load translations for language  "en_US"
Empty translation file for language  "en_US"
Application language is  "en_US"
Loading Solar System data ...
Found an old starsConfig.json file, upgrade..
Creates file  "/home/nemo/.stellarium/stars/default/starsConfig.json"
Loading star data ...
"Loading \"/usr/share/stellarium/stars/default/stars_0_0v0_3.cat\": 0_0v0_2; 4963"
"Loading \"/usr/share/stellarium/stars/default/stars_1_0v0_3.cat\": 1_0v0_2; 21598"
"Loading \"/usr/share/stellarium/stars/default/stars_2_0v0_3.cat\": 2_0v0_2; 150090"
"Loading \"/usr/share/stellarium/stars/default/stars_3_1v0_2.cat\": 3_1v0_1; 423540"
"file not found: stars/default/stars_4_1v0_0.cat"
"file not found: stars/default/stars_5_2v0_0.cat"
"file not found: stars/default/stars_6_2v0_0.cat"
"file not found: stars/default/stars_7_2v0_0.cat"
"file not found: stars/default/stars_8_2v0_0.cat"
Finished loading star catalogue data, max_geodesic_level:  3
Warning: location "auto" is unknown.
navigation/preset_sky_time is a double - treating as jday: 2.45151e+06
Loaded 10051 NGC records
Loading NGC name data ...
Loaded 412 / 412 NGC name records successfully
Use vertex shader for atmosphere rendering.
Satellites::init copied default satellites.json to  "/home/nemo/.stellarium/modules/Satellites/satellites.json"
Satellites: loading catalog file: "/home/nemo/.stellarium/modules/Satellites/satellites.json"
Loading star names from "/usr/share/stellarium/skycultures/western/star_names.fab"
Loaded 236 / 236 common star names
Loading star names from "/usr/share/stellarium/stars/default/name.fab"
Loaded 4359 / 4359 scientific star names
Loading variable stars from "/usr/share/stellarium/stars/default/gcvs_hip_part.dat"
Loaded 6886 / 6886 variable stars
Loaded 88 / 88 constellation records successfully for culture "western"
Loaded 85 / 85 constellation art records successfully for culture "western"
Loaded 89 / 89 constellation names
Loading constellation boundary data ... 
Loaded 782 constellation boundary segments
StelPainter: initGLShaders()... 
StelPainter: initGLShaders()... done
action "actionShow_Satellite_hints" not found
Satellites: starting Internet update...
Starts downloading  QUrl("http://celestrak.com/NORAD/elements/tle-new.txt")
Starts downloading  QUrl("http://celestrak.com/NORAD/elements/science.txt")
Starts downloading  QUrl("http://celestrak.com/NORAD/elements/noaa.txt")
Starts downloading  QUrl("http://celestrak.com/NORAD/elements/goes.txt")
Starts downloading  QUrl("http://celestrak.com/NORAD/elements/amateur.txt")
Starts downloading  QUrl("http://celestrak.com/NORAD/elements/gps-ops.txt")
Starts downloading  QUrl("http://celestrak.com/NORAD/elements/galileo.txt")
Starts downloading  QUrl("http://celestrak.com/NORAD/elements/iridium.txt")
Starts downloading  QUrl("http://celestrak.com/NORAD/elements/geo.txt")
Satellite has invalid orbit: "CZ-4B DEB" "33411"
Satellites: update finished. 0 / 0 updated, 146 added, 0 missing or removed. 936 source entries parsed.
Process killed by signal
 

The Following 6 Users Say Thank You to Mara For This Useful Post:
Mara's Avatar
Posts: 1,298 | Thanked: 772 times | Joined on Mar 2006 @ Irving, TX
#24
I have now Stellarium Mobile running on my Sailfish device (Moto G4 Plus). It is now usable and doesn't crash anymore.

There are still major bugs that I need to resolve before thinking releasing this into public:
- GUI elements/buttons and skycultures are too big. Need to find some global scaling factor setting?
- Nebula pictures are not shown due to incorrect storage path defined somewhere I have not yet found.

Bonus:
- Artificial satellites are supported!

This is pretty much full/complete stellarium and rpm-package weights ~64MB. May need rather capable device to run properly. (On my octa-core 4GB RAM Moto G4 plus it works quite smoothly.)

The GUI is same as you can see in Android version.

I have looked at the Stellarium SF as well but it might need more work to get working. It works on Sailfish emulator (which uses SW OpenGL renderer?) but fails on device supporting HW OpenGL renderer. It might be easy fix? Hard part is to find it...

EDIT: Nebulas are working...

Last edited by Mara; 2017-12-18 at 01:22.
 

The Following 13 Users Say Thank You to Mara For This Useful Post:
Posts: 39 | Thanked: 89 times | Joined on May 2015
#25
Edited /home/nemo/.stellarium-sf/config.ini to adjust screen resolution for Xperia X. This didn't fix the Xperia issue mentioned above.

Stellarium-sf okay on my 'old' Jolla1.

(version 0.9.1)

Last edited by objectifnul; 2017-12-17 at 23:58.
 

The Following 4 Users Say Thank You to objectifnul For This Useful Post:
Mara's Avatar
Posts: 1,298 | Thanked: 772 times | Joined on Mar 2006 @ Irving, TX
#26
I have uploaded my first beta into Warehouse. You can download it from there.
https://openrepos.net/content/matsav/stellarium-sfm

The known bugs (too big buttons and skycultures) are still present. In addition I noticed that I can not launch the application from the icon for some reason. Workaround is to launch it from terminal using command "stellarium".

Good luck... I'll be curious to hear if (and how well?) it works with different Sailfish devices, including the older Jolla phones?

EDIT: Moving forward I'll put my effort on getting the Stellarium-sf version working due to it having the proper GUI for Sailfish devices.

EDIT2: I have stored my source code to Github:
https://github.com/Matsavol/stellarium-SFM-master

Last edited by Mara; 2017-12-30 at 02:54. Reason: new github link
 

The Following 17 Users Say Thank You to Mara For This Useful Post:
Posts: 39 | Thanked: 89 times | Joined on May 2015
#27
Sadly, doesn't work on Xperia X (2.1.3.7). Uses 79 Mb of system memory (/usr/share/stellarium/).

Oops.It works from terminal. Sorry. Too big buttons indeed. No landscape orientation. Note: still working after I converted /usr/share/stellarium/ into a symlink to save system space (because rootfs partition is very tiny on Xperia).

Last edited by objectifnul; 2017-12-19 at 09:41. Reason: Terminal launch
 

The Following 4 Users Say Thank You to objectifnul For This Useful Post:
Mara's Avatar
Posts: 1,298 | Thanked: 772 times | Joined on Mar 2006 @ Irving, TX
#28
Status of the Stellarium SFM (SailFish Mobile):

Last graphical bugs (Skycultures and GUI elements too big) have been resolved.

Only the "can't open app from icon" bug still exists. This is tough since I haven't been able to capture any debugging logs when launched this way? I'm open to suggestion what to try...

I'm wondering if my development environment (Sailfish SDK on WIndows 10 PC) has something to do with this, but then other (smaller) example projects I tried don't have this issue...
 

The Following 7 Users Say Thank You to Mara For This Useful Post:
Posts: 1,093 | Thanked: 2,769 times | Joined on Apr 2011 @ Netherlands
#29
Originally Posted by Mara View Post
Status of the Stellarium SFM (SailFish Mobile):

Only the "can't open app from icon" bug still exists. This is tough since I haven't been able to capture any debugging logs when launched this way? I'm open to suggestion what to try...

I'm wondering if my development environment (Sailfish SDK on WIndows 10 PC) has something to do with this, but then other (smaller) example projects I tried don't have this issue...
It fails with:

Code:
mapplauncherd[13660]: Booster: Failed to invoke: Booster: Loading symbol 'main' failed: '/usr/bin/stellarium: undefined symbol: main'
Changing
Code:
X-Nemo-Application-Type=silica-qt5
to
Code:
X-Nemo-Application-Type=no-invoker
in your desktop file will help.

And one more thing: please don't upload split tar files as sources to github, but upload the source tree and additional commits itself.
 

The Following 6 Users Say Thank You to ade For This Useful Post:
Mara's Avatar
Posts: 1,298 | Thanked: 772 times | Joined on Mar 2006 @ Irving, TX
#30
Originally Posted by ade View Post
It fails with:

Code:
mapplauncherd[13660]: Booster: Failed to invoke: Booster: Loading symbol 'main' failed: '/usr/bin/stellarium: undefined symbol: main'
Changing
Code:
X-Nemo-Application-Type=silica-qt5
to
Code:
X-Nemo-Application-Type=no-invoker
in your desktop file will help.

And one more thing: please don't upload split tar files as sources to github, but upload the source tree and additional commits itself.
Thanks ade! The desktop file modification did the trick.

The github thing I got lazy... When I tried to upload my source files tree in there it either complained I had too many files, or (single compressed) file was too big. To solve that I just packed my sources into multi-tar files to get around those limitations. I'll see how I can get the files uploaded properly now that the Stellarium SFM is actually working/useful project.

Aside the Stellarium-sf port I haven't been able to figure out the problem. When I played with it on Sailfish emulator the GUI is not really working that well (in my opinion), and is missing some features that the Stellarium SFM has... so I'm not going to pursue that port any further.

I should be pushing update to the openrepos soon...
 

The Following 5 Users Say Thank You to Mara For This Useful Post:
Reply

Tags
crash, question, stellarium

Thread Tools

 
Forum Jump


All times are GMT. The time now is 00:29.