Notices


Reply
Thread Tools
Posts: 318 | Thanked: 825 times | Joined on Aug 2013
#3251
Originally Posted by sulu View Post
Are your N900s running kernel power? The armhf images need it.
Yes, I think that is the problem as well. I think kernel power was not copied from the original N900 using backup menu so probably needs to be (re-)installed or fixed. Haven't got access to the backup N900 right now, so cannot do a uname -r to check.

Last time I used the backup N900 I checked the application manager and I only had the option to un-install kernel power so it appeared to be installed. Didn't check the kernel version then.

Maybe I need to do a re-install.

apt-get install --reinstall -y kernel-power kernel-power-flasher

Will give it a try tomorrow.
 
Posts: 168 | Thanked: 190 times | Joined on Mar 2013
#3252
Originally Posted by sulu View Post
Are your N900s running kernel power? The armhf images need it.
No kernel power for me on my second N900.
Will look into this next days as I don't have time right now.
We will see if it works after installing kernel power.
 
Posts: 318 | Thanked: 825 times | Joined on Aug 2013
#3253
Originally Posted by t-b View Post
apt-get install --reinstall -y kernel-power kernel-power-flasher

Will give it a try tomorrow.
I can confirm this worked. Backup menu is not copying the kernel (seems kinda obvious in hindsight) but using the reinstall option works fine.
 

The Following User Says Thank You to t-b For This Useful Post:
Posts: 168 | Thanked: 190 times | Joined on Mar 2013
#3254
Just had time to try this, and I also confirm that once kernel power installed the armhf image works.

Thanks.
 
Posts: 168 | Thanked: 190 times | Joined on Mar 2013
#3255
Hey,

I seem to have some trouble to upgrade debian_jessie2sulu_armhf image.
At first when I did a "apt-get update && apt-get upgrade" I had an error of this kind (translating to English, so the error message could be different but the idea is the same) :

Code:
dpkg : unrecoverable fatal error, abandon
group crontab unknown in the permissions file (statoverride)
E: Sub-process /usr/bin/dpkg returned an error code (2)
So after some research I did as root :

Code:
mv /var/lib/dpkg/statoverride /var/lib/dpkg/statoverride.bak
And the problem seemed to be solved, but now I have a second error about libc6_2.19-18+deb8u6_armhf.deb :

Code:
WARNING: this version of the GNU libc requires kernel version 2.6.32 or later. Please upgrade your kernel before installing glibc.
The installation of a 2.6 kernel _could_ ask you to install a new libc first, this is NOT a bug, and should *NOT* be reported. In that case, please add lenny sources to your /etc/apt/sources.list and run:
apt-get install -t lenny linux-image-2.6
Then reboot into this new kernel, and proceed with your upgrade
Should I do that? From what I know the Debian image is using the Maemo kernel (?) so I can't really upgrade that (true?). How to solve this, because I can't upgrade the system and can't install new packages.

Has anyone any idea?
 

The Following User Says Thank You to Malakai For This Useful Post:
Posts: 318 | Thanked: 825 times | Joined on Aug 2013
#3256
Originally Posted by Malakai View Post
And the problem seemed to be solved, but now I have a second error about libc6_2.19-18+deb8u6_armhf.deb :
Version of libc in the image is created by sulu and is version glibc_2.19-18+deb8u4. glibc is updated in the repo but it is not compatible with the kernel that is why we needed sulu to create a compatible version before.
For now I suggest to ignore the update and put the package on hold (I probably should have done that in the image..).

Changes are mentioned below - not sure if the updates are really needed.
https://launchpad.net/debian/+source...2.19-18+deb8u6
 

The Following 4 Users Say Thank You to t-b For This Useful Post:
Posts: 768 | Thanked: 2,406 times | Joined on Jan 2011 @ Germany
#3257
What a coincidence!
Just this week I tried to create a first Stretch image, and took the chance to also build some new glibc packages for Jessie. [1]

As for Stretch, I have bad news. Stretch comes with glibc 2.24 and some essential software in Stretch makes it mandatory to ship at least 2.23. I managed to build 2.23 for kernel 2.6.28, but actually running that build on the Maemo kernel immediately causes a segfault.
So unless someone (certainly not me) plans to either bring a more recent kernel to Maemo (at least 2.6.32, preferably 3.2 or newer), or restores glibc's ability to run on kernel 2.6.28 just for us, Jessie will be the last Easy Debian release ever.


[1] http://www38.zippyshare.com/v/TToYMdN7/file.html
 

The Following 4 Users Say Thank You to sulu For This Useful Post:
Posts: 168 | Thanked: 190 times | Joined on Mar 2013
#3258
Originally Posted by t-b View Post
Version of libc in the image is created by sulu and is version glibc_2.19-18+deb8u4. glibc is updated in the repo but it is not compatible with the kernel that is why we needed sulu to create a compatible version before.
For now I suggest to ignore the update and put the package on hold (I probably should have done that in the image..).

Changes are mentioned below - not sure if the updates are really needed.
https://launchpad.net/debian/+source...2.19-18+deb8u6
Even when putting the package on hold I can't seem to install new packages ; I get a dependency error for the following packages : libc6-dbg, libc6-dev, libc6-pic.

And when I want to install vim I get :

Code:
vim : Depends: vim-runtime (= 2:7.4.488-7) but it is not going to be installed
Depends: libgpm2 (>= 1.20.4) but it is not going to be installed

E: Unmet dependencies. Try 'apt-get -f install'  with no packages (or specify a solution).
What should I do now?

Originally Posted by sulu View Post
What a coincidence!
Just this week I tried to create a first Stretch image, and took the chance to also build some new glibc packages for Jessie. [1]

[1] http://www38.zippyshare.com/v/TToYMdN7/file.html
Sorry to ask a maybe basic question, but what should I do with that package? Or maybe should I ask where to uncompress it?

Originally Posted by sulu View Post
As for Stretch, I have bad news. Stretch comes with glibc 2.24 and some essential software in Stretch makes it mandatory to ship at least 2.23. I managed to build 2.23 for kernel 2.6.28, but actually running that build on the Maemo kernel immediately causes a segfault.
So unless someone (certainly not me) plans to either bring a more recent kernel to Maemo (at least 2.6.32, preferably 3.2 or newer), or restores glibc's ability to run on kernel 2.6.28 just for us, Jessie will be the last Easy Debian release ever.
Too sad... this will mean the end of an up to date Debian system on our N900... really waiting for the Neo900 now.
 

The Following User Says Thank You to Malakai For This Useful Post:
Posts: 768 | Thanked: 2,406 times | Joined on Jan 2011 @ Germany
#3259
Originally Posted by Malakai View Post
Even when putting the package on hold I can't seem to install new packages ; I get a dependency error for the following packages : libc6-dbg, libc6-dev, libc6-pic.
Can you post this output please:
Code:
dpkg -l | grep libc
I suspect that some of the packages you want to install depend on the libc6 packages you mentioned. Those are not installed by default and once they get an update from Debian my patched packages won't be compatible anymore.
That's why I upload update archives from time to time. These archives include the full set of patched glibc packages so you can manually install (dpkg -i) them.

Originally Posted by Malakai View Post
And when I want to install vim I get :

Code:
vim : Depends: vim-runtime (= 2:7.4.488-7) but it is not going to be installed
Depends: libgpm2 (>= 1.20.4) but it is not going to be installed

E: Unmet dependencies. Try 'apt-get -f install'  with no packages (or specify a solution).
What should I do now?
What happens if you run apt-get -f install ?

Originally Posted by Malakai View Post
Too sad... this will mean the end of an up to date Debian system on our N900...
Well, it was always just a matter of time. Back then I was actually quite surprised that I got Jessie to run at all.
I think in the grand scheme of things we just have to realize that the N900 is a legacy device now, not because it is slow but because its software is basically unmaintainable, and we're hitting increasingly harder walls as time goes on.

The only thing I can offer now is to try to build Jessie backports on demand for software that is available in Stretch.
 

The Following 8 Users Say Thank You to sulu For This Useful Post:
Posts: 168 | Thanked: 190 times | Joined on Mar 2013
#3260
Originally Posted by sulu View Post
Can you post this output please:
Code:
dpkg -l | grep libc
Code:
ii  glibc-doc                          2.19-18+deb8u4                    all          GNU C Library: Documentation
ii  glibc-source                       2.19-18+deb8u4                    all          GNU C Library: sources
ii  libc-bin                           2.19-18+deb8u6                    armhf        GNU C Library: Binaries
iU  libc-dev-bin                       2.19-18+deb8u6                    armhf        GNU C Library: Development binaries
ii  libc6:armhf                        2.19-18+deb8u4                    armhf        GNU C Library: Shared libraries
iU  libc6-dbg:armhf                    2.19-18+deb8u6                    armhf        GNU C Library: detached debugging symbols
iU  libc6-dev:armhf                    2.19-18+deb8u6                    armhf        GNU C Library: Development Libraries and Header Files
iU  libc6-pic:armhf                    2.19-18+deb8u6                    armhf        GNU C Library: PIC archive library
ii  libcairo2:armhf                    1.14.0-2.1+deb8u1                 armhf        Cairo 2D vector graphics library
ii  libcap-ng0:armhf                   0.7.4-2                           armhf        An alternate POSIX capabilities library
ii  libcap2:armhf                      1:2.24-8                          armhf        POSIX 1003.1e capabilities (library)
ii  libcap2-bin                        1:2.24-8                          armhf        POSIX 1003.1e capabilities (utilities)
ii  libcdparanoia0:armhf               3.10.2+debian-11                  armhf        audio extraction tool for sampling CDs (library)
ii  libcomerr2:armhf                   1.42.12-1.1                       armhf        common error description library
ii  libcroco3:armhf                    0.6.8-3+b1                        armhf        Cascading Style Sheet (CSS) parsing and manipulation toolkit
ii  libcryptsetup4:armhf               2:1.6.6-5                         armhf        disk encryption support - shared library
ii  libcups2:armhf                     1.7.5-11+deb8u1                   armhf        Common UNIX Printing System(tm) - Core library
ii  libcurl3-gnutls:armhf              7.38.0-4+deb8u3                   armhf        easy-to-use client-side URL transfer library (GnuTLS flavour)
ii  liblocale-gettext-perl             1.05-8+b1                         armhf        module using libc functions for internationalization in Perl
iU  linux-libc-dev:armhf               3.16.36-1+deb8u1                  armhf        Linux support headers for userspace development
Originally Posted by sulu View Post
What happens if you run apt-get -f install ?
Code:
dpkg: error processing archive /var/cache/apt/archives/libc6_2.19-18+deb8u6_armhf.deb (--unpack) :
subprocess new pre-installation script returned error exit status 1
Errors were encountered while processing:  
/var/cache/apt/archives/libc6_2.19-18+deb8u6_armhf.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
Should I install the archive you provided with dpkg -i?
 

The Following User Says Thank You to Malakai For This Useful Post:
Reply

Tags
beta, debian, easy debian, extras-devel, fremantle, i <3 qole, squeeze

Thread Tools

 
Forum Jump


All times are GMT. The time now is 19:31.