Notices


Reply
Thread Tools
omeriko9's Avatar
Posts: 385 | Thanked: 344 times | Joined on Jan 2010 @ Israel
#1
Hi,

I've downloaded and mounted the "out-of-the-box" image of ubuntu with ESBox wrapped inside.

I'm trying to compile & run the Pyside sample project called "pyqthelloworld".

The code does not compiles, and gives the error specified in the subject:

"ImportError: No module names PyQt4".

Please assist, what am I doing wrong?
 
Posts: 3,319 | Thanked: 5,609 times | Joined on Aug 2008 @ Finland
#2
If you're using PySide that should be import PySide and not PyQt4...
__________________
Blogging about mobile linux - The Penguin Moves!
Maintainer of PyQt (see introduction and docs), AppWatch, QuickBrownFox, etc
 
omeriko9's Avatar
Posts: 385 | Thanked: 344 times | Joined on Jan 2010 @ Israel
#3
Originally Posted by attila77 View Post
If you're using PySide that should be import PySide and not PyQt4...
Sorry, I thought that Python+Qt4 on n900 is called Pyside.

So I'm not using Pyside, I'm using PyQt4. And it's not me actually, it's the pyqt helloworld that comes with ESBox.

Last edited by omeriko9; 2010-01-28 at 17:31.
 
Posts: 3,428 | Thanked: 2,855 times | Joined on Jul 2008
#4
You need to first install the python2.5-qt4 files

Code:
apt-get install python2.5-qt4-gui
and maybe the dev files:
Code:
apt-get install python2.5-qt4-dev python2.5-qt4-dev-tools
ETA: Make sure you're using python2.5 as well if in the SDK.
__________________
If I've helped you or you use any of my packages feel free to help me out.
-----------------------------------------------------------------------------------
Maintaining:
pyRadio - Pandora Radio on your N900, N810 or N800!

Last edited by fatalsaint; 2010-01-28 at 03:58.
 

The Following 3 Users Say Thank You to fatalsaint For This Useful Post:
omeriko9's Avatar
Posts: 385 | Thanked: 344 times | Joined on Jan 2010 @ Israel
#5
Originally Posted by fatalsaint View Post
You need to first install the python2.5-qt4 files

Code:
apt-get install python2.5-qt4-gui
and maybe the dev files:
Code:
apt-get install python2.5-qt4-dev python2.5-qt4-dev-tools
ETA: Make sure you're using python2.5 as well if in the SDK.
OMG thank you!!! that was exactly what I was missing!!

Now it compiles and runs and finally I can start developing for n900..
 
Reply

Thread Tools

 
Forum Jump


All times are GMT. The time now is 12:44.