Notices


Reply
Thread Tools
Posts: 726 | Thanked: 2,164 times | Joined on Jan 2011 @ Germany
#1
Hi,

I just ran into a very strange problem.
step by step:

1. I took a backup N900 out of my closet that's never been powered on (PR1.3 preinstalled).
2. I installed rootsh and openssh-server via HAM.
3. I successfully ssh'ed into the N900 via wifi from my desktop-PC (Debian Wheezy).
4. I swapped home and mydocs partitions according to [1] (this involved a reboot).
5. I successfully ssh'ed into the N900 via wifi again.
6. I installed CSSU stable according to [2] (including the reboot).
7. I installed kernel-power v52 and rebooted the N900.
8. I tried to ssh into the N900 again but always get this error:
Code:
~$ ssh root@192.168.1.6
root@192.168.1.6's password: 
Permission denied, please try again.
9. I un- and reinstalled ssh-server several times, via HAM, via apt-get (with and without purge), deleted /etc/ssh but always get the same error, not only from my PC but also from my HTPC (also running Debian). I have not made any changes to the N900's default ssh configuration (/etc/sshd_config attached).

Question:
Has anybody ever seen something like this? Is this CSSU/KP-related? If not, what's going on here?

Otherwise wifi from the N900 works just fine. I can ping the N900 from my PC, I can ssh from the N900 to the PC and I can browse the internet.


[1] http://wiki.maemo.org/Repartitioning...Docs_partition
[2] https://wiki.maemo.org/Community_SSU#Installation
Attached Files
File Type: txt n900_sshd_config.txt (1.9 KB, 53 views)

Last edited by sulu; 2014-01-02 at 15:34.
 

The Following User Says Thank You to sulu For This Useful Post:
Estel's Avatar
Posts: 5,029 | Thanked: 8,593 times | Joined on Mar 2011
#2
Try changing StrictModes to look like:
Code:
StrictModes no
...in /etc/ssh/sshd_config

I remember having exact same issues (albeit I was using publickey auth, only), for reasons unknown. I *ensured* that all files are owned correctly, and permissions are *not* set to "allow write" for world., still, strictmode was kicking in.

I scratched my head about it for a while, then just shrugged and left it as "no", cause I maintain correct permissions for my ssh configs, anyway. Still, it is very interesting, that you run into it just after installing CSSU, not ssh-server update, as I thought - it may be worthwile to left a note to CSSU guys, then.

Of course, only if it really help in your case as I suspect - otherwise all of the above is moot

/Estel
__________________
N900's aluminum backcover / body replacement
-
N900's HDMI-Out
-
Camera cover MOD
-
Measure battery's real capacity on-device
-
TrueCrypt 7.1 | ereswap | bnf
-
Hardware's mods research is costly. To support my work, please consider donating. Thank You!
 

The Following User Says Thank You to Estel For This Useful Post:
Posts: 726 | Thanked: 2,164 times | Joined on Jan 2011 @ Germany
#3
It turned out that I mixed up my devices (productive vs. testing) and for some reason set up a different ssh password on the testing device which I was now trying to use on the producttive one.

I guess I shouldn't do such things with a new-years hangover.
Thanks anyway!
 

The Following 4 Users Say Thank You to sulu For This Useful Post:
Reply

Thread Tools

 
Forum Jump


All times are GMT. The time now is 14:04.