Notices


Reply
Thread Tools
Posts: 25 | Thanked: 56 times | Joined on Jul 2016 @ Where do I live?
#1
I have recently been trying to install Metasploit Framework in my Nokia N900.

Whenever I try to run it using
Code:
ruby msfconsole
, I get the following message:

Code:
../msfconsole:117:in `require': no such file to load -- rex (LoadError) from ../msfconsole:117


Has anybody experienced the same?
 
Posts: 895 | Thanked: 2,908 times | Joined on Oct 2014
#2
perhaps

gem install rex

?
 
Posts: 25 | Thanked: 56 times | Joined on Jul 2016 @ Where do I live?
#3
Originally Posted by nieldk View Post
perhaps

gem install rex

?
Code:
/bin/sh: gem: not found
If I try to apt-get install rubygems, I will get a 'package not found'.

Also, there's a rex folder in my instllation path, but the script does not seem to find it.
 
Posts: 25 | Thanked: 56 times | Joined on Jul 2016 @ Where do I live?
#4
UPDATE:

I installed the latest Rubygems from its official website, and wgot rex 1.0.2 (the one compatible with my Ruby version (1.8.7)) from their old gems repo.

It seems, though, that Metasploit is still not able to see where is it installed...
 
Reply

Tags
fremantle, metasploit, pwnphone

Thread Tools

 
Forum Jump


All times are GMT. The time now is 11:59.