Notices


Reply
Thread Tools
Posts: 529 | Thanked: 1,425 times | Joined on Feb 2012 @ Germany
#11
@jonwil bumping up the version would be better also maybe use the latest source code for your patches. In the repositority there is already a version 0.0.37.
 

The Following 2 Users Say Thank You to Halftux For This Useful Post:
Posts: 538 | Thanked: 2,744 times | Joined on Oct 2009
#12
What repository?
 

The Following User Says Thank You to jonwil For This Useful Post:
pichlo's Avatar
Posts: 5,324 | Thanked: 16,231 times | Joined on Sep 2012 @ UK
#13
Originally Posted by jonwil View Post
What repository?
The repository?
__________________
In particle accelerators atoms are indeed not only touching each others. But banging together in a massive explosive orgasm.
-- nieldk in a TMO post
 

The Following User Says Thank You to pichlo For This Useful Post:
Posts: 538 | Thanked: 2,744 times | Joined on Oct 2009
#14
Thanks, I wasn't sure if you were talking about a Git repo or something or the maemo apt repository.
I will do some more work on it soon (including bumping the version number on QT and uploading the packages for it to community-devel just to make it easy for people to grab them)
 

The Following User Says Thank You to jonwil For This Useful Post:
Posts: 538 | Thanked: 2,744 times | Joined on Oct 2009
#15
I have released another new version, this time with proper changelogs and stuff.
I bumped the version number on qt4-x11. The source can be found at https://github.com/community-ssu/qt-x11-maemo and the binaries I compiled can be found at http://maemo.merlin1991.at/cssu/comm...ree/q/qt4-x11/ (I stuck them in cssu-devel as an easy way to share them all without needing to find some file space that could hold all those large files and yes I know CSSU is basically dead at this point)

The latest Fahrplan source code (which requires the new QT version given above to be installed into your build environment in order to compile) is at https://github.com/jonwil/fahrplan and the binary is attached to this post. To make it work you need the new QT bits given above plus the QJson bits linked elsewhere in this thread. You may need other upgraded things from CSSU as well, I dont know for sure what might be needed, if anything (I am running the latest version of cssu-testing and all the packages contained therein)

The changes made since the last version I posted are:
Bump the version number to 0.37
Update the changelog
Update the dependencies so Fahrplan depends on the new QT version
Include the "Fixed parsing DB detail view when flaparrow is closed" change from the Fahrplan version in extras-devel.

I would still like to figure out something useful to do with maps but otherwise I have no plans to do anything more to Fahrplan at this time (if someone else wants to make further changes to it for whatever reason, I am happy to include those into my git repository if need be)
Attached Files
File Type: deb fahrplan_0.0.37_armel.deb (235.6 KB, 25 views)
 

The Following 3 Users Say Thank You to jonwil For This Useful Post:
Posts: 538 | Thanked: 2,744 times | Joined on Oct 2009
#16
Released another update to Fahrplan to support TLS 1.2 in the Translink parser and update the journey planner URLs to the new ones.
Source is at https://github.com/jonwil/fahrplan and binary is attached to this post.

You will need the new OpenSSL (source is at https://github.com/jonwil/openssl/ and binaries are at http://maemo.merlin1991.at/cssu/comm...ree/o/openssl/ ) and the new QT (source is at https://github.com/community-ssu/qt-x11-maemo and binaries are at http://maemo.merlin1991.at/cssu/comm...ree/q/qt4-x11/ ) plus the QJson bits linked elsewhere in this thread.

Unsure if you need any other bits from CSSU or not.

Its working on my own N900 as of now and I can properly journey plan with Fahrplan again.
 

The Following 3 Users Say Thank You to jonwil For This Useful Post:
Reply

Thread Tools

 
Forum Jump


All times are GMT. The time now is 06:42.