Notices


Reply
Thread Tools
Posts: 529 | Thanked: 46 times | Joined on Sep 2007
#1
Hi
updated maemo-mapper to 2.6.2
and old receiver_mac address looks to be hardcoded
as searching for GPS receiver failed


MM >Settings > Bluetooth and Scan fields
are not active
old mac value in Bluetooth field

reset mac address to new value with gconftool-2
unfortunately mamemo-mapper loads old mac address
as previously.

Please tell me if you can use remore bluetooth gps device
in maemo-mapper 2.6.2
and how to get mm to read new mac address of bluetooth gps device ?

Can connect bt gps device from maemo general bluetooth applet.
 
Posts: 32 | Thanked: 8 times | Joined on Sep 2008
#2
install an older version of maemo mapper, as described here:

http://talk.maemo.org/showthread.php?t=30850
 
Posts: 529 | Thanked: 46 times | Joined on Sep 2007
#3
Thanks cecil,

I don't want to install older version of mm as it makes no sense,
as I upgraded mm to 2.6.2 to get new features.

2 years ago the same problem appeared
and all one has to do is to tweak libraries
as I run 2007He + mm 2.6.2
I am looking for a working manual
step-by-step on what gpsd library is valid
for 2007He + mm 2.6.2.

I appended my reply to the same thread in N800

http://talk.maemo.org/showthread.php?t=24772

but no reply.

Nokia is no more supporting Nokia 770,N800, N810.

Last edited by Darius2006; 2009-12-27 at 22:01.
 
Posts: 529 | Thanked: 46 times | Joined on Sep 2007
#4
@cecil

I am back with my old (2 years old) thread discussing the same

http://talk.maemo.org/showthread.php...highlight=j800

Followed manual and failed (new libraries)

http://packages.debian.org/sid/gpsd/armel/download

(was earlier)
http://packages.debian.org/lenny/armel/gpsd/download

today

sid replaced by lenny

Tried really hard and failed.

Edited rfcomm0 manually

The issue maemo mapper Settings
comes
with
/dev/pgps
and GPSD Host 127.0.0.1
predefined

so can not select
/dev/rfcomm0

but have to try again
in MM, open the settings dialog and choose the 'file path' option with "/dev/rfcomm0" as the path

ok, edited /dev/rfcomm0
with configuration tool run from CLI

Can connect to bluetooth device from maemo
can't force maemo mapper to run rfcomm0
to get connected to gps
 
Posts: 529 | Thanked: 46 times | Joined on Sep 2007
#5
finally a solution
patched maemo mapper 2.6.2
works fine on Nokia 770, 2007He
no more grayed out input fields in MM Settings

abbreviated web link to deb file
http://tinyurl.com/maemo262

from
http://talk.maemo.org/showthread.php?t=34318
"
===
TA-t3

I have no idea if this will really work for OS2007HE and the 770, but you could try my patched version of maemo mapper 2.6.2 which you can find in this post:
http://talk.maemo.org/showpost.php?p=319596&postcount=1

I patched the original 2.6.2 and rebuilt for OS2007, because the original would not let me select a bluetooth GPS (or search for one).
__________________
N800/OS2007
-- Metalayer-crawler delenda est.
====
"

Last edited by Darius2006; 2009-12-30 at 22:54.
 
Posts: 2 | Thanked: 0 times | Joined on Jan 2010
#6
hi, i tried installation in my N770 with 2007HE os. it does allow to select bluetooth gps. but, it followed by data error. the gps connection is not working. any solution?
 
Posts: 529 | Thanked: 46 times | Joined on Sep 2007
#7
Fully recharge your gps bluetooth device
set to on to see if it can get fix outdoor.

Run MM 2.6.2 patched (as above)
from menu go to Settings
and look at entries (not greyed out)

( ) Bluetooth some Mac address or none run Scan
bt gps discovery
File path /dev/pgps
GPSD Host 127.0.0.1 port 2947


Scanning for Bluetooth Devices .....................

Select your Bluetooth Device ( your bt gps device)
OK

Menu > Settings > OK

You are back in MM
Menu > GPS > Enable GPS

Searching for GPS receiver ..............................
 
Posts: 2 | Thanked: 0 times | Joined on Jan 2010
#8
Thanks Darius,
I flashed my N770 to 2007HE version 4 (year 2008). Then tried a few times. But it still won't work for GPS although I can see the all three lights are flashing. But N770 won't connect to gps. Occasionally, it connected, but it does not show in maemo mapper.
The Navicore works fine in my N770. Please any help will be much appreciated.
 
Posts: 529 | Thanked: 46 times | Joined on Sep 2007
#9
It worked for me on 2007He
then I flashed 770 to 2008He and geolocation is on,
gps is ok in MM and can be shared by a number of
gps-based apps installed, as gps location comes with OS2008He.

Have a try. 2008He is an excellent piece of job by Nokia
to make your N770 to flash again.
 
Reply

Thread Tools

 
Forum Jump


All times are GMT. The time now is 00:15.