Notices


Reply
Thread Tools
karlos devel's Avatar
Posts: 137 | Thanked: 392 times | Joined on Mar 2013 @ Guate
#21
Originally Posted by Schturman View Post
Hi to all..
For some reasons I can't update all my 3 devices (Jolla1, C and Tablet)
1. It took too much time (few hours) for download till I get message "Ready to install"
2. When tried to install, it always failed and it rebooting into 2.1.4.14
3. After each reboot it again showing me "Ready to install" instead of "Check for updates" or "Download..."
4. Tried via terminal too, but always getting this message:

Code:
Fatal error: File '/repodata/repomd.xml' not found on medium 'https://store-repository.jolla.com/releases/2.2.0.29/aliendalvik//?credentials=store'
Any idea how to fix it and update my devices ?
Thanks
rm /home/nemo/.local/share/system/privileged/Notifications/notifications.db To fix notifications.
If still persist the issues on update the OS, uninstall thirdparty master package if has.

Last edited by karlos devel; 2018-06-01 at 03:38.
 

The Following 4 Users Say Thank You to karlos devel For This Useful Post:
karlos devel's Avatar
Posts: 137 | Thanked: 392 times | Joined on Mar 2013 @ Guate
#22
new feature on camera a fake 1600 iso
 

The Following 5 Users Say Thank You to karlos devel For This Useful Post:
Posts: 61 | Thanked: 309 times | Joined on Aug 2017
#23
So, while removing all those unneeded account-extensions packages for sociald and jolla-settings, I stumbled upon this interesting package:

Code:
Available   	jolla-settings-accounts-extensions-sip-0.3.39-1.6.9.armv7hl (jolla)	Extension plugin for SIP accounts
Code:
[root@Sailfish nemo]# pkcon install jolla-settings-accounts-extensions-sip
Resolving                                                                                                                                                     
Querying                                                                                                                                                      
Testing changes                                                                                                                                               
Finished                                                                                           [                                                ] (0%)  
The following packages have to be installed:
 jolla-settings-accounts-extensions-sip-0.3.39-1.6.9.armv7hl	Extension plugin for SIP accounts
 sofia-sip-1.12.11+git2-1.2.2.armv7hl	Sofia SIP User-Agent library
 sofia-sip-glib-1.12.11+git2-1.2.2.armv7hl	Glib bindings for Sofia-SIP
 telepathy-rakia-0.7.4+git1-1.2.2.armv7hl	SIP connection manager for Telepathy
Proceed with changes? [N/y] y
Edit: Just found out, this package exists since 2.0. Oh well.
 

The Following 3 Users Say Thank You to jenix For This Useful Post:
Posts: 10 | Thanked: 19 times | Joined on Jun 2010
#24
I ran in the same problem as cy8aer (http://talk.maemo.org/showpost.php?p...90&postcount=8). I downloaded only a few minutes after the first problem with the download was solved and tried to install before the second problem was solved.
The installation started fine and the Xperia X got to the Progressbar of the update. There it stayed for >2 hours with no progress at all.
I then rebooted and the old system came up without a problem.
I then decided to try the "version --dup" way for the update.
This worked without problems and I rebooted in 2.2.0.29. The system seems to work without a problem.

My probem is that I still have the update notification.
When I check if there is an update I says my system is Up to date with 2.2.0.29 but the last time the check ran has the shows as bevore the update. Checking again runs in a timeout.
The journal shows the following:

May 31 21:47:41 Sailfish invoker[6103]: invoker: Invoking execution: '/usr/bin/store-client'

May 31 21:47:41 Sailfish [6101]: [D] unknown:0 - System update already in progress. Check request ignored.

...and later...

May 31 21:49:41 Sailfish [6101]: [D] unknown:0 - -- quiting, inactivity timer expired

May 31 21:49:41 Sailfish [6101]: [D] unknown:0 - telling PackageKit daemon to quit

May 31 21:49:41 Sailfish PackageKit[6115]: daemon quit

May 31 21:50:41 Sailfish estart[4296]: [D] unknown:0 - Update check timed out!

rebooting the device over a dozen time by now hasn't changed anything.
To me it looks as if some of the preperations for the update weren't cleaned up after the first update failed and the updater doesn't check anything because he believes to be in the middle of an update.

Does anybody know how to fix this?

Best Regards

Edit:

found a solution for my Problem here:
https://together.jolla.com/question/...#post-id-99219

Last edited by ummon; 2018-06-02 at 16:13. Reason: Found a solution for my problem
 

The Following 6 Users Say Thank You to ummon For This Useful Post:
pichlo's Avatar
Posts: 5,413 | Thanked: 16,664 times | Joined on Sep 2012 @ UK
#25
I think I found a use case Jolla had not considered. Or maybe they had but don't care. Or don't know how to fix it.

In short, the "use WiFi only" setting for dowloading updates is honoured only at the start of the download. A download already in progress is not paused or interrupted when you leave the WiFi area and the network switches to expensive mobile data.

[tl;dr]
I started downloading the update at work, about 30 minutes before going home. Risky but I thought, what the hell. By home time, only about 200 out of 400 MB had been downloaded. I had to leave sharp to collect the kids and cannot dilly-dally, so I closed the Settings app, assuming that the download would be interrupted and I would either resume or start all over again at home. So you can imagine my surprise when I checked it at upon arriving home and found that the download had finished and my credit reduced by amount roughly equivalent to downloading 200 MB through mobile data.
__________________
In particle accelerators atoms are indeed not only touching each others. But banging together in a massive explosive orgasm.
-- nieldk in a TMO post
 

The Following 8 Users Say Thank You to pichlo For This Useful Post:
Schturman's Avatar
Posts: 5,338 | Thanked: 4,119 times | Joined on Jan 2010 @ Israel
#26
Originally Posted by karlos devel View Post
rm /home/nemo/.local/share/system/privileged/Notifications/notifications.db To fix notifications.
If still persist the issues on update the OS, uninstall thirdparty master package if has.
As far as I know, I don't have thirdparty master packages...
I still can't update...
Tried via terminal:
pkcon refresh (same error about dalvik repo)
zypper ref (same error about dalvik repo)
ssu ur (show nothing)
pkcon repo-set-data jolla refresh-now true (no errors)

Don't know what to try else...
 

The Following 2 Users Say Thank You to Schturman For This Useful Post:
Posts: 296 | Thanked: 506 times | Joined on May 2015 @ Italy
#27
Originally Posted by pichlo View Post
I started downloading the update at work, about 30 minutes before going home. Risky but I thought, what the hell. By home time, only about 200 out of 400 MB had been downloaded. I had to leave sharp to collect the kids and cannot dilly-dally, so I closed the Settings app, assuming that the download would be interrupted and I would either resume or start all over again at home. So you can imagine my surprise when I checked it at upon arriving home and found that the download had finished and my credit reduced by amount roughly equivalent to downloading 200 MB through mobile data.
I have 3GB included in my data plan so for me it wouldn't have been a problem...but I always switch off mobile data if I don't need it, especially if I have to pay for it! Never trust what's running in background...
On my brother's Nokia 5800, one of the first days the A-Gps used mobile Internet without asking, stealing more than 10...
Aaah, Symbian was a pain, with whatsapp I had to kill it several times with another app, since it was not possible to turn off mobile data, except of putting it to offline.
 

The Following 3 Users Say Thank You to claustn For This Useful Post:
velox's Avatar
Posts: 330 | Thanked: 1,117 times | Joined on Dec 2009
#28
My First impressions, Xperia X:
  • Update through command line went through beautifully, no stuck notification, no problems with previously updated webkit package.
  • I like the gallery layout the previous layout wasn't my cup of tea. Have not spend more than a few seconds there, though. Did not try camera.
  • Boy, does the keyboard sound get on my nerves. Such a small thing, yet so irritating for me. EDIT: as has been pointed out: This is a OKBoard bug.
  • Fingerprint unlock does not work great for me, though it could have something to do with my huge protective case. Also I was negatively suprised that you have to swipe from the lock screen before using it. I had hoped you wouldn't even have to press the power button that would have been a nice substitute for double-tap-to-wake. Well. EDIT: You don't have to swipe, It was just not registering well for me! Still have to press Power, though.
__________________
slumber: sensors enabled sleep timer for SFOS (translations/input/ appreciated if you've got some spare time)
talefish: directory based audiobook player for SFOS
nofono: ofono restart for SFOS
___
list of i486/noarch packages on openrepos (jolla tablet)

Last edited by velox; 2018-06-01 at 11:52.
 

The Following 3 Users Say Thank You to velox For This Useful Post:
Community Council | Posts: 4,391 | Thanked: 10,913 times | Joined on May 2012 @ Southerrn Finland
#29
In finland everybody has unlimited flat rate plans so it really does not matter whether one uses wlan or 4g.

I guess that's the reason for such slips in SFOS design
 

The Following 6 Users Say Thank You to juiceme For This Useful Post:
benny1967's Avatar
Posts: 3,789 | Thanked: 5,706 times | Joined on Mar 2006 @ Vienna, Austria
#30
What did they do to the gallery? This is so bad. No longer touch friendly, several ways to achieve the same thing, ugly, ... Who on earth is responsible for this?

Also, what is this so called "Emoji-Keyboard" supposed to be? I would have expected something that's at least on par with the keyboard from Openrepos... but those are just a few smiling faces, nothing more. No dogs, no pizza, no beer... Who is going to use this instead of the existing Emoji Keyboard?
 

The Following 11 Users Say Thank You to benny1967 For This Useful Post:
Reply

Thread Tools

 
Forum Jump


All times are GMT. The time now is 07:15.