Reply
Thread Tools
edgedemon's Avatar
Posts: 383 | Thanked: 208 times | Joined on Oct 2009 @ London UK
#181
I have installed ubuntu into virtual box and could do with some help

below is the output from my terminal session when I try to install scratchbox

root@n900-dev:~# sudo ./maemo-scratchbox-install_5.0.sh -u xxxxxx
This script will install Scratchbox 1.0.16 'apophis' release to your computer.

Install options
---------------

Install from packages=apt
Scratchbox install path=/scratchbox
Scratchbox group=sbox
armel compiler=cs2007q3-glibc2.5-arm
i386 compiler=cs2007q3-glibc2.5-i386
armel devkits=perl:debian-etch:qemu:doctools:svn:git
i386 devkits=perl:debian-etch:doctools:svn:git
armel CPU transparency=qemu-arm-sb

Checking for prerequisites
--------------------------

Running as user root... yes
Not running as user root inside fakeroot... yes
Running outside of scratchbox... yes
Scratchbox installation existing... no
Running on Linux kernel... yes
Running on i386 architecture... yes
Host kernel binfmt_misc support... yes
Host kernel VDSO support... no
E: Host kernel VDSO support is incompatible with scratchbox.
E: You can disable VDSO support for this session with
E: 'echo 0 > /proc/sys/vm/vdso_enabled' as root
E: For a permanent solution you may add 'vm.vdso_enabled = 0'
E: to /etc/sysctl.conf and run 'sysctl -p' as root
root@n900-dev:~#


Not sure what option I need to choose???
 
Posts: 452 | Thanked: 522 times | Joined on Nov 2007
#182
Originally Posted by edgedemon View Post
I have installed ubuntu into virtual box and could do with some help
Host kernel VDSO support... no
E: Host kernel VDSO support is incompatible with scratchbox.
E: You can disable VDSO support for this session with
E: 'echo 0 > /proc/sys/vm/vdso_enabled' as root
E: For a permanent solution you may add 'vm.vdso_enabled = 0'
E: to /etc/sysctl.conf and run 'sysctl -p' as root
root@n900-dev:~#


Not sure what option I need to choose???
Ok, you probably want the permanent solution; because this will be a issue each time you start your VM. But to install it you can do the
Code:
echo 0 > /proc/sys/vm/vdso_enabled
then edit the /etc/sysctl.com and add that line.

Then you should be able to continue with your install.

Nathan.
 

The Following User Says Thank You to Nathan For This Useful Post:
Helmuth's Avatar
Posts: 1,259 | Thanked: 1,337 times | Joined on Oct 2009 @ Germany
#183
Ooookay, this is my outing. I'm a stupid Windows User.

I downloaded the VM Image, Ubuntu is running. Network is present.
When I open the Installation Folder on the Desktop and Doubleclick "Step 1. Install Scratchbox" - the Terminal opens and after a short while it closes itself and nothing happend.

I tryed to run the Script manual in a Terminal. But when I enter "bash -c '~/Maemo_Install/Scripts/Install/Install_Scratchbox'" the Error "Permission denied" appears.

So this was my outing. What should I do?
 
SubCore's Avatar
Posts: 850 | Thanked: 622 times | Joined on Sep 2009 @ Vienna, Austria
#184
the script probably has the executable flag missing.

try issuing this command, and then retry:
Code:
chmod -R +x ~/Maemo_Install/Scripts/*
 
Helmuth's Avatar
Posts: 1,259 | Thanked: 1,337 times | Joined on Oct 2009 @ Germany
#185
Thanks a lot!

It was also a hard try to install the Nokia Binaries, but now Maemo is running. I should order a Book "LINUX for Beginners"
 
joshua.maverick's Avatar
Posts: 805 | Thanked: 437 times | Joined on Aug 2009 @ Mississauga, On
#186
Is this latest/up to date? I'm starting to learn python, and I want to start messing around for real now! lol
 
joshua.maverick's Avatar
Posts: 805 | Thanked: 437 times | Joined on Aug 2009 @ Mississauga, On
#187
Originally Posted by Nathan View Post
Thanks nymajoak for the help!

---

Yes open a terminal and do the following:

Code:
svn --force update ~/Maemo_Install
sudo chown -R maemo:maemo ~/Maemo_Install
chmod -R 777 ~/Maemo_Install
Then try running the first step. That should solve the issues. I need to put another VM Image out; it appears that I forgot to chmod one of the silly scripts before I released it. I thought the updated step 1 script would fix it; but apparently it isn't. Sorry for the confusion...

Nathan.
The installation still requires this, not sure if you released a new version or not.
 
Posts: 3,664 | Thanked: 1,524 times | Joined on Sep 2009 @ Hamilton, New Zealand
#188
I am too interested in installing Maemo 5 on virtual Machine on my windows 7! Is there any chance of directly install maemo5 without having to install ubuntu ?
 
Posts: 39 | Thanked: 4 times | Joined on Nov 2009
#189
Hi,

Please help me.

I downloaded the vm and fixed the permissions as nathan advised.

I have tried 4 times now and keep getting this error:

toolchain cs2005q3.2-glibc-arm hash sum mismatch

How can I fix this? Is there anyway I can resume the download from where it stopped? I dont want to download everything again. Some of the packages like docs are huge.

EDIT: Solved: I downloaded and installed manually.

As per http://wiki.maemo.org/Documentation/...l_Installation

Thanks.

Last edited by n900_ag; 12-22-2009 at 05:22 AM.
 
Posts: 39 | Thanked: 4 times | Joined on Nov 2009
#190
Please add -o Acquire::http::Pipeline-Depth=0 to the nokia binaries script.

https://bugs.maemo.org/show_bug.cgi?id=3811

I was getting numerous connection reset by peer error specifically on the nokia script and the bug above solved the problem with apt.
 
Reply

Tags
development, fremantle, maemo, maemo 5, programming, sdk, virtual machine, virtualpc, windows, windows 7

Thread Tools

 
Forum Jump


All times are GMT -4. The time now is 11:20 PM.