Active Topics

 



Notices


Reply
Thread Tools
Posts: 830 | Thanked: 3,356 times | Joined on Mar 2009
#31
Originally Posted by freemangordon View Post
Do you mind to put that in the repos? Increasing the version ofc, as it is the same as the latest in extras-devel
I have tried to put this fixed version to the extras-devel, but it silently rejects it. Can you fetch some logs for me?

I should use bigger version number for fixed version (and not same than non-fixed version).
 

The Following User Says Thank You to AapoRantalainen For This Useful Post:
Posts: 3,034 | Thanked: 12,649 times | Joined on Mar 2010 @ Sofia,Bulgaria
#32
Originally Posted by AapoRantalainen View Post
I have tried to put this fixed version to the extras-devel, but it silently rejects it. Can you fetch some logs for me?

I should use bigger version number for fixed version (and not same than non-fixed version).
Hmm, those logs are available to everyone: https://garage.maemo.org/builder/fremantle/

However, could you reupload python2.7_2.7.3~rc2-2.1-maemo5 (I guess this is the fixed version) to the builder again, I have the feeling your attempt coincide with some maintaining or reboot. Try first without increasing the version.

EDIT:
If it fails again, I'll look at it more closely

EDIT2:
And I'll appreciate if I receive reports for anything suspicious related to the autobuilder/package interface

EDIT3:
don;t reupload to builder, there are some problems, will inform you when the builder is fixed
__________________
Never fear. I is here.

720p video support on N900,SmartReflex on N900,Keyboard and mouse support on N900
Nothing is impossible - Stable thumb2 on n900

Community SSU developer
kernel-power developer and maintainer


Last edited by freemangordon; 2013-08-15 at 17:55.
 

The Following User Says Thank You to freemangordon For This Useful Post:
Posts: 830 | Thanked: 3,356 times | Joined on Mar 2009
#33
Now I can see builder logs (you did something?)

armel build ok: 04-Aug-2013 21:17
i386 failed: 15-Aug-2013 18:07

(Reading from logs) During tests on arm qemu seg faults and then skips tests and success with packages.
On i386 it runs tests and fails with "Name or service not known" during test_docxmlrpc (SimpleXMLRPCServer.py+SocketServer.py) which looks something that builder might block for reason.

And actually it is not tests, but run_profile_task on

Code:
profile-opt:
        @echo "Building with support for profile generation:"
        $(MAKE) clean
        $(MAKE) build_all_generate_profile
        @echo "Running benchmark to generate profile data:"
        $(MAKE) profile-removal
        $(MAKE) run_profile_task
        @echo "Rebuilding with profile guided optimizations:"
        $(MAKE) clean
        $(MAKE) build_all_use_profile
And debian/rules is explicitly asking profiled build (so it can easily disabled).
 

The Following User Says Thank You to AapoRantalainen For This Useful Post:
Posts: 3,034 | Thanked: 12,649 times | Joined on Mar 2010 @ Sofia,Bulgaria
#34
Originally Posted by AapoRantalainen View Post
Now I can see builder logs (you did something?)

armel build ok: 04-Aug-2013 21:17
i386 failed: 15-Aug-2013 18:07

(Reading from logs) During tests on arm qemu seg faults and then skips tests and success with packages.
On i386 it runs tests and fails with "Name or service not known" during test_docxmlrpc (SimpleXMLRPCServer.py+SocketServer.py) which looks something that builder might block for reason.

And actually it is not tests, but run_profile_task on

Code:
profile-opt:
        @echo "Building with support for profile generation:"
        $(MAKE) clean
        $(MAKE) build_all_generate_profile
        @echo "Running benchmark to generate profile data:"
        $(MAKE) profile-removal
        $(MAKE) run_profile_task
        @echo "Rebuilding with profile guided optimizations:"
        $(MAKE) clean
        $(MAKE) build_all_use_profile
And debian/rules is explicitly asking profiled build (so it can easily disabled).
Yep, I did, there was a make -j4 ... stuck since 4th of August. We suspect OOM, now there is more memory added to builder VM. I killed that stuck make, so it continued, albeit failed.

Could you upload python2.7 again, to see if it will work this time.
__________________
Never fear. I is here.

720p video support on N900,SmartReflex on N900,Keyboard and mouse support on N900
Nothing is impossible - Stable thumb2 on n900

Community SSU developer
kernel-power developer and maintainer

 

The Following 2 Users Say Thank You to freemangordon For This Useful Post:
Posts: 3,034 | Thanked: 12,649 times | Joined on Mar 2010 @ Sofia,Bulgaria
#35
@aapo - Definitely it is not autobuilder to blame, for some reason a python process got stuck. I killed it by hand, so the build will succeed, but I think you should check the build rules and disable whatever is not really needed. Like profiled build, tests, etc.

EDIT:
Code:
Exception in thread Thread-268:
Traceback (most recent call last):
  File "/home/builder1/maemo-fremantle-i386-extras-devel/work/python2.7-2.7.3~rc2-2.1/Lib/threading.py", line 551, in __bootstrap_inner
    self.run()
  File "/home/builder1/maemo-fremantle-i386-extras-devel/work/python2.7-2.7.3~rc2-2.1/Lib/logging/config.py", line 883, in run
    ready=self.ready)
  File "/home/builder1/maemo-fremantle-i386-extras-devel/work/python2.7-2.7.3~rc2-2.1/Lib/logging/config.py", line 851, in __init__
    ThreadingTCPServer.__init__(self, (host, port), handler)
  File "/home/builder1/maemo-fremantle-i386-extras-devel/work/python2.7-2.7.3~rc2-2.1/Lib/SocketServer.py", line 408, in __init__
    self.server_bind()
  File "/home/builder1/maemo-fremantle-i386-extras-devel/work/python2.7-2.7.3~rc2-2.1/Lib/SocketServer.py", line 419, in server_bind
    self.socket.bind(self.server_address)
  File "/home/builder1/maemo-fremantle-i386-extras-devel/work/python2.7-2.7.3~rc2-2.1/Lib/socket.py", line 224, in meth
    return getattr(self._sock,name)(*args)
gaierror: [Errno -2] Name or service not known

make[2]: *** [run_profile_task] Terminated
Terminated is because of me killing the stuck python
__________________
Never fear. I is here.

720p video support on N900,SmartReflex on N900,Keyboard and mouse support on N900
Nothing is impossible - Stable thumb2 on n900

Community SSU developer
kernel-power developer and maintainer


Last edited by freemangordon; 2013-08-16 at 10:35.
 
Posts: 830 | Thanked: 3,356 times | Joined on Mar 2009
#36
Built success. Waiting package coming to the repository for testing.

Originally Posted by freemangordon View Post
@aapo - Definitely it is not autobuilder to blame, for some reason a python process got stuck.
How about this, happens on builder for ARM, but not my local SB.
Code:
test_exceptions
qemu: uncaught target signal 11 (Segmentation fault) - core dumped
make[2]: [run_profile_task] Error 126 (ignored)
Originally Posted by freemangordon View Post
you should check the build rules and disable whatever is not really needed. Like profiled build, tests, etc.
I have tried to do that, but this time that profiled build was slipped out of my radar.
 

The Following User Says Thank You to AapoRantalainen For This Useful Post:
Posts: 3,034 | Thanked: 12,649 times | Joined on Mar 2010 @ Sofia,Bulgaria
#37
Originally Posted by AapoRantalainen View Post
Built success. Waiting package coming to the repository for testing.



How about this, happens on builder for ARM, but not my local SB.
Code:
test_exceptions
qemu: uncaught target signal 11 (Segmentation fault) - core dumped
make[2]: [run_profile_task] Error 126 (ignored)

I have tried to do that, but this time that profiled build was slipped out of my radar.
qemu, only devils know how it works, not the God even .

I guess your SB setup differs from autobuilder.

Code:
ii  scratchbox-core:i386                               1.0.18                       Scratchbox base system
ii  scratchbox-devkit-apt-https:i386                   1.0.11                       APT HTTPS devkit for Scratchbox
ii  scratchbox-devkit-debian-squeeze:i386              1.0.4                        Debian Squeeze devkit for Scratchbox
ii  scratchbox-devkit-doctools:i386                    1.0.14                       Doctools for Scratchbox
ii  scratchbox-devkit-git:i386                         1.0.2                        Git for Scratchbox
ii  scratchbox-devkit-perl:i386                        1.0.5                        Perl modules for Scratchbox
ii  scratchbox-devkit-qemu:i386                        0.12.50-0sb3                 Qemu scratchbox devkit
ii  scratchbox-libs:i386                               1.0.18                       Scratchbox libraries
ii  scratchbox-toolchain-cs2005q3.2-glibc2.5-arm:i386  1.0.7.2                      cs2005q3.2-glibc2.5-arm compiler for Scratchbox
ii  scratchbox-toolchain-cs2005q3.2-glibc2.5-i386:i386 1.0.7                        cs2005q3.2-glibc2.5-i386 compiler for Scratchbox
ii  scratchbox-toolchain-cs2007q3-glibc2.5-arm7:i386   1.0.16-2                     cs2007q3-glibc2.5-arm7 compiler for Scratchbox
ii  scratchbox-toolchain-cs2007q3-glibc2.5-i486:i386   1.0.16-1                     cs2007q3-glibc2.5-i486 compiler for Scratchbox
ii  scratchbox-toolchain-host-gcc:i386                 1.0.18                       Scratchbox host-gcc toolchain
and fremantle scratchbox in autobuilder is using debian-squeeze, not debian-etch
__________________
Never fear. I is here.

720p video support on N900,SmartReflex on N900,Keyboard and mouse support on N900
Nothing is impossible - Stable thumb2 on n900

Community SSU developer
kernel-power developer and maintainer

 

The Following User Says Thank You to freemangordon For This Useful Post:
Posts: 830 | Thanked: 3,356 times | Joined on Mar 2009
#38
Builder got -maemo5 built (arm+i386) , but there were also stucked -maemo6, so it didn't push it to the repository.

I bumped version number and reuploaded, but seems i386 version is again exhausted, armel deps are already in results: https://garage.maemo.org/builder/fre...c2-2.1-maemo6/
 

The Following User Says Thank You to AapoRantalainen For This Useful Post:
Posts: 3,034 | Thanked: 12,649 times | Joined on Mar 2010 @ Sofia,Bulgaria
#39
Originally Posted by AapoRantalainen View Post
Builder got -maemo5 built (arm+i386) , but there were also stucked -maemo6, so it didn't push it to the repository.

I bumped version number and reuploaded, but seems i386 version is again exhausted, armel deps are already in results: https://garage.maemo.org/builder/fre...c2-2.1-maemo6/
For some reason it hangs on "./python ../Lib/test/regrtest.py -x test_bsddb3 test_compiler test_cprofile test_dbm_dumb test_dbm_ndbm...", I guess next time you should disable regression tests in the build scripts.

There seems to be another problem with python2.7, similar to the KP problem - newest version does not appear in the package interface as the latest version. I'll look at that problem as soon as I have some spare time.
__________________
Never fear. I is here.

720p video support on N900,SmartReflex on N900,Keyboard and mouse support on N900
Nothing is impossible - Stable thumb2 on n900

Community SSU developer
kernel-power developer and maintainer

 

The Following User Says Thank You to freemangordon For This Useful Post:
Posts: 830 | Thanked: 3,356 times | Joined on Mar 2009
#40
Originally Posted by freemangordon View Post
I guess next time you should disable regression tests in the build scripts
I think I now got how to disable it correctly (for next time).

Originally Posted by freemangordon View Post
There seems to be another problem with python2.7, similar to the KP problem - newest version does not appear in the package interface as the latest version. I'll look at that problem as soon as I have some spare time.
Yes, this is weird. But now working package is in extras-devel. And package page is: http://maemo.org/packages/package_in...c2-2.1-maemo6/
Is there risk that builder will remove it as a old version? Should I save it to the testing?
 
Reply

Thread Tools

 
Forum Jump


All times are GMT. The time now is 19:21.