Active Topics

 



Notices


Reply
Thread Tools
Posts: 14 | Thanked: 0 times | Joined on Oct 2017 @ Poland
#1
Hi, i had a problem with flashing my n9 (i did it because of bootloop, i simply couldn't turn it on, and it's not battery's fault cause i recently bought a new one thinking that bootloop problerm is caused by old battery) Do you know what may be wrong? I've red many threads about flashing and it really helped me but now im stuck.



C:\>cd..

C:\>cd "Program Files\Nokia\Flasher"

C:\Program Files\Nokia\Flasher>flasher -i
flasher 3.12.1 (Oct 6 2011) Harmattan
WARNING: This tool is intended for professional use only. Using it may result
in permanently damaging your device or losing the warranty.

Suitable USB interface (bootloader/phonet) not found, waiting...
Found device RM-696, hardware revision 1603
NOLO version 2.3.6
Version of 'sw-release': DFL61_HARMATTAN_40.2012.21-3.341.2_PR_341
Success

C:\Program Files\Nokia\Flasher>flasher -f -F DFL61_HARMATTAN_40.2012.21-3_PR_LEG
ACY_001-OEM1-958_ARM.bin --erase-user-data=secure
flasher 3.12.1 (Oct 6 2011) Harmattan
WARNING: This tool is intended for professional use only. Using it may result
in permanently damaging your device or losing the warranty.

Found device RM-696, hardware revision 1603
NOLO version 2.3.6
Version of 'sw-release': DFL61_HARMATTAN_40.2012.21-3.341.2_PR_341
Sending ape-algo image (7096 kB)...
100% (7096 of 7096 kB, avg. 17565 kB/s)
Suitable USB interface (phonet) not found, waiting...
Ping attempt 1 (250 ms)
Server application: 1.7.2
Found product RM-696 rev. 1603
Server implements softupd protocol version 1.8

Battery level 13 %, continuing.
Erasing, this may take a while.
Erase done.
Image SW version DFL61_HARMATTAN_40.2012.21-3_PR_001
Image moslo not present
Image mmc not present
Image tar skipped
Image config skipped

Battery level 17 %, continuing.

image [state progress transfer flash speed]
---------------------------------------------------------------------
[_] cert-sw [init 0 % 0 / 0 kB NA ]
[ ] cmt-2nd [pending 0 % 0 / 0 kB NA ]
[ ] cmt-algo [pending 0 % 0 / 0 kB NA ]
[ ] cmt-mcusw [pending 0 % 0 / 0 kB NA ]
[ ] xloader [pending 0 % 0 / 0 kB NA ]
[ ] secondary [pending 0 % 0 / 0 kB NA ]
[ ] kernel [pending 0 % 0 / 0 kB NA ]
[ ] rootfs [pending 0 % 0 / 0 kB NA ]
ERROR: SU_GET_UPDATE_STATUS_REQ terminated with error code 10: Security failure

image [state progress transfer flash speed]
---------------------------------------------------------------------
[f] cert-sw [init 0 % 1 / 1 kB NA ]
[ ] cmt-2nd [pending 0 % 0 / 0 kB NA ]
[ ] cmt-algo [pending 0 % 0 / 0 kB NA ]
[ ] cmt-mcusw [pending 0 % 0 / 0 kB NA ]
[ ] xloader [pending 0 % 0 / 0 kB NA ]
[ ] secondary [pending 0 % 0 / 0 kB NA ]
[ ] kernel [pending 0 % 0 / 0 kB NA ]
[ ] rootfs [pending 0 % 0 / 0 kB NA ]
Fetching error list:
========================================
bb5_rdc_cert_read failed
bb5_rdc_cert_read failed
bb5_rdc_cert_read failed
bb5_rdc_cert_read failed
bb5_rdc_cert_read failed
bb5_rdc_cert_read failed
Downgrade disallowed (1352745255)
[Pipe 0] Finishing in error state with status 10
========================================

ERROR: Failed to flash images

C:\Program Files\Nokia\Flasher>


And by the way, is there a recent thread about nitdroid installation?, it would be nice to do it if there's a chance.
 
Posts: 469 | Thanked: 893 times | Joined on Aug 2014
#2
Answer is near the bottom of output = Downgrade disallowed (1352745255)

More firmware links in this thread:http://talk.maemo.org/showthread.php?t=96401

Nitdroid in 2016:http://talk.maemo.org/showthread.php...ht=N9+Nitdroid

Last edited by aspergerguy; 2017-10-25 at 12:10. Reason: Addition
 
Posts: 14 | Thanked: 0 times | Joined on Oct 2017 @ Poland
#3
Thanks for your reply, i took te firmware from the exact same thread, can you tell me more about that downgrade? does it mean that i already have pr1.3 firmware (i'm not sure)? i didn't mess with the system by any means, but i can't turn on my n9, so i thougt the best thing to do would be to reflash it.
 
Posts: 469 | Thanked: 893 times | Joined on Aug 2014
#4
This resource probably explains it quite well:http://forum.gsmhosting.com/vbb/f609...nside-1494320/

At top of your Flasher output it tells you that it has the following:https://archive.org/download/NokiaN9...ngePlPlBlackV2

For Bootloop try using R & D mode as described here:https://talk.maemo.org/showpost.php?...83&postcount=2

Last edited by aspergerguy; 2017-10-25 at 17:23. Reason: Correction
 

The Following User Says Thank You to aspergerguy For This Useful Post:
Posts: 14 | Thanked: 0 times | Joined on Oct 2017 @ Poland
#5
Ok, i 've enabled R&D mode but now it's stuck witch a wrench on the screen and nokia logo for a while only to disconnenct and connect every few seconds. Is it possible to flash a phone without the latest system version? I mean only with the version that i already have? And how do i know whats the image name for eMMc? I also found something about cleaning rootfs by flasher but i dont know whether it is important or not.

Sorry for so many questions, but i am a noob who is just trying to learn.
 
Posts: 469 | Thanked: 893 times | Joined on Aug 2014
#6
[QUOTE=enes;1537743]Is it possible to flash a phone without the latest system version? I mean only with the version that i already have? And how do i know whats the image name for eMMc? I also found something about cleaning rootfs by flasher but i dont know whether it is important or not./QUOTE]

As regards EMMC use DFL61_HARMATTAN_40.2012.13-7.NOMAPS_EMMC_NOMAPS in first source I gave you. All EMMC images have well out of date map data so pointless using although even latest map data is only 2015 for N9.

It would be worth trying to flash 05E93654_DFL61_HARMATTAN_40.2012.21-3.341.2_PR_LEGACY_341_ARM_RM-696_PRD_signed.bin from archive link again.

Although it make take some time think that you need to use:
HTML Code:
flasher -f -F main.bin --erase-user-data=secure -F emmc.bin --erase-mmc=secure
Please have a look at this comprehensive resource, although now very long most flashing problems occurring have been covered:http://talk.maemo.org/showthread.php?t=82693

Last edited by aspergerguy; 2017-10-26 at 12:52. Reason: Addition
 

The Following User Says Thank You to aspergerguy For This Useful Post:
Posts: 14 | Thanked: 0 times | Joined on Oct 2017 @ Poland
#7
Ok, i'm trying it right now, but is it normal that the battery is empty even though it was charged to 11% few hours ago when it was plugged to the computer? It's a new battery, i got it 3 days ago, is it possible that it's faulty? Because the bootloop appeared with other battery overnight without any earlier symptoms.
 
Posts: 469 | Thanked: 893 times | Joined on Aug 2014
#8
Last time I bought so called new battery it was manufactured years ago. If you use flasher to charge battery to <10% using
HTML Code:
flasher -F <firmware-image> --flash-only=kernel -f -R
and then exit can you connect it to mains charger to fully charge or not? https://talk.maemo.org/showpost.php?...21&postcount=1
Did you hold power button in fully until phone vibrated (takes about 8 seconds) after using flasher to ensure it was actually switched off?

Last edited by aspergerguy; 2017-10-26 at 14:06. Reason: Addition
 

The Following User Says Thank You to aspergerguy For This Useful Post:
Posts: 14 | Thanked: 0 times | Joined on Oct 2017 @ Poland
#9
Yes, after plugging it to the charger it was tuning on and of every few second like it did with the computer, but it seems that it doesn't charge at all when plugged to the charger. It vibrates and the led is on but then it turns of itself.
 
Posts: 469 | Thanked: 893 times | Joined on Aug 2014
#10
It won't charge from mains charger until you reach critical level 11% using flasher method. but if you don't exit process at that stage it starts to flash image.

There have been reported problems with non-genuine batteries in the past only demonstrated by returning to manufacturer's battery and charging using above method. Can be worth checking all the connectors one more time if unused to disassembling N9.

Last edited by aspergerguy; 2017-10-26 at 14:19. Reason: Addition
 

The Following User Says Thank You to aspergerguy For This Useful Post:
Reply

Thread Tools

 
Forum Jump


All times are GMT. The time now is 05:19.