Thread Tools
Posts: 90 | Thanked: 38 times | Joined on Jan 2014
Originally Posted by Cecchi85 View Post
Homescreen feeds don't work with

am i the only one?
No, same for me, just tried now this version because with default client i get error when i share to twitter.

I activated all settings in Settings, i selected custom update to 0 or 1 but no change. Still dosent work.
Delete tweet function dosent work as well, maybe others too, didnt tried.

But share to rocket function isnt like stock default twitter client. you need to wait loading the client and then press manual tweet.
Default share function from stock client is addictive.
Posts: 228 | Thanked: 100 times | Joined on May 2010 @ Australia
I definitely get a feed on my event screen with Sometimes I get double tweets if I update via the refresh button then run the rocket app - annoying.
As mentioned, I can't use the stock twitter app anymore so updates for this app would be greatly appreciated!
Posts: 90 | Thanked: 38 times | Joined on Jan 2014
If you press refresh will update all your feeds that are activated so make sure you stock twitter feed is turn off in Settings>>Notifications>>Feeds.

In feeds home screen (not rocket, twitter) long press on a feed and see what it says : CLEAR ROCKET or CLEAR TWITTER
On second tweet feed that is the same make again a long press and see if says clear rocket or clear twitter, if both are clear rocket then is a bug from client.

installed version 0.0.7 and feeds are working but still dosent update in real time feeds you send, you need to press refresh on home screen, again function >>delete feed <<dosent working.
Posts: 95 | Thanked: 70 times | Joined on Mar 2009 @ Massachusetts
First, I'd like to say thanks for making this incredible Twitter client, Rocket!
I've been using it for some time, and it's one of my favorites to use on the N9 next to the stock Twitter app. Now I'd like to point out some suggestions that I'd like to see fixed or added.

Maybe it's just me, but I prefer to have it search in real-time and list suggestions as I'm typing in the search field. Here's a comparison between the current Rocket and Twitter for Windows Phone:

Notice how the Windows Phone version gives me suggestions on who (Twitter profiles) I'm searching for in a drop down list. If it's not listed, I would be simply hit the Enter key to search and scroll through the results until I find it.

Next up is profile view. Is there a way you can let us view the profile background? You can't even view photos/videos they posted. I mean, look at all that empty space! If not, then please, at least place a button or option to open the profile in a web browser. That way, we can view the profile properly. I like that you can tap their tweets to view their tweets and such (favs/flw/flr). That is very useful for me. Please, let us tap their Lists. Profile details aren't lined up correctly and are placed over those buttons. Any URLs in the profile detail are not clickable either. Fix this! (Also, show full URL as the user intended, not shortened URLs)

I do like how you have @ reply and DM buttons at the bottom. But the icons for them have these dashes which I guess stands for quick reply, quick direct message. Aren't they the same as regular @reply and DM? Just keep it simple as possible, and use the same icons as you have it displayed on the main Timeline view. Even when long pressing a tweet in the Timeline, you should keep the same @ icon for reply action. It's about consistency in design. It shows up again when you're viewing a single tweet.

I do think that the Mute/Block option should be moved over to where you're viewing the person's profile (which is already there, and should be the only place to find it). We don't use that Mute button too often. What if we were to press it by accident and not know it because we're trying to navigate the app? It should not be seen when you're just viewing their tweet. However, I do like the copy tweet text and copy tweet URL though. That's very useful for me. If you can, please add those options (or just the copy tweet text) when long pressing a tweet in the Timeline. Also, if there's an URL in the tweet, I'd like to copy and paste and view the actual URL in full (ie., and not shortURL (
While we're in the tweet view, I'd like to be able to see the stats. Maybe it requires more bandwidth or too much API hits, but I like to see the number of favorites and RTs for that tweet I'm viewing, and also the replies and conversations, and have any new reply show up below in real-time without having me to go back in and out of the tweet to view new posts. Windows Phone version does this perfectly well. It even shows the date and time, and the entire conversation.

I very much like to be very precise with my tweets, so knowing that I have the correct URL would be great.
The Retweet is fine. I like that when you long press, and click the RT icon, it brings you the tweet so you can either instant Retweet or click the text to edit the tweet and it automatically adds the RT at the front. Other Twitter clients would just have that icon for instant retweet only.

Now I'm a big user of Twitter Lists. I clicked the options to view my Lists, but I'm left with only the ones I'm subscribed to... Where are the Lists that I made? It would be great if you could have Lists that I made show up in the Lists view. Most clients, you have click your profile and then click Lists. That's what I have to do in the stock Twitter on Nokia N9 and Twitter for Windows Phone. But in Rocket, you click Account option to edit your profile! Haha

I've skimmed through the thread and learned that you aren't able to add people to your List. That's a shame because I do that a lot. There's no mobile client I know that lets you do this. (Unless you can run TweetDeck on a tablet or something, but that's different)

Let's look at how we compose a tweet in Rocket.

I don't know what you're trying to do by having all those @names there. If you're going to do that, at least have names whose been mentioned in the tweet I'm replying to (if any) or the related # hashtags (if any) as suggestions. Even then, you still need to press the @ icon and then press the name suggestion for it to work. You should be be able to just click the @name suggestion to autocomplete and have it show up in the tweet. I see this useful when you're participating in a Twitter conversation where multiple people are @replying each other. It's a waste of space having all of that there when not needed. Plus, with the photo attachment placed behind the names? That's not good. I want to be able to see the image I'm attaching. So place that higher, just underneath the composing field so I can better see whether I had chosen the correct photo. Make the thumbnail bigger too.
Speaking of photos, if we could attach more than one photo in a future update, that'd be great. Another big one I'd like to see is photo tagging. If we can tag people in the photo, that would definitely make me use this client more. It helps reduce the number of text needed for the tweet. Of course, there are some people who don't allow themselves to be tagged in photos. That should be indicated when search for people to tag. Look to the Windows Phone version for example.

One last thing is have the what we're tweeting from show as Rocket! for Nokia N9 or Rocket! for MeeGo and not just Rocket! (make it optional in the settings). If we could edit our own, that would be super cool.

Overall, Rocket is good. It does lag a bit when I'm returning to the Timeline view or just initially booting it up. It takes about 7+ seconds to gather the new tweets and resume. (Hardware limitation?) I would definitely use it more often once those suggestions have been fulfilled.
Posts: 117 | Thanked: 61 times | Joined on Mar 2012 @ Durham, UK

Rocket is excellent but after a while the homescreen daemon stops and the app won't start - I get the splash screen for maybe a 30 seconds then it quits. A reboot fixes the problem.

Any idea what the root cause is and if I could fix it from ssh/terminal instead of a reboot?

I'm using v007 on N9.


Posts: 228 | Thanked: 100 times | Joined on May 2010 @ Australia
Originally Posted by gabrielharrison View Post
Any idea what the root cause is and if I could fix it from ssh/terminal instead of a reboot?

Yes, this happens to me as well.
What I do is go to terminal and type:

 ps | grep rocket
this will bring up the pid (number) of the rocket process, then you can type:

 kill "pid number"

The Following 2 Users Say Thank You to skyjumper For This Useful Post:
Posts: 228 | Thanked: 100 times | Joined on May 2010 @ Australia
Are there any planned updates coming to this great program for us?

The Following User Says Thank You to skyjumper For This Useful Post:
Posts: 90 | Thanked: 38 times | Joined on Jan 2014
Would be great if manages at least to have a option to select how many tweets can download to put a option like 50, if you dont have automatic updates and enter on rocket from time to time and you use rocket just to share when downloads 200 tweets no chance, gets blocked and you wait very much.

So in one sentence: option to download only last 25, 50, 100, 150 tweets by case.

The Following 2 Users Say Thank You to youFailed For This Useful Post:
Posts: 68 | Thanked: 23 times | Joined on Jun 2014 @ Sweden
Looks like authorizing the app is now broken.
Either that, or i'm doing something wrong.
I cant seam to get mine back to working after i reset my phone, and restored a backup.
So far i have (well, mostly for another reason, my OS was apparently borked) reflashed, and reinstalled rocket, with no luck. The app is still authorized on Twitter, i tried revoking that, and then tried authorizing again. No go. So i un-revoked it, and still nothing. It says i'm logged in, but that's all she does. No status updates, no nothing.

I guess the authorizing process changed somewhere, since it just goes to a blank page. I wish i could "stop it" after pressing authorize, since there is, for a second, a link visible for opening, and authorizing in a browser, but then it's gone, and i cant get to it. I'm sure loading that link would have sorted it, just to screw with me... Oh well.

The Following User Says Thank You to Mr B For This Useful Post:
Posts: 17 | Thanked: 24 times | Joined on Oct 2013 @ USA
I also lost ability to use Rocket after restoring a backup. But I have two N9's and Rocket is working fine on the non-restored one. Tweetian still works after restore, so try that. It is nice, too.

Restoring a backup is supposed to fix things, not break things. This was the only thing I noticed broken.

The Following User Says Thank You to dini For This Useful Post:

rocket, twitter

Thread Tools

Forum Jump

All times are GMT. The time now is 11:38.