Notices


Reply
Thread Tools
Schturman's Avatar
Posts: 5,318 | Thanked: 4,080 times | Joined on Jan 2010 @ Israel
#1
I bought one of Transcend, and jolla can see it.. It come formatted to exFAT, already tried to reformat it to NTFS and ext4, but nothing help..
Both file mangers (CargoDock and File Browser) can't see it, also when I connect jolla to pc
Can someone explain me how to get it work, please ?
 
Posts: 700 | Thanked: 2,048 times | Joined on Feb 2011 @ UK
#2
Format it to FAT32. You'll need to use command line tools on Windows as the GUI will insist on exFAT. On a Mac Disk Utility will format it ok but watch the default partition options.

The partition scheme has to be the old Master Boot Record type and only one partition is supported. It should auto mount.

You can also use btrfs and ext4 but those aren't compatible with Windows or Macs and it won't auto mount.
 

The Following 4 Users Say Thank You to aegis For This Useful Post:
Schturman's Avatar
Posts: 5,318 | Thanked: 4,080 times | Joined on Jan 2010 @ Israel
#3
 
Posts: 837 | Thanked: 1,285 times | Joined on Jul 2010 @ Brittany, France
#4
ext4 format will be OK, but it will not be automatically mounted. I had to edit /usr/sbin/mount-sd.sh with valuable help from someone on the IRC channel to automatically mount it. Now it works and I can use SFTP to transfer or remove files from /run/user/100000/media/sdcard, even using Windows.

My mount-sd.sh after the changes is the following, but I cannot guarantee this is safe as I only did what I was told to. Please keep in mind that it might really result in issues with your Jolla, and here the warning is a true warning because I'm not a Linux power user.

Code:
#!/bin/bash

SDCARD=/dev/sdcard
DEF_UID=$(grep "^UID_MIN" /etc/login.defs |  tr -s " " | cut -d " " -f2)
DEF_GID=$(grep "^GID_MIN" /etc/login.defs |  tr -s " " | cut -d " " -f2)
DEVICEUSER=$(getent passwd $DEF_UID | sed 's/:.*//')
MNT=/run/user/$DEF_UID/media/sdcard

if [ "$ACTION" = "add" ]; then
        if [ -b /dev/mmcblk1p1 ]; then
                ln -sf /dev/mmcblk1p1 $SDCARD
        elif [ -b /dev/mmcblk1 ]; then
                ln -sf /dev/mmcblk1 $SDCARD
        else
                exit $?
        fi
        su $DEVICEUSER -c "mkdir -p $MNT"
        mount $SDCARD $MNT -o uid=$DEF_UID,gid=$DEF_GID
        if [ -z $(mount | grep $MNT) ]; then
                # let's try 2nd time w/o options
                mount -o rw $SDCARD $MNT
                if [ $? = 0 ]; then
                        chown $DEF_UID:$DEF_GID $MNT
                fi
        fi
else
        umount $SDCARD

        if [ $? = 0 ]; then
                rm -f $SDCARD
        else
                umount -l $MNT
                rm -f $SDCARD
        fi
fi
 

The Following 5 Users Say Thank You to Kabouik For This Useful Post:
Community Council | Posts: 4,143 | Thanked: 9,969 times | Joined on May 2012 @ Southerrn Finland
#5
I formatted my card to btrfs and it works OK.
 

The Following 2 Users Say Thank You to juiceme For This Useful Post:
Posts: 1,067 | Thanked: 2,377 times | Joined on Jan 2012 @ Finland
#6
exFAT works ok if you just compile these into the device http://code.google.com/p/exfat/downloads/list
__________________
IRC: jonni@freenode
Sailfish: Qt5 SailfishTouchExample Qt5 MultiPointTouchArea Example ipaddress stoken Sailbox (Dropbox client)
Harmattan: Presence VNC for Harmattan Live-F1 BTinput-terminal BabyLock BabyLock Trial QML TextTV
Disclaimer: all my posts in this forum are personal trolling and I never post in any official capacity on behalf of any company.
 

The Following 3 Users Say Thank You to rainisto For This Useful Post:
ZogG's Avatar
Posts: 1,385 | Thanked: 1,843 times | Joined on Feb 2010 @ Israel
#7
Anyone tried to use samsung's driver? http://www.phoronix.com/scan.php?pag...tem&px=MTQzODQ
__________________
IRC nick on freenode ZogG
imgrup
 
javispedro's Avatar
Posts: 2,330 | Thanked: 5,197 times | Joined on Jan 2009 @ Barcelona
#8
Note that FAT32 works just fine for Windows.
 

The Following 2 Users Say Thank You to javispedro For This Useful Post:
Posts: 721 | Thanked: 773 times | Joined on Jan 2012 @ Berlin
#9
i use samsung 64gb with fat32 and work very well. No Probs. i dont try it with exFAT/NTFS before, cant say if this working too
__________________
www.sailfishmods.de
 

The Following User Says Thank You to cvp For This Useful Post:
willi6868's Avatar
Posts: 540 | Thanked: 517 times | Joined on Aug 2011 @ Germany
#10
Originally Posted by rainisto View Post
exFAT works ok if you just compile these into the device http://code.google.com/p/exfat/downloads/list
Could someone please provide a rpm-package or a How-To for this?
 
Reply

Thread Tools

 
Forum Jump


All times are GMT. The time now is 06:37.