Notices


Reply
Thread Tools
vistaus's Avatar
Posts: 398 | Thanked: 417 times | Joined on Sep 2014 @ Hilversum, The Netherlands
#11
Originally Posted by HtheB View Post
I hope you guys are being sarcastic, because for me they are loud, especially when unlocking the phone :/
I'm not sarcastic, my system sounds really are low. All sounds and volume are set to max but still the output is too low.
 
Community Council | Posts: 4,141 | Thanked: 9,967 times | Joined on May 2012 @ Southerrn Finland
#12
Originally Posted by stickymick View Post
Maybe, but I'm pretty sure I didn't.
If you really lost/messed your contacts when trying to delete your phone log you sure botched something.

The phone log is stored in /home/nemo/.local/share/commhistory/commhistory.db
The contacts in /home/nemo/.local/share/system/privileged/Contacts/qtcontacts-sqlite/contacts.db

It's 2 completely different databases, you just cannot change contacts when you modify commhistory.

(but if you'd said you deleted your SMS'es accidentally, well, that would be possible. Messages and phone calls are both in same database...)
 
vistaus's Avatar
Posts: 398 | Thanked: 417 times | Joined on Sep 2014 @ Hilversum, The Netherlands
#13
Isn't there a way to 'hack' the volume? It's Linux after all and we can access a lot of files, surely there must be something that controls the volume output...
 
pichlo's Avatar
Posts: 4,928 | Thanked: 14,754 times | Joined on Sep 2012 @ UK
#14
Originally Posted by vistaus View Post
I'm not sarcastic, my system sounds really are low. All sounds and volume are set to max but still the output is too low.
I also find the system sounds volume very low. I though it was low on the N900 and I missed quite a few calls because I did not hear the phone ringing in my pocket but Jolla's ringtones, SMS and email alerts are even quieter. Good job I do not use it as my main communication device.

They are also - at least the default ones - very short and rather unremarkable (for example, a simple "ding!" for an email alert). Fortunately that part can be solved by replacing the tones.
 
vistaus's Avatar
Posts: 398 | Thanked: 417 times | Joined on Sep 2014 @ Hilversum, The Netherlands
#15
pactl set-sink-volume 1 200%

in terminal and then lowering the ringtone sound of my Ambience a bit solved the issue for me. You have to repeat the command after a reboot though but that's a minority for much improved sound IMHO
(my source for this solution: https://together.jolla.com/question/...an-100-volume/)
 

The Following 2 Users Say Thank You to vistaus For This Useful Post:
Posts: 188 | Thanked: 308 times | Joined on Jan 2013 @ UK
#16
Originally Posted by vistaus View Post
pactl set-sink-volume 1 200%

in terminal and then lowering the ringtone sound of my Ambience a bit solved the issue for me. You have to repeat the command after a reboot though but that's a minority for much improved sound IMHO
(my source for this solution: https://together.jolla.com/question/...an-100-volume/)
You could create a systemd service file to re-apply the setting at reboot. Something like this would do it (this isn't tested, I just adapted one from my desktop machine):

Code:
[Unit]
Description=Fix volume settings

[Service]
Type=oneshot
RemainAfterExit=no
ExecStart=/usr/bin/pactl set-sink-volume 1 200%

[Install]
WantedBy=default.target
put that in a file called <meaningfulname>.service in /etc/systemd/system (not sure what the default target is for the phone, not really looked into it).

There may be better examples on the forum, or together though, so you could do a search on "ExecStart" or similar. I've not yet had a need to do this, so I may be missing a detail here or there. It shouldn't break anything though, if something's missing, it just won't run.
 

The Following 2 Users Say Thank You to skanky For This Useful Post:
vistaus's Avatar
Posts: 398 | Thanked: 417 times | Joined on Sep 2014 @ Hilversum, The Netherlands
#17
Thanks, I'll try that out later on and let you know if it worked! (or not lol)
 

The Following User Says Thank You to vistaus For This Useful Post:
stickymick's Avatar
Posts: 975 | Thanked: 722 times | Joined on Mar 2010
#18
That Quasar MX Pro mentioned in the discussion that Vistaus links to could also be worth a try, but does that work for ringtones or just through the media player?
__________________
Mick has just punched the cr@p out of the "Unlike" button on the Official Nokia Facebook Page.
 
vistaus's Avatar
Posts: 398 | Thanked: 417 times | Joined on Sep 2014 @ Hilversum, The Netherlands
#19
Originally Posted by skanky View Post
You could create a systemd service file to re-apply the setting at reboot. Something like this would do it (this isn't tested, I just adapted one from my desktop machine):

Code:
[Unit]
Description=Fix volume settings

[Service]
Type=oneshot
RemainAfterExit=no
ExecStart=/usr/bin/pactl set-sink-volume 1 200%

[Install]
WantedBy=default.target
put that in a file called <meaningfulname>.service in /etc/systemd/system (not sure what the default target is for the phone, not really looked into it).

There may be better examples on the forum, or together though, so you could do a search on "ExecStart" or similar. I've not yet had a need to do this, so I may be missing a detail here or there. It shouldn't break anything though, if something's missing, it just won't run.
Didn't work. I created the file, put it in the right place with the right name (the way you told me), enabled it via systemctl but after a reboot I still have to execute the command I found on TJC to get the volume higher.
 

The Following User Says Thank You to vistaus For This Useful Post:
Posts: 188 | Thanked: 308 times | Joined on Jan 2013 @ UK
#20
Originally Posted by vistaus View Post
Didn't work. I created the file, put it in the right place with the right name (the way you told me), enabled it via systemctl but after a reboot I still have to execute the command I found on TJC to get the volume higher.
Okay, I've just had a quick look. I don't have volume issues, so don't want to mess with it at the moment, so this will again be untested. Sorry.

There's at least one issue with what I suggested. Firstly, the pulseaudio is run under user, so you maybe need to move the unit to user and use the --user option in systemctl.

Secondly, I forgot that we need to make sure that the daemon is started first. So we need to add a dependency:

Code:
[Unit]
Description=Fix volume settings
After=pulseaudio.service
Requires=pulseaudio.service

[Service]
Type=oneshot
RemainAfterExit=no
ExecStart=/usr/bin/pactl set-sink-volume 1 200%

[Install]
WantedBy=default.target

I did though, wonder if it was possible to configure pulseaudio to increase the volume at start-up itself, but I've not seen an obvious way to do that, yet.
 

The Following User Says Thank You to skanky For This Useful Post:
Reply

Thread Tools

 
Forum Jump


All times are GMT. The time now is 17:38.