Notices


Reply
Thread Tools
Posts: 5 | Thanked: 0 times | Joined on Mar 2015
#21
Originally Posted by Ilew View Post
They're just commands so you should be able to copy and paste but I'll try to expand.

Steps are done on the n900.

2. Extract the file :
(Note: You have to be in the same directory as the file you downloaded)
Code:
tar xzvf emojifix-bin.tar.gz
3. Navigate to the newly created directory :
Code:
cd emojifix-bin
4. Run the binary patcher :
Code:
./patcher /usr/lib/libsms-utils.so.0.0.0 libemojitils.so.0
5. Make a backup of the lib you're about to replace :
Code:
cp /usr/lib/libsms-utils.so.0.0.0 /usr/lib/libsms-utils.so.0.0.0.orig
6. Copy the the newly created fix and patched lib files to /usr/lib/ :
(Note: You will need permissions for this)
Code:
cp libemojitils.so.0 libsms-utils.so.0.0.0 /usr/lib/
Thanks . I have problem to get permissions on step 4 . So how do i get permission . I have downloaded the ageis hack and are in root in the terminal app .but get denied on step 4
 
Posts: 5 | Thanked: 0 times | Joined on Mar 2015
#22
Yes i fix it . Now i can use my N9 as my main phone .
Thanks to IIew .
 
Posts: 1,075 | Thanked: 1,533 times | Joined on Jan 2011 @ Touring
#23
Has anyone made any progress in making an emoji soft keyboard for the N900 which resulted in sendable emoji?
I believe it would not be too difficult, like mapping any keyboard, perhaps they are in the wiki somewhere?
The problem remains getting the N900 to send the emoji in a working SMS, as above I have cut/pasted emoji and the sms fails to upload
 
peterleinchen's Avatar
Posts: 3,197 | Thanked: 5,777 times | Joined on Aug 2010 @ Ruhrgebiet, Germany
#24
I would believe it is not the keyboard but the language settings/support selected for SMS? At least I remember a setting like that from my Symbian phones (which is not available on N900).
__________________
SIM-Switcher, automated SIM switching with a Double (Dual) SIM adapter
--
Thank you all for voting me into the Community Council 2014-2016!

Please consider your membership / supporting Maemo e.V. and help to spread this by following/copying this link to your TMO signature:
[MC eV] Maemo Community eV membership application, http://talk.maemo.org/showthread.php?t=94257

editsignature, http://talk.maemo.org/profile.php?do=editsignature
 

The Following User Says Thank You to peterleinchen For This Useful Post:
Posts: 70 | Thanked: 220 times | Joined on Aug 2012
#25
Originally Posted by biketool View Post
Has anyone made any progress in making an emoji soft keyboard for the N900 which resulted in sendable emoji?
I believe it would not be too difficult, like mapping any keyboard, perhaps they are in the wiki somewhere?
The problem remains getting the N900 to send the emoji in a working SMS, as above I have cut/pasted emoji and the sms fails to upload
AFAIK there isn't any patch to allow you to send emojis for n900.
Do you have some output via syslog of the failed sent SMS?
It's probably a similar issue, though it might be a lot harder to fix than just receiving.

Edit:
Got the following error messages when trying to send an emoji.
Code:
Nokia-N900 rtcom-messaging-ui[1660]: GLIB CRITICAL ** default - dbus_g_error_get_name: assertion `error->code == DBUS_GERROR_REMOTE_EXCEPTION' failed
Nokia-N900 rtcom-messaging-ui[1660]: GLIB CRITICAL ** GLib - g_str_has_prefix: assertion `str != NULL' failed
Also when copying an emoji into the text box the char count gets all messed up. Shame rtcom-messaging-ui is also closed.

Last edited by Ilew; 2015-05-20 at 08:45.
 

The Following 2 Users Say Thank You to Ilew For This Useful Post:
Posts: 1,075 | Thanked: 1,533 times | Joined on Jan 2011 @ Touring
#26
Llew, just curious where are you getting the sample emojis?
I don't find anything at /var/log/syslog so apparently Maemo places that somewhere different or I would try emoji from several sources and post results. So far I have just cut/paste from the wikipedia article on emoji.
With the fix given in this thread installed do others receive emoji form other phones? I only have the two N900s in the house and no other mobile phones.
 
Posts: 70 | Thanked: 220 times | Joined on Aug 2012
#27
I just copied an emoji from a sms that I received from an iPhone user.
This is the emoji i used.
😃
When I try to send the above emoji to an iPhone user the rtcom-messaging-ui doesn't show the failed text until the delivery fails.
So to answer your question no the n900 can't send emojis to other non-n900 either but it can receive with the fix in this thread.
 
peterleinchen's Avatar
Posts: 3,197 | Thanked: 5,777 times | Joined on Aug 2010 @ Ruhrgebiet, Germany
#28
Originally Posted by Ilew View Post
So to answer your question no the n900 can't send emojis to other non-n900 either but it can receive with the fix in this thread.
Same goes for the N9, just tested.
Whereas I tried to send from N9 to N900 (not iPhone) so I assume sending to service already fails, and not specific end device.

--edit
At least you may immediately notice during writing whether the SMS is deliverable.
On N9: the number of still available chars (#SMS) switches to 0(0) if there is an 'invalid' emoji in the SMS.
On N900 the number switch to an out-of-range high value.
In case you delete this emoji from SMS the numbers go back to a normal value, e.g. 159(1).
__________________
SIM-Switcher, automated SIM switching with a Double (Dual) SIM adapter
--
Thank you all for voting me into the Community Council 2014-2016!

Please consider your membership / supporting Maemo e.V. and help to spread this by following/copying this link to your TMO signature:
[MC eV] Maemo Community eV membership application, http://talk.maemo.org/showthread.php?t=94257

editsignature, http://talk.maemo.org/profile.php?do=editsignature

Last edited by peterleinchen; 2015-05-21 at 21:03.
 

The Following User Says Thank You to peterleinchen For This Useful Post:
Posts: 160 | Thanked: 607 times | Joined on Oct 2012
#29
Hi!
We found a fix for sending SMSes with Emoji for N9, which might work on N900 too.
I proposed an alternative fix for N9 (http://talk.maemo.org/showpost.php?p...3&postcount=42), which, to my surprise, also fixed the problem with sending SMSes with Emoji characters (http://talk.maemo.org/showpost.php?p...0&postcount=56). The same fix (replacing UCS-2 with UTF16 directly in libsms-utils) might also fix the problem on N900 too (I don't have N900, so I can't try).
__________________
My N9 apps: MeeTeleGram, Dukto, Prayers, Saaghar, N9 Easy Boot
Donations are appreciated (or maybe this or this)
 

The Following 3 Users Say Thank You to hedayat For This Useful Post:
Posts: 70 | Thanked: 220 times | Joined on Aug 2012
#30
Originally Posted by hedayat View Post
Hi!
We found a fix for sending SMSes with Emoji for N9, which might work on N900 too.
I proposed an alternative fix for N9 (http://talk.maemo.org/showpost.php?p...3&postcount=42), which, to my surprise, also fixed the problem with sending SMSes with Emoji characters (http://talk.maemo.org/showpost.php?p...0&postcount=56). The same fix (replacing UCS-2 with UTF16 directly in libsms-utils) might also fix the problem on N900 too (I don't have N900, so I can't try).
I used the method peterleinchen suggested but I wasn't able to get a sms to send.
I tried twice :
a sms with just an emoji failed to send
a sms with text and emoji disappeared into the void

I didn't try just copying the binary though.

Can anyone else confirm if it's working or not for the n900?
 
Reply

Thread Tools

 
Forum Jump


All times are GMT. The time now is 14:54.