Notices


Reply
Thread Tools
Posts: 26 | Thanked: 59 times | Joined on Feb 2012 @ Greater Chicagoland area
#1
Hey, all. I'm sure this is something simple, but I simply have not figured it out, yet. So I am yielding and asking here.

I had to replace my Sailfish X F5121 with another F5121. I decided I wanted to keep SFOSX on the old phone and have it on my new, so I bought another license yesterday. When I downloaded the SFOS yesterday it was actually 2.1.4.14, so I didn't have to do the upgrade through versions like I did with the original F5121. Nice.

I've transferred stuff over, set up my T-Mobile USA settings and can get mobile data and MMS text messages. On my old phone the voicemail notification icon worked normally. However, on my new phone, I receive an SMS with content starting:

//VVM:SYNC:ev=NM;id=.....

and my voicemail notification icon doesn't appear. I found a thread from 2015 but this was closed and associated questions on TJC were closed because it was addressed in a far earlier update years ago.

Is anyone else seeing this? I had already upgraded my old phone to 2.1.4.14 and voicemail notification was working fine there. I haven't logged into my T-Mobile portal account to change anything there. To be thorough tomorrow, I will even put my SIM back in my old phone and test this. But that will just show something is different from old phone setup to new phone setup. I don't know where to look for the differences, though. Any ideas?

Thank you.
 

The Following User Says Thank You to RasLikesN9 For This Useful Post:
Posts: 609 | Thanked: 624 times | Joined on Mar 2012 @ Ohio
#2
Originally Posted by RasLikesN9 View Post
Hey, all. I'm sure this is something simple, but I simply have not figured it out, yet. So I am yielding and asking here.

I had to replace my Sailfish X F5121 with another F5121. I decided I wanted to keep SFOSX on the old phone and have it on my new, so I bought another license yesterday. When I downloaded the SFOS yesterday it was actually 2.1.4.14, so I didn't have to do the upgrade through versions like I did with the original F5121. Nice.

I've transferred stuff over, set up my T-Mobile USA settings and can get mobile data and MMS text messages. On my old phone the voicemail notification icon worked normally. However, on my new phone, I receive an SMS with content starting:

//VVM:SYNC:ev=NM;id=.....

and my voicemail notification icon doesn't appear. I found a thread from 2015 but this was closed and associated questions on TJC were closed because it was addressed in a far earlier update years ago.

Is anyone else seeing this? I had already upgraded my old phone to 2.1.4.14 and voicemail notification was working fine there. I haven't logged into my T-Mobile portal account to change anything there. To be thorough tomorrow, I will even put my SIM back in my old phone and test this. But that will just show something is different from old phone setup to new phone setup. I don't know where to look for the differences, though. Any ideas?

Thank you.
In my experience, this message is displayed when T-Mobile thinks you have visual voicemail. When I put my sim into my Nexus 5 running SFOS this message appears when I get a voicemail. If I turn off visual voicemail on my other device (BB10) before removing the sim to put it into my Nexus 5, I don't get this message.

I don't get many voicemails, so it has been awhile, but I believe this is how it works for me...
 

The Following 5 Users Say Thank You to imaginaryenemy For This Useful Post:
Posts: 284 | Thanked: 887 times | Joined on Jun 2010 @ USA
#3
Honestly I never could get rid of this (I'm on t-mobile US) on my old (retired) Nexus 5 or my current Sailfish X. So I installed phonehook and blocked the number it comes from.

Magic... it's gone!
__________________
Sony Xperia X SFOS 2.1.3.7, Nokia N810
 

The Following 2 Users Say Thank You to deprecated For This Useful Post:
Posts: 26 | Thanked: 59 times | Joined on Feb 2012 @ Greater Chicagoland area
#4
Ugh. I'm soooo sorry it took me so long to reply to this. Imaginaryenemy (IE), you were absolutely correct. What through me was my logic that I had an F5121 and replaced it with another F5121, so why would T-Mobile do this to me on one phone and not the other?

But after IE posted, combined with the text I received starting with "VVM", I determined IE had to be correct, so I called T-Mobile. That got me quickly escalated and that person was awesome. If I had a direct number to give you guys, I would. He went through a bunch of stuff and found that, indeed, my line now had VVM turned on. It turned out that two of the other lines of the four in our plan had it turned on, as well. I muted my mic and asked the family members with those lines and it turns out they have received these messages since we went from N9s to the SFOSX phones. They just never told me about it.

So the tech support guy had to do a bit more than just uncheck a box. He had to rebuild our voicemail boxes, then send a reset to the phone which would drop our call. He called me back and the problem was resolved. We tested with various voicemails and I've not received an errant message since he worked his magic.

Deprecated, since the VVM messages were coming from the same number that T-Mobile uses to send other notifications, I didn't want to block the number altogether. But yes, that solution would have worked, as well.

I still don't know why the fourth line, also an F5121 with SFOSX on it didn't get identified as a VVM phone, nor why my original one didn't. But whatever the case, it is something you can ask them to turn off for you.

Thanks for your help and sorry for the delayed response.
 

The Following 6 Users Say Thank You to RasLikesN9 For This Useful Post:
Reply

Tags
voicemail

Thread Tools

 
Forum Jump


All times are GMT. The time now is 14:33.