Notices


Reply
Thread Tools
Posts: 84 | Thanked: 245 times | Joined on Jan 2014 @ India
#1
So this now is an annoying issue for many Aqua Fish owners. And some claim, they don't have it. Anyway, I hope this thread can give some insights or even possibly solve the issue on Aqua Fish. May be the next update will solve it, but patience has limits and curiousity does not.

This is what I know. At every boot, systemd starts a service to send an sms to a predefined number after three hours of uptime and stops the service.

Code:
[root@Sailfish nemo]# cat /usr/lib/systemd/user/sms-activation-intex.service
[Unit]
Description=Sends an activation SMS to Intex

[Service]
Type=simple
EnvironmentFile=/var/lib/environment/sms-activation-intex/sms-activation-intex.conf
ExecStart=/usr/libexec/sms-activation-intex

[Install]
WantedBy=user-session.target
I suppose commenting "ExecStart=..intex" should prevent the code to send sms from executing.

The coonfiguration file has the number to which sms is sent.
Code:
[root@Sailfish nemo]# cat /var/lib/environment/sms-activation-intex/sms-activation-intex.conf
INTEX_SMS_ACTIVATION_NUMBER=+919582943043
INTEX_SMS_ACTIVATION_DONE_FILE_PATH=/mnt/vendor_data/.sms-activation-intex-done
So I checked the path which mention the activation completed file. And there is no ".sms-activation-intex-done" file created, which may be triggering the sms sending procedure after a reboot again.

Can I simply delete the .service and .timer files, of course after making a backup at some other location? Or how can I prevent that being run at every boot?

And could AquaFish owners who are not facing the recurring sms issue please check location /mnt/vendor/data for the file ".sms-intex-activation-done" and share its content if that doesn't seem to be something confidential like a unique activation code.

Update:
Masking the timer seems to be a working solution for now.
Refer this post. Thanks to mautz!

Last edited by lal; 2016-08-03 at 02:42.
 

The Following 5 Users Say Thank You to lal For This Useful Post:
Posts: 238 | Thanked: 934 times | Joined on Feb 2015
#2
I would just rip this stuff off.
There's no place on Sailfish for this cheap-noname-china-android-phone-malware stuff.
 

The Following 5 Users Say Thank You to lantern For This Useful Post:
Posts: 20 | Thanked: 55 times | Joined on Sep 2011 @ Leuven/Belgium
#3
China..? Isn't that India?^^
 

The Following 4 Users Say Thank You to napaDokc For This Useful Post:
Posts: 238 | Thanked: 934 times | Joined on Feb 2015
#4
Originally Posted by napaDokc View Post
China..? Isn't that India?^^
It is. But cheap china android phones are notorious for having malware in stock fw.
 

The Following 5 Users Say Thank You to lantern For This Useful Post:
Posts: 20 | Thanked: 75 times | Joined on Jul 2016 @ India
#5
That's great
Don't know why I didn't try to find.

what if we create the file ".sms-intex-activation-done" manually?
I'm having same issue and no file in /mnt/vendor_data
 

The Following 5 Users Say Thank You to bhavin192 For This Useful Post:
Posts: 370 | Thanked: 1,008 times | Joined on Feb 2014 @ Germany
#6
Why don't you just disable the service?
 

The Following 4 Users Say Thank You to mautz For This Useful Post:
Posts: 20 | Thanked: 75 times | Joined on Jul 2016 @ India
#7
Originally Posted by mautz View Post
Why don't you just disable the service?
LOL
That's what I was thinking about but I was trying with systemctl
there is pkcon for that.

https://together.jolla.com/question/...rom-aqua-fish/
 

The Following User Says Thank You to bhavin192 For This Useful Post:
Posts: 370 | Thanked: 1,008 times | Joined on Feb 2014 @ Germany
#8
The TJC post has nothing to do with the sms service described here.

just stop the service with:

systemctl --user stop sms-activation-intex.service

and see if the problem is gone. To disable the service permanently use:

systemctl --user disable sms-activation-intex.service
 

The Following 9 Users Say Thank You to mautz For This Useful Post:
Posts: 84 | Thanked: 245 times | Joined on Jan 2014 @ India
#9
Originally Posted by mautz View Post
The TJC post has nothing to do with the sms service described here.

just stop the service with:

systemctl --user stop sms-activation-intex.service

and see if the problem is gone. To disable the service permanently use:

systemctl --user disable sms-activation-intex.service
Thanks! I just disabled it. Will reboot the phone now and see if it sends further sms after three hours.
 

The Following 3 Users Say Thank You to lal For This Useful Post:
Posts: 20 | Thanked: 75 times | Joined on Jul 2016 @ India
#10
Originally Posted by mautz View Post
The TJC post has nothing to do with the sms service described here.

just stop the service with:

systemctl --user stop sms-activation-intex.service

and see if the problem is gone. To disable the service permanently use:

systemctl --user disable sms-activation-intex.service
So --user was missing
It doesn't need root privileges also
thanks

Last edited by bhavin192; 2016-07-31 at 17:49.
 

The Following 2 Users Say Thank You to bhavin192 For This Useful Post:
Reply

Tags
activation sms, aqua fish, intex

Thread Tools

 
Forum Jump


All times are GMT. The time now is 23:31.