Notices


Reply
Thread Tools
Posts: 126 | Thanked: 315 times | Joined on Jun 2014 @ Finland
#1
I bought two Patona 1500mAh batteries to replace my old ones. They seem to perform nicely, but the device thinks they have about 1200-1300mAh capacity instead of 1500. I have been trying to calibrate them using Estel's guide: http://talk.maemo.org/showpost.php?p...93&postcount=2

I have tried twice, and both times VDQ just turned 0 but the device shut down (didn't faint but powered off) before I managed to do it manually. So looks like modprobing doesn't work. If I understood it correctly, modprobing those modules should prevent the device performing panic poweroff, but somehow it doesn't work.

Here's my lsmod after a reboot and while charging: https://pastebin.com/cWWwZajX

The module rx51_battery mentioned in the guide is there, and then there is power_supply module which is used by rx51_battery. But the other mentioned module called bq27x00_battery is missing. Is this normal, or have something changed in the system after writing that guide? Or is there something else that I am doing wrong?

I have managed to get voltage around 3245mV (monitored using BNF), and as said, VDQ turns to zero at that point, but then the device immediately powers off. I guess that if the modprobing worked as it should, the device would stay up and running until voltage drops to somewhere below 3000mV. And I have done the last steps very slowly, having all the apps closed and internet switched off. Just dim screen on to prevent any accidental power peaks to drop the voltage too fast.

Last edited by Koiruus; 2018-05-07 at 21:45.
 

The Following User Says Thank You to Koiruus For This Useful Post:
Posts: 126 | Thanked: 315 times | Joined on Jun 2014 @ Finland
#2
While holding that massive group of people aggressively offering their help with one hand, I did some more research with my other hand. Which I guess I should have done in the first place. I found BME replacement thread and gave it a try. Now the battery applet and bnf give same information about battery capacity. So I guess the problem is solved now.
 

The Following 2 Users Say Thank You to Koiruus For This Useful Post:
Reply

Thread Tools

 
Forum Jump


All times are GMT. The time now is 15:48.