Notices


Reply
Thread Tools
Posts: 343 | Thanked: 1,535 times | Joined on Aug 2016 @ Estonia
#111
@Zeta, thank you very much for testing!

I must say I am quite puzzled with the results. Its all working on OnePlus X SFOS 2.1.0.11 - no crashes.

So, I would like to ask others to test and check whether it works on other hardware. Earlier we had as working:

Oneplus One, SFOS 2.1.1.24
Jolla C, SFOS 2.1.1.26
Sony X, SFOS 2.1.1.26
Jolla Tablet, SFOS 2.1.1.26

and crashing

Jolla 1, SFOS 2.1.0.11, n=3
Photon Q, 2.1.0.11

Would be good if at least one J1 owner would confirm the crash with the current demo.

Few things have changed when compared to the earlier test:

* I am linking libstdc++ statically, as I did for mapbox-gl-qml to ensure that I can distribute Mapbox GL QML type as a plugin. Earlier, a dynamic linking with libstdc++ was used and libstdc++ together with the libgcc_s were provided with the binary. I am not doing that anymore and maybe this causes the crash.

* QMapboxGL library is updated to qt-staging branch from qt-v1.1.0 to enable mangling of URLs when requested from online (corresponding PR https://github.com/mapbox/mapbox-gl-native/pull/10156 was just accepted upstream). Use of the latest qt branch was required to enable support of internal Mapbox GL scheduler that is used in constructing the corresponding callback. URL mangling is required when you want to use servers that ask for api keys, as the server setup by @otsaloma does. However, maybe there are some additional changes in the new branch that lead to the crash.

* there are probably several other changes that I did while developing the QML type, but nothing really pops up into my mind that would cause such behavior.

So, before I start reverting the changes, would be good to get some additional testing on the current version.

Edit: PS: Zeta, sailfish_latest_armv7hl (armv8el) used to be before as well. As far as I understood, its default for the current SFOS target. Or am I wrong?

Last edited by rinigus; 2017-10-10 at 07:34.
 

The Following 2 Users Say Thank You to rinigus For This Useful Post:
Posts: 50 | Thanked: 112 times | Joined on Dec 2016
#112
For me mapbox-sfos is working fine on nexus 5 with 2.1.2.3.
 

The Following User Says Thank You to bomo For This Useful Post:
Posts: 343 | Thanked: 1,535 times | Joined on Aug 2016 @ Estonia
#113
Originally Posted by bomo View Post
For me mapbox-sfos is working fine on nexus 5 with 2.1.2.3.
bomo, thanks four reporting ! it's the latest version (red map with country borders only ), right ?
 

The Following User Says Thank You to rinigus For This Useful Post:
Posts: 50 | Thanked: 112 times | Joined on Dec 2016
#114
Originally Posted by rinigus View Post
bomo, thanks four reporting ! it's the latest version (red map with country borders only ), right ?
the version from the linked repo. Yes, it was red with borders only; and playing with the knobs worked also.

Last edited by bomo; 2017-10-10 at 12:49.
 

The Following 2 Users Say Thank You to bomo For This Useful Post:
Posts: 232 | Thanked: 978 times | Joined on Oct 2013 @ France
#115
Originally Posted by rinigus View Post
I must say I am quite puzzled with the results. Its all working on OnePlus X SFOS 2.1.0.11 - no crashes.
Yes, me too. I hope it is only something wrong on my phone, but I doubt it. We'll see when another J1 user will test it.

Originally Posted by rinigus View Post
PS: Zeta, sailfish_latest_armv7hl (armv8el) used to be before as well. As far as I understood, its default for the current SFOS target. Or am I wrong?
Searching a little, I found that : https://wiki.merproject.org/wiki/ARM
The OBS provides a number of uniquely named schedulers but these are not named appropriately for Mer and we use armv7el scheduler for armv6l, armv7l builds and armv8el scheduler for armv7hl.
So it looks like it is only a name, not something related to armv8.
 

The Following User Says Thank You to Zeta For This Useful Post:
Posts: 343 | Thanked: 1,535 times | Joined on Aug 2016 @ Estonia
#116
Originally Posted by Zeta View Post
Yes, me too. I hope it is only something wrong on my phone, but I doubt it. We'll see when another J1 user will test it.
No, I doubt there is something wrong with your phone. But let's wait for conformation. So far, we have 1+X and N5 working, J1 failing.

Originally Posted by Zeta View Post
Searching a little, I found that : https://wiki.merproject.org/wiki/ARM
So it looks like it is only a name, not something related to armv8.
Thank you for looking it up!
 
Posts: 26 | Thanked: 11 times | Joined on Aug 2008 @ Netherlands
#117
Hi,

Your mapbox-sfos-0.1 is working perfectly on Oneplus One, with 2.1.1.24. smooth zooming while pitched in and lanscape mode: great job!
 

The Following User Says Thank You to wdehoog For This Useful Post:
Posts: 140 | Thanked: 290 times | Joined on Nov 2014
#118
Originally Posted by rinigus View Post
Would be good if at least one J1 owner would confirm the crash with the current demo.
Code:
[nemo@Sailfish ~]$ mapbox-sfos
[D] unknown:0 - Using Wayland-EGL
Segmentation fault
J1 - SFOS 2.1.2.3

I noticed the GPS satelite icon in the status bar was flashing for a while after trying to launch mapbox-sfos.
 

The Following 2 Users Say Thank You to tmi For This Useful Post:
Posts: 36 | Thanked: 76 times | Joined on Sep 2013 @ Norway
#119
Originally Posted by tmi View Post
Code:
[nemo@Sailfish ~]$ mapbox-sfos
[D] unknown:0 - Using Wayland-EGL
Segmentation fault
J1 - SFOS 2.1.2.3

I noticed the GPS satelite icon in the status bar was flashing for a while after trying to launch mapbox-sfos.
Same result on my J1 - SFOS 2.1.2.3.
 

The Following 2 Users Say Thank You to PamNor For This Useful Post:
Posts: 343 | Thanked: 1,535 times | Joined on Aug 2016 @ Estonia
#120
Thanks for testing!

GPS was enabled in the earlier version (version 2) of the demo, just not advertised.

Looks like we have similar situation as earlier, with J1 failing and others doing just fine. Zeta's backtrace suggests that crash is during rendering (calls to mbgl::Renderer::Impl::render), its maybe just hits the corresponding section faster.

We are still missing debug info in the builds, I'll look how to enable it so we could get something more out of the crashes. Just probably would do it a bit later. Or maybe someone could look into qmapboxgl and mapbox qml rpm's and suggest the changes?
 

The Following User Says Thank You to rinigus For This Useful Post:
Reply

Thread Tools

 
Forum Jump


All times are GMT. The time now is 23:44.