Notices


Reply
Thread Tools
kick's Avatar
Posts: 58 | Thanked: 84 times | Joined on Jan 2017 @ India
#11
can you give me quick steps for the process i need to do to rewrite cert-sw as i probably am stuck on pr006 itll be really helpful if you could explain a little about what i have to do

BTW i have got the n9 back (but on pr006 which sucks as no cmt)
i have developer mode
and have aegis
 

The Following User Says Thank You to kick For This Useful Post:
Posts: 1,132 | Thanked: 1,794 times | Joined on Feb 2011 @ The Netherlands
#12
Originally Posted by kick View Post
can you give me quick steps for the process i need to do to rewrite cert-sw as i probably am stuck on pr006 itll be really helpful if you could explain a little about what i have to do

BTW i have got the n9 back (but on pr006 which sucks as no cmt)
i have developer mode
and have aegis
From the third link I gave you:

Step 1: Obtain an older cert.
A: Dump it from your /dev/mtd1 or B: use the cert from that post.

Step 2: rename the the cert and place it in '/root/' so you end up with '/root/cert.bin'

for example:
Code:
cp /home/user/MyDocs/cert-DFL61_HARMATTAN_40.2012.21-3_PR_001.bin /root/cert.bin
Step 3: Install that deb (compile it yourself from source, if you want)
note it has to be installed from com.nokia.maemo origin. So you need to have aegis-install hack.

Step 4: Invoke cal-writer as root from command-line.


NO GUARANTEES as I never tried it myself.
__________________
N900 loaded with:
CSSU-T (Thumb)
720p recording,
Pierogi, Lanterne, Cooktimer, Frogatto
N9 16GB loaded with:
Kernel-Plus
--
[TCPdump & libpcap | ngrep]
--
donate
 

The Following 3 Users Say Thank You to mr_pingu For This Useful Post:
kick's Avatar
Posts: 58 | Thanked: 84 times | Joined on Jan 2017 @ India
#13
i did the steps you said but it gives an error

Error: open(/dev/mtd1): permission denied
couldnt open cal for writing

and before you say yes i did install it by doing
aegis-dpkg -i <file address>
also i did have the cert.bin in the root directory and yes i did run it as root

EDIT: i tried it out with inception privleges and it probably worked
the last thing it says is
debug: 2: nand_write: 4096 bytes to 0x000e3000 retval : 0
is that a good sign? even if it is or isnt ima try flashing and tell please gimme the news while im flashing

Last edited by kick; 2017-08-08 at 22:31.
 

The Following User Says Thank You to kick For This Useful Post:
Posts: 1,132 | Thanked: 1,794 times | Joined on Feb 2011 @ The Netherlands
#14
You can't be in openmode, as it disables writing to CAL. Are you?
Else try this and try again

Code:
chown root:root /dev/mtd1
If that doesn't work you need to figure out why you don't have all rights to write to CAL. I can't think of what's blocking that.

If it works you need to change the owner of mtd1 back:
Code:
chown cal:cal /dev/mtd1
__________________
N900 loaded with:
CSSU-T (Thumb)
720p recording,
Pierogi, Lanterne, Cooktimer, Frogatto
N9 16GB loaded with:
Kernel-Plus
--
[TCPdump & libpcap | ngrep]
--
donate

Last edited by mr_pingu; 2017-08-08 at 22:15.
 

The Following User Says Thank You to mr_pingu For This Useful Post:
kick's Avatar
Posts: 58 | Thanked: 84 times | Joined on Jan 2017 @ India
#15
my man it worked im on pr001 now im just waiting for zeroise to finish its thing so that i can check if the cmt flashing of the pr003 works damn thanks man youre a genius i might just use my n9 as a daily driver now

inception does actually add a whole new level of accessibility
 

The Following User Says Thank You to kick For This Useful Post:
kick's Avatar
Posts: 58 | Thanked: 84 times | Joined on Jan 2017 @ India
#16
heres the output of the flash
Code:
C:\Windows\system32>cd C:\Program Files\Nokia\Flasher

C:\Program Files\Nokia\Flasher>flasher -f -F DFL61_HARMATTAN_40.2012.21-3_PR_LEGACY_001-OEM1-958_ARM.bin --erase-user-da
ta=secure
flasher 3.12.1 (Oct  6 2011) Harmattan
WARNING: This tool is intended for professional use only. Using it may result
in permanently damaging your device or losing the warranty.

Ping attempt 1 (250 ms)
Server application: 1.7.2
Found product RM-696 rev. 1603
Server implements softupd protocol version 1.8

Battery level 78 %, continuing.
Erasing, this may take a while.
Erase done.
Image SW version DFL61_HARMATTAN_40.2012.21-3_PR_001
Image moslo not present
Image mmc not present
Image tar skipped
Image config skipped

Battery level 81 %, continuing.

    image        [state    progress         transfer     flash speed]
---------------------------------------------------------------------
[x] cert-sw      [finished   100 %       1 /       1 kB      NA     ]
[x] cmt-2nd      [finished   100 %      95 /      95 kB      NA     ]
[x] cmt-algo     [finished   100 %     789 /     789 kB      NA     ]
[_] cmt-mcusw    [finishing    0 %    6050 /    6050 kB    3066 kB/s]
[x] xloader      [finished   100 %      23 /      23 kB      NA     ]
[x] secondary    [finished   100 %      94 /      94 kB      NA     ]
[x] kernel       [finished   100 %    2714 /    2714 kB    3100 kB/s]
[_] rootfs       [writing     56 %  664576 / 1170282 kB    5423 kB/s]
ERROR: SU_GET_UPDATE_STATUS_REQ terminated with error code 1: Unknown error

    image        [state    progress         transfer     flash speed]
---------------------------------------------------------------------
[x] cert-sw      [finished   100 %       1 /       1 kB      NA     ]
[x] cmt-2nd      [finished   100 %      95 /      95 kB      NA     ]
[x] cmt-algo     [finished   100 %     789 /     789 kB      NA     ]
[f] cmt-mcusw    [finishing    0 %    6050 /    6050 kB    3066 kB/s]
[x] xloader      [finished   100 %      23 /      23 kB      NA     ]
[x] secondary    [finished   100 %      94 /      94 kB      NA     ]
[x] kernel       [finished   100 %    2714 /    2714 kB    3100 kB/s]
[x] rootfs       [finished   100 % 1170282 / 1170282 kB    6160 kB/s]
Fetching error list:
========================================
Update content failed to verify against cert: SW certificate not updated
bb5_rdc_cert_read failed
bb5_rdc_cert_read failed
bb5_rdc_cert_read failed
bb5_rdc_cert_read failed
bb5_rdc_cert_read failed
MTC_NOS_READY not received
MTC_NOS_READY not received
MTC_NOS_READY not received
CMT RFS failed
[Pipe   7] Finishing in error state with status 1
========================================

ERROR: Failed to flash images

C:\Program Files\Nokia\Flasher>flasher -f -F DFL61_HARMATTAN_40.2012.21-3_PR_LEGACY_001-OEM1-958_ARM.bin -F Emmc.bin -M
flasher 3.12.1 (Oct  6 2011) Harmattan
WARNING: This tool is intended for professional use only. Using it may result
in permanently damaging your device or losing the warranty.

Ping attempt 1 (250 ms)
Server application: 1.7.2
Found product RM-696 rev. 1603
Server implements softupd protocol version 1.8
Image SW version DFL61_HARMATTAN_40.2012.21-3_PR_001
Image cmt-2nd skipped
Image cmt-algo skipped
Image cmt-mcusw skipped
Image xloader skipped
Image secondary skipped
Image kernel skipped
Image moslo skipped
Image rootfs skipped
Image tar skipped
Image config skipped

Battery level 82 %, continuing.

    image        [state    progress         transfer     flash speed]
---------------------------------------------------------------------
[x] cert-sw      [finished   100 %       1 /       1 kB      NA     ]
[x] mmc          [finished   100 %  261587 /  261587 kB    5745 kB/s]
Success

C:\Program Files\Nokia\Flasher>flasher -f -F china.bin --flash-only=cmt
flasher 3.12.1 (Oct  6 2011) Harmattan
WARNING: This tool is intended for professional use only. Using it may result
in permanently damaging your device or losing the warranty.

Ping attempt 1 (250 ms)
Server application: 1.7.2
Found product RM-696 rev. 1603
Server implements softupd protocol version 1.8
Image SW version DFL61_HARMATTAN_40.2012.21-3_PR_003
Image cert-sw skipped
Image xloader skipped
Image secondary skipped
Image kernel skipped
Image moslo skipped
Image rootfs skipped
Image mmc skipped
Image tar skipped
Image config skipped

Battery level 83 %, continuing.

    image        [state    progress         transfer     flash speed]
---------------------------------------------------------------------
[x] cmt-2nd      [finished   100 %      95 /      95 kB      NA     ]
[x] cmt-algo     [finished   100 %     789 /     789 kB      NA     ]
[_] cmt-mcusw    [finishing   75 %    6050 /    6050 kB    3160 kB/s]
ERROR: SU_GET_UPDATE_STATUS_REQ terminated with error code 1: Unknown error

    image        [state    progress         transfer     flash speed]
---------------------------------------------------------------------
[x] cmt-2nd      [finished   100 %      95 /      95 kB      NA     ]
[x] cmt-algo     [finished   100 %     789 /     789 kB      NA     ]
[f] cmt-mcusw    [finishing    0 %    6050 /    6050 kB    3160 kB/s]
Fetching error list:
========================================
Update content failed to verify against cert: SW certificate not updated
bb5_rdc_cert_read failed
bb5_rdc_cert_read failed
bb5_rdc_cert_read failed
bb5_rdc_cert_read failed
bb5_rdc_cert_read failed
Update content failed to verify against cert: SW certificate not updated
bb5_rdc_cert_read failed
bb5_rdc_cert_read failed
bb5_rdc_cert_read failed
bb5_rdc_cert_read failed
bb5_rdc_cert_read failed
MTC_POWER_OFF not received
CMT RFS failed
[Pipe   2] Finishing in error state with status 1
========================================

ERROR: Failed to flash images

C:\Program Files\Nokia\Flasher>
cmt still wont flash if theres any fix for that will have the n9 back to speed
 

The Following User Says Thank You to kick For This Useful Post:
mike727's Avatar
Posts: 60 | Thanked: 114 times | Joined on Aug 2015 @ Australia
#17
Originally Posted by kick View Post
cmt still wont flash if theres any fix for that will have the n9 back to speed
edit: just realised that this is repeating info, sorry.

If the phone has ever been flashed with 003, cmt might only be flashed using 003, as you see here.
Code:
flasher -f -F old(003)_main.bin --flash-only=cmt

Last edited by mike727; 2017-08-09 at 00:21.
 

The Following User Says Thank You to mike727 For This Useful Post:
Posts: 1,132 | Thanked: 1,794 times | Joined on Feb 2011 @ The Netherlands
#18
Oh boy you have damaged CMT hardware or software. In your case it's software because only CMT-mcusw fails, the other CMT parts ARE flashed, actually a good sign.
Basically if you flash new RPL file specifically for your phone it might be fixed. Unfortunately, we can't get these files from Nokia anymore. We wouldn't anyway because they were only sold to repair-shop owners / Nokia Service Centers. So that option is striked.
For users that have a working N9, there are tools out there that can backup RPL. Google RPL + BB5.
Addition from what I read; It seems that you can create RPL from PM backup. Making a PM backup and then make RPL from it and write RPL might fix it too.

The thing is we need to flash CMT of 003 variant. But we are running a bit out of options, unfortunately.

But there things you can try, what happens if you upgrade everything to 003?

Else we must resort to more experimental methods and that's a long time ago for me. In the symbian days we could use JAF over USB to flash almost everything. Now we need sort of the same thing, to force flash the right CMT.

The options are listed below, again no guarantees.

I would start to examine JAF, you probably need windows XP for this, 7 may work too but I am not sure of win10. You might one to tick dead-phone/usb mode.

Maybe Cyclone Box software can be hacked to work over USB too.Or maybe it works out of the box over USB. I don't know.

Otherwise BB5 service tool by Infinity Team might help you.

Really these are experimental waters, to see if we can revive it.
As last option would be to optain a flash-box, but then no guarantees that that will work.


EDIT: I'm trying to examine the errors from your logs. Then I found this: https://bugs.maemo.org/show_bug.cgi?id=7433. Some suggest to try different PC / OS. Might help.
Suggestion 2:
Also try with --no-preserve
Suggestion 3: Check if firmware files are not corrupt.
__________________
N900 loaded with:
CSSU-T (Thumb)
720p recording,
Pierogi, Lanterne, Cooktimer, Frogatto
N9 16GB loaded with:
Kernel-Plus
--
[TCPdump & libpcap | ngrep]
--
donate

Last edited by mr_pingu; 2017-08-09 at 10:38.
 

The Following 2 Users Say Thank You to mr_pingu For This Useful Post:
kick's Avatar
Posts: 58 | Thanked: 84 times | Joined on Jan 2017 @ India
#19
i tried using --no-preserve got the same result heres the output
Code:
C:\Windows\system32>cd C:\Program Files\Nokia\Flasher

C:\Program Files\Nokia\Flasher>flasher -f -F china.bin --flash-only=cmt --no-preserve
flasher 3.12.1 (Oct  6 2011) Harmattan
Warning: --no-preserve is not recommended, instead use erase commands
WARNING: This tool is intended for professional use only. Using it may result
in permanently damaging your device or losing the warranty.

Suitable USB interface (bootloader/phonet) not found, waiting...
Found device RM-696, hardware revision 1603
NOLO version 2.3.6
Version of 'sw-release': DFL61_HARMATTAN_40.2012.21-3_PR_001
Sending ape-algo image (7096 kB)...
100% (7096 of 7096 kB, avg. 14024 kB/s)
Suitable USB interface (phonet) not found, waiting...
Ping attempt 1 (250 ms)
Server application: 1.7.2
Found product RM-696 rev. 1603
Server implements softupd protocol version 1.8
Image SW version DFL61_HARMATTAN_40.2012.21-3_PR_003
Image cert-sw skipped
Image xloader skipped
Image secondary skipped
Image kernel skipped
Image moslo skipped
Image rootfs skipped
Image mmc skipped
Image tar skipped
Image config skipped

Battery level 77 %, continuing.

    image        [state    progress         transfer     flash speed]
---------------------------------------------------------------------
[x] cmt-2nd      [finished   100 %      95 /      95 kB      NA     ]
[x] cmt-algo     [finished   100 %     789 /     789 kB      NA     ]
[_] cmt-mcusw    [finishing   75 %    6050 /    6050 kB    3240 kB/s]
ERROR: SU_GET_UPDATE_STATUS_REQ terminated with error code 1: Unknown error

    image        [state    progress         transfer     flash speed]
---------------------------------------------------------------------
[x] cmt-2nd      [finished   100 %      95 /      95 kB      NA     ]
[x] cmt-algo     [finished   100 %     789 /     789 kB      NA     ]
[f] cmt-mcusw    [finishing    0 %    6050 /    6050 kB    3240 kB/s]
Fetching error list:
========================================
bb5_rdc_cert_read failed
bb5_rdc_cert_read failed
bb5_rdc_cert_read failed
bb5_rdc_cert_read failed
bb5_rdc_cert_read failed
bb5_rdc_cert_read failed
MTC_POWER_OFF not received
CMT RFS failed
[Pipe   2] Finishing in error state with status 1
========================================

ERROR: Failed to flash images
so --no-preserve didnt help i also tried with windows 7 same result
so it seems that when i accedintally flashed the 006 firm it mustve overwritten my cmt-mcusw as i did the zeroise thing and wont let me reflash the cmt completely even on another zero hmm interisting probably needs more checking i dunno if even inception can help at this point as i dunno what state its in
 

The Following User Says Thank You to kick For This Useful Post:
kick's Avatar
Posts: 58 | Thanked: 84 times | Joined on Jan 2017 @ India
#20
also the files are good i downloaded around 3 of the same firmware from diffrent sources(the chinese 003 firm) and all gave the same result probably not the file's fault
 

The Following User Says Thank You to kick For This Useful Post:
Reply

Thread Tools

 
Forum Jump


All times are GMT. The time now is 07:43.