Notices


Reply
Thread Tools
Posts: 175 | Thanked: 181 times | Joined on Jan 2010 @ Accra,Ghana
#621
Originally Posted by ntxy View Post

I even get a login prompt for a few seconds. But before I can log in the phone switches off.
are these symptoms of a wrong systemd version ? haven't had the chance to downgrade systemd to your version.
mb it's the hard float...


i believe the screen goes off because the watchdog module is not loaded. did you compile the kernel modules? if you did then you need to place them in the correct folder as stated in my tutorial.
 

The Following 2 Users Say Thank You to tcbl50 For This Useful Post:
Posts: 5 | Thanked: 3 times | Joined on Nov 2016
#622
oh there was indeed something wrong with the modules.

lib symlinks to usr/lib. I broke that somehow when I did

Code:
10. Go to your modules folder and copy the folder "lib" to /mnt/
yeah and I followed the elinux/n900 page too blindly for compiling the kernel/dt kernel. did both. so the modules didn't get the correct config values (I guess..)

the watchdog hint was the key! thanks

I can log in now and there is no shutting off anymore but lots of services are failing. including logind. but I'm onto that.
 
Posts: 5 | Thanked: 3 times | Joined on Nov 2016
#623
Originally Posted by saponga View Post
You need kernel-power
I installed "U-Boot with kernel 2.6.28-omap1" from the application manager as the 1st post of the u-boot thread suggests.

Could I simply install kernel-power after that ?
 
Posts: 389 | Thanked: 678 times | Joined on Jun 2011
#624
Originally Posted by ntxy View Post
I installed "U-Boot with kernel 2.6.28-omap1" from the application manager as the 1st post of the u-boot thread suggests.

Could I simply install kernel-power after that ?
From kernel power 53 thread
U-Boot support (optional):
From Hildon Application Manager install packages: U-Boot with kernel 2.6.28-omap1 and Linux kernel for power user (boot image for U-Boot)
Or via apt-get packages: u-boot-flasher and kernel-power-bootimg
Make sure you accept flashing U-Boot!
 

The Following User Says Thank You to saponga For This Useful Post:
Posts: 175 | Thanked: 181 times | Joined on Jan 2010 @ Accra,Ghana
#625
Originally Posted by ntxy View Post
oh there was indeed something wrong with the modules.

lib symlinks to usr/lib. I broke that somehow when I did

Code:
10. Go to your modules folder and copy the folder "lib" to /mnt/
yeah and I followed the elinux/n900 page too blindly for compiling the kernel/dt kernel. did both. so the modules didn't get the correct config values (I guess..)

the watchdog hint was the key! thanks

I can log in now and there is no shutting off anymore but lots of services are failing. including logind. but I'm onto that.
services are failing due to the version of systemd installed. what you can do is get the old version of systemd and put it on your memory card. then you can install it manually using pacman - U
 

The Following User Says Thank You to tcbl50 For This Useful Post:
Posts: 5 | Thanked: 3 times | Joined on Nov 2016
#626
Originally Posted by saponga View Post
From kernel power 53 thread
U-Boot support (optional):
From Hildon Application Manager install packages: U-Boot with kernel 2.6.28-omap1 and Linux kernel for power user (boot image for U-Boot)
Or via apt-get packages: u-boot-flasher and kernel-power-bootimg
Make sure you accept flashing U-Boot!
oh thanks, I missed that one.
 
Posts: 5 | Thanked: 3 times | Joined on Nov 2016
#627
Originally Posted by tcbl50 View Post
services are failing due to the version of systemd installed. what you can do is get the old version of systemd and put it on your memory card. then you can install it manually using pacman - U
yes ofc. that worked.

any ideas why the newest systemd doesn't ?
 
Posts: 175 | Thanked: 181 times | Joined on Jan 2010 @ Accra,Ghana
#628
 

The Following User Says Thank You to tcbl50 For This Useful Post:
Posts: 13 | Thanked: 8 times | Joined on Jan 2012
#629
Does anyone have a working link to alarm-n900-201306-rootfs.tar.gz or ArchLinuxARM-N900-2013.02-rootfs.tar.gz?
 
Reply

Thread Tools

 
Forum Jump


All times are GMT. The time now is 07:39.