Notices


Reply
Thread Tools
Guest | Posts: n/a | Thanked: 0 times | Joined on
#31
Search for bugs , for example:https://www.midnight-commander.org/ticket/3144

btw, version 4.8.10 is on my openrepos
https://openrepos.net/content/nieldk/midnight-commander
 

The Following 3 Users Say Thank You to For This Useful Post:
Posts: 532 | Thanked: 501 times | Joined on May 2010 @ nanaurbusiness
#32
Hmmm, ok.
I'll just use yours.

So, thanks for adding mc to your openrepos...

Regards,

J4ZZ
__________________

N900 ~ $ make me a sandwich
-bash: no, make it yourself
N900 ~ $ sudo make me a sandwich
-bash: ok then...

Last edited by J4ZZ; 2014-01-08 at 22:24.
 
xerxes2's Avatar
Posts: 513 | Thanked: 651 times | Joined on Feb 2011 @ Sweden
#33
@neildk

You seems to be the man to ask for cli apps so I would like to make a request for wget. If you would add that to openrepos that would be awesome. Curl -O works but still wget is less to write.
__________________
But the WM7 "horse" has a blood lineage tracing back to donkeys such as WM6.5, 6.1, 6.0, 5.1 that was fully neglected for too many years and Microsoft did sweet F all to maintain it (still running on Pocket IE4/6!!).
 
Posts: 532 | Thanked: 501 times | Joined on May 2010 @ nanaurbusiness
#34
Already available
Code:
[root@localhost Downloads]# pkcon get-packages | grep wget
Installed    wget-1.13.4-2.4.Nemo.Apps.armv7hl
Edit: Sorry, my bad. I probably just compiled it myself.
Edit2: See post#38
__________________

N900 ~ $ make me a sandwich
-bash: no, make it yourself
N900 ~ $ sudo make me a sandwich
-bash: ok then...

Last edited by J4ZZ; 2014-01-08 at 23:04.
 

The Following User Says Thank You to J4ZZ For This Useful Post:
Posts: 2,076 | Thanked: 3,262 times | Joined on Feb 2011
#35
Originally Posted by J4ZZ View Post
Edit: ./configure works now but make install doesn't?
Anything else I need to be aware of?

Last lines....
Code:
Making install in skin
make[2]: Entering directory `/home/nemo/Downloads/mc-4.8.11/lib/skin'
make[3]: Entering directory `/home/nemo/Downloads/mc-4.8.11/lib/skin'
make[3]: Nothing to be done for `install-exec-am'.
make[3]: Nothing to be done for `install-data-am'.
make[3]: Leaving directory `/home/nemo/Downloads/mc-4.8.11/lib/skin'
make[2]: Leaving directory `/home/nemo/Downloads/mc-4.8.11/lib/skin'
Making install in tty
make[2]: Entering directory `/home/nemo/Downloads/mc-4.8.11/lib/tty'
  CC       key.lo
key.c: In function 'tty_get_event':
key.c:2121:5: error: 'flag' undeclared (first use in this function)
key.c:2121:5: note: each undeclared identifier is reported only once for each function it appears in
make[2]: *** [key.lo] Error 1
make[2]: Leaving directory `/home/nemo/Downloads/mc-4.8.11/lib/tty'
make[1]: *** [install-recursive] Error 1
make[1]: Leaving directory `/home/nemo/Downloads/mc-4.8.11/lib'
make: *** [install-recursive] Error 1
Cheers,

J4ZZ
Checking my bash history...

Code:
./configure --with-screen=ncurses
After this make worked on 4.8.11, no bug fixes/patches needed (you might need to install ncurses-devel and gettext-devel), then again maybe are needed for the overlays from fingerterm, refreshing is kinda screwed (works perfectly when sshed from n900 though, so I blame fingerterm).
 

The Following User Says Thank You to szopin For This Useful Post:
xerxes2's Avatar
Posts: 513 | Thanked: 651 times | Joined on Feb 2011 @ Sweden
#36
Originally Posted by J4ZZ View Post
Already available
Code:
[root@localhost Downloads]# pkcon get-packages | grep wget
Available    wget-1.13.4-2.4.Nemo.Apps.armv7hl
I don't have it but I know that it exists in a Nemo repository but that is not an official repo for Sailfish. Would be much better to have a supported version on openrepos than from some repo that might not work with Sailfish.
__________________
But the WM7 "horse" has a blood lineage tracing back to donkeys such as WM6.5, 6.1, 6.0, 5.1 that was fully neglected for too many years and Microsoft did sweet F all to maintain it (still running on Pocket IE4/6!!).
 

The Following User Says Thank You to xerxes2 For This Useful Post:
Posts: 2,076 | Thanked: 3,262 times | Joined on Feb 2011
#37
Originally Posted by xerxes2 View Post
I don't have it but I know that it exists in a Nemo repository but that is not an official repo for Sailfish. Would be much better to have a supported version on openrepos than from some repo that might not work with Sailfish.
I attached sailfish binary here:
http://talk.maemo.org/showpost.php?p...78&postcount=5
Would be nice to have it auto-updating though
 
Posts: 532 | Thanked: 501 times | Joined on May 2010 @ nanaurbusiness
#38
I took the one from nemo posted by xerxes2.

Code:
curl http://repo.merproject.org/obs/nemo:/devel:/apps/next_armv7hl/armv7hl/wget-1.13.4-2.4.Nemo.Apps.armv7hl.rpm -o wget.rpm
followed by
pkcon install-local wget.rpm
__________________

N900 ~ $ make me a sandwich
-bash: no, make it yourself
N900 ~ $ sudo make me a sandwich
-bash: ok then...
 

The Following 3 Users Say Thank You to J4ZZ For This Useful Post:
Posts: 532 | Thanked: 501 times | Joined on May 2010 @ nanaurbusiness
#39
Originally Posted by szopin View Post
Checking my bash history...

Code:
./configure --with-screen=ncurses
(you might need to install ncurses-devel and gettext-devel)
I did but make still won't work.
Do I need any other additional packages? So far I've also installed autoconf automake libtool and cvs.

Would be nice to know if there are more *-devel packages I probably missed out.

TIA,

J4ZZ
__________________

N900 ~ $ make me a sandwich
-bash: no, make it yourself
N900 ~ $ sudo make me a sandwich
-bash: ok then...

Last edited by J4ZZ; 2014-01-08 at 22:55.
 
Posts: 2,076 | Thanked: 3,262 times | Joined on Feb 2011
#40
Originally Posted by J4ZZ;14'04968
I did but make still won't work.
May I miss additional packages?
I've also installed autoconf automake libtool and cvs.

Would be nice to no if there are more *-devel packages I probably missed out.

TIA,

J4ZZ
'pkcon install pcre' might also be needed, is configure finishing for you? Usually it should inform you that it is not finding a lib
 
Reply

Thread Tools

 
Forum Jump


All times are GMT. The time now is 19:58.