Notices


Reply
Thread Tools
Posts: 286 | Thanked: 855 times | Joined on Dec 2015
#581
If someone's stuck on 2.0.2, then I can do a build for that. I'd rather not though as folks will get confused enough as it is.

Btw, my Pebble2 arrived. Looks nice. Doesn't do anything yet though
 

The Following 3 Users Say Thank You to abranson For This Useful Post:
Posts: 207 | Thanked: 482 times | Joined on Mar 2016
#582
which reminds me of one past due item on my todo list - emery and diorite hw implementation
 
Posts: 23 | Thanked: 35 times | Joined on Feb 2012
#583
@abranson
whats your opinion on this, do you think it is realistic to expect pebble 2 support (btle) for the jolla c soon?
 
Feathers McGraw's Avatar
Posts: 629 | Thanked: 2,253 times | Joined on Jul 2014 @ UK
#584
Can anyone tell me the full version number of SFOS 2.0.5 (2.0.5.X)? I'd like to update to it if possible, I'm on 2.0.4 with the latest version of rockpool and the UI won't open (I didn't mean to upgrade to this version, wasn't paying attention when I upgraded a few FP2 bits!)

Alternatively, do you know how I can downgrade rockpool with zypper/pkcon to the last working version?
 

The Following 2 Users Say Thank You to Feathers McGraw For This Useful Post:
Posts: 286 | Thanked: 855 times | Joined on Dec 2015
#585
Originally Posted by Feathers McGraw View Post
Can anyone tell me the full version number of SFOS 2.0.5 (2.0.5.X)? I'd like to update to it if possible, I'm on 2.0.4 with the latest version of rockpool and the UI won't open (I didn't mean to upgrade to this version, wasn't paying attention when I upgraded a few FP2 bits!)

Alternatively, do you know how I can downgrade rockpool with zypper/pkcon to the last working version?
Afaik you can't do that now - those versions of 2.0.2 and 2.0.3 were only available to the public because they were installed on the Jolla C and the Turing.

Apologies if you're on the wrong version - I thought I'd restricted installation to the correct sailfish version. Must have messed it up. You can fix the version with:

Code:
zypper install --force rockpool-1.3-1
 

The Following 3 Users Say Thank You to abranson For This Useful Post:
Feathers McGraw's Avatar
Posts: 629 | Thanked: 2,253 times | Joined on Jul 2014 @ UK
#586
Originally Posted by abranson View Post
Code:
zypper install --force rockpool-1.3-1
Thanks, that worked perfectly!
 
Posts: 428 | Thanked: 1,043 times | Joined on Jan 2012 @ Enschede, The Netherlands
#587
Since some time now I see the apps and watch settings interface anymore. I guessed it got something to do with the browser component in SFOS 2.0.4, but now in 2.0.5 EA things haven't changed. I've updated Rockpool to 1.3-2.

When trying to configure an app or watch face, all I see is:



And I also grabbed some logging when trying to open the settings page.

When I closed Rockpool, I also got this in the console:

Code:
###!!! [Child][DispatchAsyncMessage] Error: (msgtype=0x460003,name=PEmbedLiteWindow::Msg_Destroy) Route error: message sent to unknown actor ID
What do?
 
Posts: 207 | Thanked: 482 times | Joined on Mar 2016
#588
Jolla still hasn't released 2.0.5 SDK so I don't know yet what to do with it. Still waiting...

Or rather I do know what to do, I just don't have anything to start with

Last edited by ruff; 2016-11-25 at 19:08.
 
Posts: 428 | Thanked: 1,043 times | Joined on Jan 2012 @ Enschede, The Netherlands
#589
You mean this SDK?
 

The Following 2 Users Say Thank You to Fuzzillogic For This Useful Post:
Posts: 207 | Thanked: 482 times | Joined on Mar 2016
#590
weird, why did they publish it on the web but not on the ota
Ok, seems after recent reshuffle I've lost ea repos. thanks for the headsup!

Last edited by ruff; 2016-11-26 at 10:17.
 
Reply

Tags
pebble, smartwatch

Thread Tools

 
Forum Jump


All times are GMT. The time now is 00:47.