Active Topics

 



Notices


Reply
Thread Tools
Posts: 251 | Thanked: 220 times | Joined on Jul 2010
#201
Nope, doesn't work. It shows the downloading Dune II data files progress bar, but then the popup window says it could not install.
__________________
21.2011.38-1Smaemo7 (CSSU Stable)
2.6.28.10power53 (not overclocked)
Yes, I search before posting.
 
Posts: 56 | Thanked: 76 times | Joined on Feb 2010 @ Estonia
#202
Originally Posted by chill View Post
Nope, doesn't work. It shows the downloading Dune II data files progress bar, but then the popup window says it could not install.
That's weird. Did you update you repository (apt-get update)? Latest version shoud be 0.7.2555-maemo11. And try to install from console via 'apt-get install opendune'. Maybe this way it shows something more informative.
 
Posts: 31 | Thanked: 92 times | Joined on Jan 2017
#203
Working fine here~
__________________
2x N900 - collecting dust
1x N9 32GB cyan - collecting dust
1x Jolla - collecting dust, after getting repaired 4 times under warranty..

iPhone SE - main phone for now (missing Maemo)
Surface Pro 4 M3 - Win10 is buggy...
 
Posts: 251 | Thanked: 220 times | Joined on Jul 2010
#204
Originally Posted by NX500 View Post
Working fine here~
Just to clarify, is it a new install or it's been working fine for years?
__________________
21.2011.38-1Smaemo7 (CSSU Stable)
2.6.28.10power53 (not overclocked)
Yes, I search before posting.
 
Posts: 31 | Thanked: 92 times | Joined on Jan 2017
#205
Originally Posted by chill View Post
Just to clarify, is it a new install or it's been working fine for years?
Oh.

It has been a new install through the application manager.
__________________
2x N900 - collecting dust
1x N9 32GB cyan - collecting dust
1x Jolla - collecting dust, after getting repaired 4 times under warranty..

iPhone SE - main phone for now (missing Maemo)
Surface Pro 4 M3 - Win10 is buggy...
 

The Following User Says Thank You to NX500 For This Useful Post:
Posts: 289 | Thanked: 709 times | Joined on Aug 2013
#206
I just gave it a try as well, exactly the same issue as chill.
 

The Following User Says Thank You to t-b For This Useful Post:
Posts: 56 | Thanked: 76 times | Joined on Feb 2010 @ Estonia
#207
Probably some utility expects different arguments or because my 'MyDocs' partition is ext3.
Try to execute postinst manually 'sh -x /var/lib/dpkg/info/opendune.postinst configure'. Then we can see where it fails.
 

The Following User Says Thank You to zod For This Useful Post:
Posts: 289 | Thanked: 709 times | Joined on Aug 2013
#208
Code:
~ $ sh -x /var/lib/dpkg/info/opendune.postinst configure | tee seconf.txt
+ set -e
+ DUNE2_DATA=http://devs.opendune.org/~truebrain/releases/opendune-data.tar.bz2
+ DUNE2_SCENARIO=http://forum.opendune.org/download/file.php?id=6
+ DUNE2_SCENARIO_LEN=312224
+ mkdir -p /home/user/MyDocs/Games/DUNE2
+ [ ! -L /opt/maemo/usr/share/games/opendune/data ]
+ DATAFILE=opendune-data.tar.bz2
+ SCENARIOFILE=scenario.pak
+ cd /home/user/MyDocs/Games/DUNE2
+ [ ! -r dune.pak ]
+ TAR=tar -x
+ tar --version
+ true
+ rm -f opendune-data.tar.bz2
+ download_with_progress http://devs.opendune.org/~truebrain/releases/opendune-data.tar.bz2 opendune-data.tar.bz2 Data
+ [ 3 -lt 3 ]
+ URL=http://devs.opendune.org/~truebrain/releases/opendune-data.tar.bz2
+ TARGET=opendune-data.tar.bz2
+ NAME=Data
+ RUNNING=0
+ [ 0 -eq 0 ]
+ pidof zenity
+ sed s/.*\ \([0-9]\+%\)\ \+\([0-9.]\+\ [KMB\/s]\+\)$/\1\n# Downloading \2/
+ zenity --progress --auto-close --auto-kill --title=Downloading Dune II Data files...
+ wget http://devs.opendune.org/~truebrain/releases/opendune-data.tar.bz2 -Oopendune-data.tar.bz2
+ [ -z 1661 ]
+ sleep 1
+ [ 0 -eq 0 ]
+ pidof zenity
+ [ -z 1661 ]
+ sleep 1
+ [ 0 -eq 0 ]
+ pidof zenity
+ [ -z 1661 ]
+ sleep 1
+ [ 0 -eq 0 ]
+ pidof zenity
+ [ -z 1661 ]
+ sleep 1
+ [ 0 -eq 0 ]
+ pidof zenity
+ [ -z 1661 ]
+ sleep 1
+ [ 0 -eq 0 ]
+ pidof zenity
+ [ -z 1661 ]
+ sleep 1
+ [ 0 -eq 0 ]
+ pidof zenity
+ [ -z  ]
+ :
+ pkill wget
+ RUNNING=1
+ sleep 1
+ [ 1 -eq 0 ]
+ [ -r opendune-data.tar.bz2 ]
+ tar -x
+ bzcat opendune-data.tar.bz2
+ mv opendune-data/data/atre.pak opendune-data/data/dune.pak opendune-data/data/dune2.exe opendune-data/data/english.pak opendune-data/data/finale.pak opendune-data/data/french.pak opendune-data/data/german.pak opendune-data/data/hark.pak opendune-data/data/intro.pak opendune-data/data/introvoc.pak opendune-data/data/mentat.pak opendune-data/data/merc.pak opendune-data/data/ordos.pak opendune-data/data/scenario.pak opendune-data/data/sound.pak opendune-data/data/voc.pak ./ -n
mv: invalid option -- n
 
Posts: 56 | Thanked: 76 times | Joined on Feb 2010 @ Estonia
#209
I have busyboxes and coreutils 'mv' and both have -n. Seems that there are even more versions.
Another fix in repositories (this time it's 0.7.2555-maemo12).
 
Posts: 289 | Thanked: 709 times | Joined on Aug 2013
#210
Looks like it is still 11 in the repo

http://repository.maemo.org/extras-d...ee/o/opendune/
 
Reply

Thread Tools

 
Forum Jump


All times are GMT. The time now is 01:13.