Notices


Reply
Thread Tools
Posts: 20 | Thanked: 75 times | Joined on Jul 2016 @ India
#31
@dillihifi

Try to mask and disable the timer as
Code:
systemctl disable sms-activation-intex.timer
Code:
systemctl mask sms-activation-intex.timer
and reboot the phone.
 

The Following 3 Users Say Thank You to bhavin192 For This Useful Post:
Posts: 84 | Thanked: 245 times | Joined on Jan 2014 @ India
#32
For now, just masking works. Disabling the timer and service do not!
 

The Following 3 Users Say Thank You to lal For This Useful Post:
Posts: 5 | Thanked: 12 times | Joined on Aug 2016
#33
I have executed the commands

[root@Sailfish nemo]#
[root@Sailfish nemo]# systemctl disable sms-activation-intex.timer
[root@Sailfish nemo]#
[root@Sailfish nemo]#
[root@Sailfish nemo]# systemctl mask sms-activation-intex.timer
[root@Sailfish nemo]#



and the status of the process after the commands run are

[root@Sailfish nemo]#
[root@Sailfish nemo]# systemctl --user status sms-activation-intex.timer
sms-activation-intex.timer - Sends an activation SMS after the device has run for 3 hours
Loaded: loaded (/usr/lib/systemd/user/sms-activation-intex.timer; disabled)
Active: active (waiting) since Fri 2016-08-12 17:38:41 IST; 6min ago

[root@Sailfish nemo]# systemctl status sms-activation-intex.timer
sms-activation-intex.timer
Loaded: masked (/dev/null)
Active: inactive (dead)

[root@Sailfish nemo]#


I cannot run the mask command with user as it return the following error


[root@Sailfish nemo]# systemctl --user mask sms-activation-intex.timer
Failed to issue method call: No such file or directory


Please advise
 

The Following User Says Thank You to dillihifi For This Useful Post:
Posts: 20 | Thanked: 75 times | Joined on Jul 2016 @ India
#34
For me both of the commands are working.
You can try to execute the --user while you are non privileged user, as nemo.
 

The Following 2 Users Say Thank You to bhavin192 For This Useful Post:
Posts: 84 | Thanked: 245 times | Joined on Jan 2014 @ India
#35
It worked for me when run as nemo. I just checked it again on my device. You dont have to type devel-su before you execute the mask command as bhavin said.

This will do!
[nemo@Sailfish nemo]$ systemctl --user mask sms-activation-intex.timer
 

The Following User Says Thank You to lal For This Useful Post:
Posts: 5 | Thanked: 12 times | Joined on Aug 2016
#36
Not Working. Pls see below and advise


[nemo@Sailfish ~]$ systemctl --user status sms-activation-intex.timer
sms-activation-intex.timer - Sends an activation SMS after the device has run for 3 hours
Loaded: loaded (/usr/lib/systemd/user/sms-activation-intex.timer; disabled)
Active: active (waiting) since Fri 2016-08-12 17:38:41 IST; 15h ago

[nemo@Sailfish ~]$ systemctl --user mask sms-activation-intex.timer
Failed to issue method call: No such file or directory
[nemo@Sailfish ~]$
[nemo@Sailfish ~]$
[nemo@Sailfish ~]$
[nemo@Sailfish ~]$ systemctl mask sms-activation-intex.timer
Failed to issue method call: Access denied
[nemo@Sailfish ~]$
[nemo@Sailfish ~]$ systemctl --user mask sms-activation-intex.timer
Failed to issue method call: No such file or directory
[nemo@Sailfish ~]$
 

The Following 3 Users Say Thank You to dillihifi For This Useful Post:
Posts: 84 | Thanked: 245 times | Joined on Jan 2014 @ India
#37
That is because the symlink to that timer file has been removed when you disabled the timer before. Enable that first and execute masking again.

Without root
[nemo@Sailfish nemo]$ systemctl --user enable sms-activation-intex.timer
Now you'll see a symlink has been created message. If you check status of timer you'll se it is enabled.
Execute masking now
[nemo@Sailfish nemo]$ systemctl --user mask sms-activation-intex.timer
 

The Following 4 Users Say Thank You to lal For This Useful Post:
Posts: 5 | Thanked: 12 times | Joined on Aug 2016
#38
Worked like a charm. Thanks
 

The Following 2 Users Say Thank You to dillihifi For This Useful Post:
Posts: 26 | Thanked: 70 times | Joined on Jul 2011 @ Germany
#39
Hey folks,

I am a new Aqua Fish user here. I checked if I've got the .sms-activation-intex-done file. Look here:

Code:
[nemo@Sailfish vendor_data]$ ls -al
total 20
drwxrwxr-x 4 root vendor 4096 Feb 25 22:03 .
drwxrwxr-x 8 root system 4096 Jan  1  1970 ..
-rw-r--r-- 1 nemo vendor    0 Feb 25 22:03 .sms-activation-intex-done
drwxr-xr-x 3 root root   4096 May 30  2016 apk
drwx------ 2 root root   4096 Jan  1  1970 lost+found
-rw-r--r-- 1 root root     29 Jan  2  2015 vendor-data.ini
[nemo@Sailfish vendor_data]$ cat .sms-activation-intex-done 
[nemo@Sailfish vendor_data]$
As you can see....it's empty. And as I can see, activation has been done. I hope this helped.
 

The Following 2 Users Say Thank You to Hensch For This Useful Post:
Reply

Tags
activation sms, aqua fish, intex

Thread Tools

 
Forum Jump


All times are GMT. The time now is 02:16.