Thread Tools
Posts: 63 | Thanked: 27 times | Joined on Jul 2011 @ Venezuela
Originally Posted by jonwil View Post
I dont know how to solve the actual reboot loop but what I have done to get my phone to be picked up by the flasher is this:
1.Boot Linux (Gentoo in my case)
2.Start flasher tool, it will say "cant find USB device"
3.Remove battery from phone, ensure phone is 100% powered down
4.Connect USB cable to phone
5.Insert battery

When I did those steps, it booted and the flasher found it no problems.
I tried the method you proposed and still nothing.. I also flashed only the kernel and bootloader but keeps hanging... As @GEONXT said, it might be a damage in boot sector, but surprisingly R&D mode boots OK.
I also tried to enable and diasble R&D after booting, and nothing!
Posts: 187 | Thanked: 213 times | Joined on Apr 2013 @ Poland
I know it is old thread but the topic is up-to-day. After cleaning my room I've found olnd n900 board. Thought it was dead but I decided to give it a try. Mounted it into case, plug the battery in and... It's starts but like it was connected to the charger no lit screen only nokia logo. Than it started booting. did 2 revelations through those five dots we all know. Then turned of. After few seconds turned on again and so, got into boot loop.

Yes I already flashed it, with many different images and so on. No change. flashing was a bit strange cause of this plug out plug in but doable.

Problem still stays, but there is a way to turn on the phone.

Remove battery. Push and hold power button, insert battery. Phone starts and works perfectly.

I really don't care about the shape of my 7th n900 but I'm curious what and why can cause the problem when phone itself can work fine...

Sorry I do care. It could be another saved and fully operational n900.

In addition: When phone is off and I do reboot it through terminal it it boots up normally.

Last edited by Ridd92; 2018-04-25 at 08:02.

Thread Tools

Forum Jump

All times are GMT. The time now is 11:12.